• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

大智慧冲动分笔

钱龙公式 第一股票指标公式网 1年前 (2019-10-05) 25次浏览 0个评论 扫描二维码

大智慧冲动分笔介绍

冲动分笔需大智慧L2数据.用法:鼠标点击排序,枝术指标.冲动分笔指标买差比[分笔成交].
源硕:
委卖价1:=askprice(1);
委买价1:=bidprice(1);
委买量1:=bidvol(1);
委卖量1:=askvol(1);
委卖价2:=askprice(2);
委买价2:=bidprice(2);
委买量2:=bidvol(2);
委卖量2:=askvol(2);
委卖价3:=askprice(3);
委买价3:=bidprice(3);
委买量3:=bidvol(3);
委卖量3:=askvol(3);
BS:=intpart(2000/c+0.5);
NS:=IF(STRFIND(STKNAME,’N’,1),0,1);
涨停:=if(NS>0 and c=dynainfo(54) and 委卖量1=0,1,0);
跌停:=if(NS>0 and c=dynainfo(55) and 委买量1=0,1,0);
非停板:=if(涨停>0 or 跌停>0,0,1);
涨停买:=if(涨停>0,vol,0);
跌停卖:=if(跌停>0,vol,0);
开盘买:=if(BARSTATUS=1 and DYNAINFO(4)>=DYNAINFO(3),vol,0);
开盘卖:=if(BARSTATUS=1 and DYNAINFO(4)<DYNAINFO(3),vol,0);
买上0a:=if(CLOSE=ref(委买价1,1) and 委买价1=ref(委买价1,1) and ref(委买量1,1)>委买量1 and BUYVOL<=(ref(委买量1,1)-委买量1),BUYVOL,0);
明买0a:=if(CLOSE=ref(委买价1,1) and 委买价1=ref(委买价1,1) and ref(委买量1,1)>委买量1 and BUYVOL>(ref(委买量1,1)-委买量1),ref(委买量1,1)-委买量1,0);
隐买0a:=IF(明买0a>0,BUYVOL-明买0a,0);
买上0b:=if(CLOSE>=ref(委买价1,1) and CLOSE<REF(委卖价1,1) and 委买价1>ref(委买价1,1) and BUYVOL<=ref(委买量1,1),BUYVOL,0);
明买0b:=if(CLOSE>=ref(委买价1,1) and CLOSE<REF(委卖价1,1) and 委买价1>ref(委买价1,1) and BUYVOL>ref(委买量1,1),ref(委买量1,1),0);
隐买0b:=IF(明买0b>0,BUYVOL-明买0b,0);
买上1a:=IF(CLOSE=REF(委卖价1,1) and 委卖价1=ref(委卖价1,1) and ref(委卖量1,1)>委卖量1 and BUYVOL<=(ref(委卖量1,1)-委卖量1),BUYVOL,0);
明买1a:=if(CLOSE=ref(委卖价1,1) and 委卖价1=ref(委卖价1,1) and ref(委卖量1,1)>委卖量1 and BUYVOL>(ref(委卖量1,1)-委卖量1),ref(委卖量1,1)-委卖量1,0);
隐买1a:=IF(明买1a>0,BUYVOL-明买1a,0);
买上1b:=IF(CLOSE>=REF(委卖价1,1) and CLOSE<REF(委卖价2,1) and 委卖价1>ref(委卖价1,1) and BUYVOL<=ref(委卖量1,1),BUYVOL,0);
明买1b:=if(CLOSE>=REF(委卖价1,1) and CLOSE<REF(委卖价2,1) and 委卖价1>ref(委卖价1,1) and BUYVOL>ref(委卖量1,1),ref(委卖量1,1),0);
隐买1b:=IF(明买1b>0,BUYVOL-明买1b,0);
买上2a:=IF(CLOSE=REF(委卖价2,1) and 委卖价1=ref(委卖价2,1) and REF(委卖量2,1)>委卖量1 and BUYVOL<=(REF(委卖量1,1)+REF(委卖量2,1)-委卖量1),BUYVOL,0);
明买2a:=IF(CLOSE=REF(委卖价2,1) and 委卖价1=ref(委卖价2,1) and REF(委卖量2,1)>委卖量1 and BUYVOL>(REF(委卖量1,1)+REF(委卖量2,1)-委卖量1),REF(委卖量1,1)+REF(委卖量2,1)-委卖量1,0);
隐买2a:=IF(明买2a>0,BUYVOL-明买2a,0);
买上2b:=IF(CLOSE>=REF(委卖价2,1) AND CLOSE<REF(委卖价3,1) and 委卖价1>ref(委卖价2,1) and BUYVOL<=(REF(委卖量1,1)+REF(委卖量2,1)),BUYVOL,0);
明买2b:=IF(CLOSE>=REF(委卖价2,1) AND CLOSE<REF(委卖价3,1) and 委卖价1>ref(委卖价2,1) and BUYVOL>(REF(委卖量1,1)+REF(委卖量2,1)),REF(委卖量1,1)+REF(委卖量2,1),0);
隐买2b:=IF(明买2b>0,BUYVOL-明买2b,0);
买上3a:=IF(CLOSE=REF(委卖价3,1) and 委卖价1=ref(委卖价3,1) and REF(委卖量3,1)>委卖量1 and BUYVOL<=(REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1)-委卖量1),BUYVOL,0);
明买3a:=IF(CLOSE=REF(委卖价3,1) and 委卖价1=ref(委卖价3,1) and REF(委卖量3,1)>委卖量1 and BUYVOL>(REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1)-委卖量1),REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1)-委卖量1,0);
隐买3a:=IF(明买3a>0,BUYVOL-明买3a,0);
买上3b:=IF(CLOSE=REF(委卖价3,1) and 委卖价1>ref(委卖价3,1) and BUYVOL<=(REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1)),BUYVOL,0);
明买3b:=IF(CLOSE=REF(委卖价3,1) and 委卖价1>ref(委卖价3,1) and BUYVOL>(REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1)),REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1),0);
隐买3b:=IF(明买3b>0,BUYVOL-明买3b,0);
买上4a:=IF(REF(委卖价3,1)>0 AND CLOSE>REF(委卖价3,1) and BUYVOL>(REF(委卖量1,1)+REF(委卖量2,1)+REF(委卖量3,1)),BUYVOL,0);
买上:=买上0a+买上0b+买上1a+买上1b+买上2a+买上2b+买上3a+买上3b+买上4a;
主买:=if(非停板>0,if(买上>0,买上,明买0a+明买0b+明买1a+明买1b+明买2a+明买2b+明买3a+明买3b),0);
隐买:=if(非停板>0,隐买0a+隐买0b+隐买1a+隐买1b+隐买2a+隐买2b+隐买3a+隐买3b,0);
卖下0a:=if(CLOSE=ref(委卖价1,1) and 委卖价1=ref(委卖价1,1) and ref(委卖量1,1)>委卖量1 and SELLVOL<=ref(委卖量1,1)-委卖量1,SELLVOL,0);
明卖0a:=if(CLOSE=ref(委卖价1,1) and 委卖价1=ref(委卖价1,1) and ref(委卖量1,1)>委卖量1 and SELLVOL>ref(委卖量1,1)-委卖量1,ref(委卖量1,1)-委卖量1,0);
隐卖0a:=IF(明卖0a>0,SELLVOL-明卖0a,0);
卖下0b:=if(CLOSE<=ref(委卖价1,1) and CLOSE>ref(委买价1,1) and 委卖价1<ref(委卖价1,1) and SELLVOl<=ref(委卖量1,1),SELLVOl,0);
明卖0b:=if(CLOSE<=ref(委卖价1,1) and CLOSE>ref(委买价1,1) and 委卖价1<ref(委卖价1,1) and SELLVOl>ref(委卖量1,1),ref(委卖量1,1),0);
隐卖0b:=IF(明卖0b>0,SELLVOL-明卖0b,0);
卖下1a:=if(CLOSE=ref(委买价1,1) and 委买价1=ref(委买价1,1) and ref(委买量1,1)>委买量1 and SELLVOl<=ref(委买量1,1)-委买量1,SELLVOl,0);
明卖1a:=if(CLOSE=ref(委买价1,1) and 委买价1=ref(委买价1,1) and ref(委买量1,1)>委买量1 and SELLVOl>ref(委买量1,1)-委买量1,ref(委买量1,1)-委买量1,0);
隐卖1a:=IF(明卖1a>0,SELLVOL-明卖1a,0);
卖下1b:=if(CLOSE<=ref(委买价1,1) and CLOSE>REF(委买价2,1) and 委买价1<ref(委买价1,1) and SELLVOl<=ref(委买量1,1),SELLVOl,0);
明卖1b:=if(CLOSE<=ref(委买价1,1) and CLOSE>REF(委买价2,1) and 委买价1<ref(委买价1,1) and SELLVOl>ref(委买量1,1),ref(委买量1,1),0);
隐卖1b:=IF(明卖1b>0,SELLVOL-明卖1b,0);
卖下2a:=if(CLOSE=ref(委买价2,1) and 委买价1=ref(委买价2,1) and ref(委买量2,1)>委买量1 and SELLVOl<=(ref(委买量1,1)+REF(委买量2,1)-委买量1),SELLVOl,0);
明卖2a:=if(CLOSE=ref(委买价2,1) and 委买价1=ref(委买价2,1) and ref(委买量2,1)>委买量1 and SELLVOl>(ref(委买量1,1)+REF(委买量2,1)-委买量1),ref(委买量1,1)+REF(委买量2,1)-委买量1,0);
隐卖2a:=IF(明卖2a>0,SELLVOL-明卖2a,0);
卖下2b:=if(CLOSE<=ref(委买价2,1) and CLOSE>REF(委买价3,1) and 委买价1<ref(委买价2,1) and SELLVOl<=(ref(委买量1,1)+REF(委买量2,1)),SELLVOl,0);
明卖2b:=if(CLOSE<=ref(委买价2,1) and CLOSE>REF(委买价3,1) and 委买价1<ref(委买价2,1) and SELLVOl>(ref(委买量1,1)+REF(委买量2,1)),ref(委买量1,1)+REF(委买量2,1),0);
隐卖2b:=IF(明卖2b>0,SELLVOL-明卖2b,0);
卖下3a:=if(CLOSE=ref(委买价3,1) and 委买价1=ref(委买价3,1) and ref(委买量3,1)>委买量1 and SELLVOl<=(ref(委买量1,1)+REF(委买量2,1)+REF(委买量3,1)-委买量1),SELLVOl,0);
明卖3a:=if(CLOSE=ref(委买价3,1) and 委买价1=ref(委买价3,1) and ref(委买量3,1)>委买量1 and SELLVOl>(ref(委买量1,1)+REF(委买量2,1)+REF(委买量3,1)-委买量1),ref(委买量1,1)+REF(委买量2,1)+REF(委买量3,1)-委买量1,0);
隐卖3a:=IF(明卖3a>0,SELLVOL-明卖3a,0);
卖下3b:=if(CLOSE=ref(委买价3,1) and 委买价1<ref(委买价3,1) and SELLVOl<=(ref(委买量1,1)+REF(委买量2,1)+REF(委买量3,1)),SELLVOl,0);
明卖3b:=if(CLOSE=ref(委买价3,1) and 委买价1<ref(委买价3,1) and SELLVOl>(ref(委买量1,1)+REF(委买量2,1)+REF(委买量3,1)),ref(委买量1,1)+REF(委买量2,1)+REF(委买量3,1),0);
隐卖3b:=IF(明卖3b>0,SELLVOL-明卖3b,0);
卖下4a:=IF(REF(委买价3,1)>0 and CLOSE<REF(委买价3,1) and SELLVOL>(REF(委买量1,1)+REF(委买量2,1)+REF(委买量3,1)),SELLVOL,0);
卖下:=卖下0a+卖下0b+卖下1a+卖下1b+卖下2a+卖下2b+卖下3a+卖下3b+卖下4a;
主卖:=if(非停板>0,if(卖下>0,卖下,明卖0a+明卖0b+明卖1a+明卖1b+明卖2a+明卖2b+明卖3a+明卖3b),0);
隐卖:=if(非停板>0,隐卖0a+隐卖0b+隐卖1a+隐卖1b+隐卖2a+隐卖2b+隐卖3a+隐卖3b,0);
大开盘买:=if(开盘买>=BS,开盘买,0);
大涨停买:=if(涨停买>=BS,涨停买,0);
大买单:=if(主买>=BS,主买,0);
大隐买:=if(隐买>=BS,隐买,0);
大开盘卖:=if(开盘卖>=BS,开盘卖,0);
大跌停卖:=if(跌停卖>=BS,跌停卖,0);
大卖单:=if(主卖>=BS,主卖,0);
大隐卖:=if(隐卖>=BS,隐卖,0);
主动买单:=大开盘买+大涨停买+大买单+大隐买;
主动卖单:=大开盘卖+大跌停卖+大卖单+大隐卖;
大买量:sum(主动买单,0);
大卖量:sum(主动卖单,0);
买卖差:大买量-大卖量;
买差比:(买卖差/capital)*100;

大智慧冲动分笔


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址