• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

若干大智慧指标集合 无未来、源码

钱龙公式 第一股票指标公式网 1年前 (2019-10-05) 19次浏览 0个评论 扫描二维码

若干大智慧指标集合 无未来源码介绍

发电机源码
{发动机副图}
{背景颜色设定}
DRAWGBKLAST(CLOSE>0,STRIP(RGB(55,75,55),RGB(10,10,20),0));
{原神猴探月公式 将原神猴线改名能量线}
CS:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
YJD:=(EMA(CS,3)-50)*2;
能量线:YJD,precis2;{探测能量动力,很像KDJ公式的J值}
中线:=0;
PARTLINE(YJD,中线);
DRAWTEXT(cross(YJD,中线),0,’●’),COLORred,ALIGN1;{买入点2}
能量线1:=能量线>=0;
能量线2:=能量线<=0;

{原 庄家克星的抄底逃顶公式 将山水线改名抛留线,去掉倒影线}
Var1:=(2*CLOSE+HIGH+LOW)/4;
Var2:=LLV(LOW,5);
Var3:=HHV(HIGH,4);
Var5:=(Var1-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
Var6:=SMA(Var5,2,1);
sK:EMA((Var1-Var2)/(Var3-Var2)*100,4),LINETHICK0,precis2;
sD:EMA(0.667*REF(sK,1)+0.333*sK,2),LINETHICK0,precis2;
sJ:2*sK-1*sD,LINETHICK0,precis2;
sKD差:sK-sD,colorred,LINETHICK0,precis2;
抛留线: SMA(Var6,2,1),COLOR889999,LINESTICK;
金叉:if(CROSS(sK,sD),抛留线,0),colorffffff,LINETHICK2;{买入点}
VERTLINE(CROSS(金叉,0.1),2),COLORffffff;
FILLRGN(0,能量线,能量线1,RGB(255,48,48)),LAYER7;
PARTLINE(抛留线,抛留线>REF(抛留线,1),RGB(255,0,0),抛留线<REF(抛留线,1),RGB(0,250,0)),linethick2;{红留,变绿一定卖}
PARTLINE(能量线,能量线>REF(能量线,1),RGB(255,0,0),能量线<REF(能量线,1),RGB(0,250,0)),linethick1;{绿不进,变红后市可看好}
VERTLINE(CROSS(能量线1,0.1),2),COLOR0000FF;
{淑女萱 一阳穿四线}
DRAWTEXT(CROSS(C,MA(C,5)) AND CROSS(C,MA(C,10)) AND CROSS(C,MA(C,20)) AND CROSS(C,MA(C,30)) and CROSS(MA(V,5),MA(V,10)),-10,’一阳穿四线’),COLORyellow,LINETHICK2;
顶线:80,COLORred;
强势:65,COLORffffff,dotline,precis2;
中线:0,COLORffffff,dotline,precis2;
均线:-65,COLORred,dotline,precis2;
底线:-80,COLORgreen;
DRAWTEXT(DISPSTATUS=2,顶线,’ 80 顶线’),COLORred,ALIGN0;
DRAWTEXT(DISPSTATUS=2,强势,’ 65 强势’),COLORffffff,ALIGN0;
DRAWTEXT(DISPSTATUS=2,中线,’ 00 中线’),COLOR00FFFF,ALIGN0;
DRAWTEXT(DISPSTATUS=2,均线,’ 均线提示’),COLORffffff,ALIGN0;
DRAWTEXT(DISPSTATUS=2,底线,’ -80 底线’),COLORgreen,ALIGN0;

{庄家克星 神奇均线主图}
Var10:=(2*CLOSE+HIGH+LOW+OPEN)/5;
A1: (EMA(Var1,3)+EMA(Var1,6)+EMA(Var1,12)+EMA(Var1,24))/4;
A2: EMA(A1,2),linethick0;
A3: EMA(A2,2),linethick0;
A4: EMA(A3,2),linethick0;
A5: EMA(A4,2),linethick0;
A6: EMA(A5,2),linethick0;
A7: EMA(A6,2),linethick0;
A8: EMA(Var1,2.78)*1.028,colorffffff,linethick0;
A9: MA(OPEN,3.2)*1.028,colorgreen,linethick0;
短线:=A8;
中线:=A9;
DRAWTEXT(cross(短线,中线),-65,’进’),COLORred,ALIGN1;
DRAWTEXT(cross(中线,短线),-65,’退’),COLORgreen,ALIGN1;

若干大智慧指标集合 无未来、源码

{趋势吸庄}

{趋势跟踪—-创幻论坛一品茶缘编写,大智慧L2版本副图指标}
{【趋势跟踪】指标使用说明:
趋势为王守铁律,顺势而为主升期;
临界出现防风险,挖坑不涨早休息!}

MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:(A1+A2+A3+A4+A5+A6)/6*100,Color00FF00;
主升浪:趋势>=50,COLOR0000FF,POINTDOT,LINETHICK0;
↓:趋势<50,COLORFFFFFF,POINTDOT,LINETHICK0;
周期:IF(主升浪,BARSLAST(CROSS(主升浪,0.1))+1,0),COLORFF00FF,POINTDOT,LINETHICK0;
临界:IF(CROSS(98,趋势),1,0),COLOR00FF00,POINTDOT,LINETHICK0;
WKQY:=BARSLAST(CROSS(50,趋势))<MIN(BARSLAST(CROSS(趋势,1)),BARSLAST(CROSS(趋势,-1)));
挖坑:BETWEEN(趋势,-1,50) and WKQY,COLOR00FFFF,POINTDOT,LINETHICK0;
{以下设置副图显示方式}
FILLRGN(50,趋势,主升浪,RGB(250,0,0)),LAYER7;
FILLRGN(50,趋势,挖坑,RGB(250,250,0)),LAYER7;
STICKLINE(主升浪,周期*0.8,周期*0.95,6,0),COLOR0000FF;
STICKLINE(主升浪,周期*1.05,周期*1.2,6,0),COLOR0000FF;
STICKLINE(主升浪 AND C<REF(C,1),周期*0.9,周期*1.1,6,1),COLORFFFFFF;
VERTLINE(CROSS(主升浪,0.1),2),COLOR0000FF;
DRAWTEXT(临界,100,’☆’),COLOR00FF00,ALIGN1;
0,COLORFFFFFF;50,COLOR00FFFF,DOTLINE;
{以下设置文字提示部分}
DRAWTEXTREL(10,620,’股票名称:’+’【’+STKLABEL+’ ‘+STKNAME+’】’),COLORFFFFFF;
DRAWTEXTREL(10,800,’== ● 趋势为王.顺势而为 ● ==’),COLOR0000FF;
DRAWTEXTREL(200,800,’ == ■ 只做主升,挖坑低吸 ■ ==’),COLOR00FFFF;
DRAWTEXTREL(400,800,’ == ☆ 临界不涨,逢高离场 ☆ ==’),COLORgreen;

N:=5;
VAR1:4*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1),3.2,1),COLORYELLOW,LINETHICK0;
VAR2:8,COLORGREEN,LINETHICK0;
上升: IF(CROSS(VAR1,VAR2),100,0),STICK,COLORffffff,LINETHICK2;
低吸: IF(VAR1<=8,25,0),STICK,COLORffffff,LINETHICK2;
DRAWTEXT(CROSS(VAR1,VAR2),80,’上升’),COLORffffff;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
建仓: IF((VARO7<10),50,0) ,COLORffffff,LINETHICK1;

若干大智慧指标集合 无未来、源码


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址