• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

长短通道主图

钱龙公式 第一股票指标公式网 1年前 (2019-10-05) 20次浏览 0个评论 扫描二维码

长短通道主图介绍

{D通}
XDC:=DMA(C,VOL/MA(V,21));
回调认同:=EMA(EXPMA(XDC,20),13),CROSSDOT,LINETHICK1,COLORRED;

{天狼剑部分}
B1:=MA(C,1);
B2:=SMA(SMA(SMA(B1,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损:IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);

LY:=10;BL:=40;
CJQS:=XMA(CLOSE,LY);
JBQS:=XMA(CLOSE,BL);
N:=REF(JBQS,BL/2+1-CURRBARSCOUNT)/REF(JBQS,BL/2+2-CURRBARSCOUNT);
M:=REF(CJQS,LY/2+1-CURRBARSCOUNT)/REF(CJQS,LY/2+2-CURRBARSCOUNT);
上:IF(CURRBARSCOUNT>BL/2,JBQS*1.1,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*1.1);
下:IF(CURRBARSCOUNT>BL/2,JBQS*0.9,REF(JBQS,BL/2+1-CURRBARSCOUNT)*POW(N,BL/2+1-CURRBARSCOUNT)*0.9);
Z上:IF(CURRBARSCOUNT>LY/2,CJQS*1.05,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*1.05)COLORLIBLUE;
Z下:IF(CURRBARSCOUNT>LY/2,CJQS*0.95,REF(CJQS,LY/2+1-CURRBARSCOUNT)*POW(M,LY/2+1-CURRBARSCOUNT)*0.95);
{DRAWTEXT(L<=Z下,(L * 0.998),’抢’),COLORYELLOW;}
DRAWTEXT(CROSS(H,Z上),(H * 1.01),’砸’),COLORYELLOW;

X上:IF(CURRBARSCOUNT>LY/2,CJQS*1.02,REF(CJQS,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*1.02)COLORLIMAGENTA;
X下:IF(CURRBARSCOUNT>LY/2,CJQS*0.98,REF(CJQS,LY/2+1-CURRBARSCOUNT)
*POW(M,LY/2+1-CURRBARSCOUNT)*0.98)COLORLIMAGENTA;

VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
VAR11A:=(CLOSE*2+HIGH+LOW)/4;
VAR21A:=EMA(VAR11A,13)-EMA(VAR11A,34);
VAR31A:=EMA(VAR21A,5);

VAR2:=((CLOSE > REF(CLOSE,1)) AND (CLOSE > REF(CLOSE,2)));
VAR3:=((REF(VAR2,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR4:=((REF(VAR3,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR5:=((REF(VAR4,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR6:=((REF(VAR5,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR7:=((REF(VAR6,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR8:=((REF(VAR7,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR9:=((REF(VAR8,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARA:=((REF(VAR9,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARB:=((REF(VARA,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARC:=((REF(VARB,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VARD:=((REF(VARC,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VARE:=((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,2)));
VARF:=((REF(VARE,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR10:=((REF(VARF,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR11:=((REF(VAR10,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR12:=((REF(VAR11,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR13:=((REF(VAR12,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR14:=((REF(VAR13,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR15:=((REF(VAR14,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR16:=((REF(VAR15,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR17:=((REF(VAR16,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR18:=((REF(VAR17,1) AND (CLOSE <= REF(CLOSE,1))) AND (CLOSE >= REF(CLOSE,2)));
VAR19:=((REF(VAR18,1) AND (CLOSE >= REF(CLOSE,1))) AND (CLOSE <= REF(CLOSE,2)));
VAR1B:=(REF((((((((((((VARE OR VARF) OR VAR10) OR VAR11) OR VAR12) OR
VAR13) OR VAR14) OR VAR15) OR VAR16) OR VAR17) OR VAR18) OR VAR19),1)
AND VAR2);
{}
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR10FFFF;
STICKLINE(VAR1B,O,O+(C-O)/3,1,0),COLOR00FFFF;
AA:=(REF((((((((((((VAR2 OR VAR3) OR VAR4) OR VAR5) OR VAR6) OR VAR7) OR VAR8) OR VAR9) OR VARA) OR VARB) OR VARC) OR VARD),1) AND VARE);

STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00EE00;
STICKLINE(AA,O,O+(C-O)/3,1,0),COLOR00FF00;
IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK2;
IF(B2<SMA2,B2,DRAWNULL),COLORGREEN,LINETHICK1;
LP:=H>=X下 AND H>=B2 AND L<=X下 AND L<=B2 ;
DRAWICON(LP=1,Z下,25);
{DRAWTEXT(L-Z下<=0.10 AND L>=Z下,(L * 0.998),’B’),COLORYELLOW;}

险:=(( O>=Z上 AND H>REF(H,1)));
DRAWTEXT(险,H*1.01,’卖’);
机:=((L<=Z下 AND C>=REF(L,1)));
DRAWTEXT(H>=Z上 AND AA ,H*1.01,’逃’);
DRAWICON(H>=Z上 AND AA ,( HIGH*1.01),2) ,COLORBLUE;
STICKLINE(机,OPEN,CLOSE,1,0),COLORMAGENTA;

XS:=MA(LOW,5)*(1-5/100),LINETHICK0;
XS1:=MA(HIGH,5)*(1+5/100);
DRAWTEXT(CROSS(XS1,C),H*1.01,’砸’),COLORWHITE;

LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE – LC),0),5,1) / SMA(ABS((CLOSE – LC)),5,1)) * 100);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
TR1:=SUM(MAX(MAX((HIGH – LOW),ABS((HIGH – REF(CLOSE,1)))),ABS((LOW – REF(CLOSE,1)))),10);
HD:=(HIGH – REF(HIGH,1));
LD:=(REF(LOW,1) – LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI – PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) – CLOSE)) / (HHV(HIGH,10) – LLV(LOW,10)));
NEWVOL:=(RSI5 – WR10);
秋天梦想:=(AV + NEWVOL);
{DRAWTEXT(CROSS(秋天梦想,0),L*0.97,’秋天’),COLORFF00FF;}
DRAWICON(CROSS(秋天梦想,0),L*0.98,1);
DRAWTEXT(CROSS(82,VARR1),H*1.005,’回家种田’),COLORBLUE;

{快赢}
T:=CLOSE*1.0+LOW*0.0+HIGH*0.0;
SL:=(T/REF(T,1)-1)*1000;
X:=XMA(XMA(XMA(SL,3),3),3)-XMA(XMA(XMA(SL,5),5),5);
中期趋势:=XMA(XMA(XMA(SL,7),7),7),LINETHICK2,COLORGREEN;
长期趋势:=XMA(XMA(XMA(SL,21),21),21),LINETHICK2,COLORBLUE;
DRAWICON(CROSS(中期趋势,长期趋势),L*0.98,13);
DRAWICON(CROSS(长期趋势,中期趋势),H*1.01,14);
DRAWICON(CROSS(X,长期趋势) AND 中期趋势>=长期趋势,L*0.97,11);
DRAWICON(CROSS(长期趋势,0),L*0.98,26);
DRAWICON(CROSS(0,长期趋势),L*0.98,27);

这个指标大部分来自本论坛以前的老师发的指标,包括通道买卖(类似薛式通道)——主图,快赢线——副图,天狼剑——主图等。
天狼剑主图我感觉不错,这里只用了的它精华的两条线,快赢线比较飘,但作为参照,还是不错的。通道上,下——是大趋势,Z上,Z下是波段,X上,X下(Z=中,X=小)是用在60分钟做波段用。

长短通道主图


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址