• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

彩带表示的macd 背离一目了然

钱龙公式 第一股票指标公式网 1年前 (2019-10-05) 26次浏览 0个评论 扫描二维码

彩带表示的macd 背离一目了然介绍

W:=1;
M:=1;
MM:=9*M;
SHORT:=MM*4/3;
LONG:=MM*26/9;
DIFF:=(EMA(CLOSE,SHORT)-EMA(CLOSE,LONG));
DEA:=EMA(DIFF,MM),COLOR58FF58;
MACD:=2*(DIFF-DEA),COLORFFFF00,LINETHICK0;
红柱:DRAWBAND(MACD,RGB(180,50,50),0,RGB(0,128,0));
绿柱:DRAWBAND(0,RGB(0,128,0),MACD,RGB(180,50,50));
AMACD:=ABS(MACD);
{STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0,MACD,W,1),COLOR6058FF;
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),0,MACD,W,0),COLOR6058FF;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),0,MACD,W,1),COLORFFFF00;
STICKLINE(MACD<0 AND MACD< REF(MACD,1),0,MACD,W,0),COLORFFFF00;}

红柱面积 := IF (MACD>0,SUM(AMACD,BARSLAST(MACD<0)),0),LINETHICK0,COLORRED;
绿柱面积 := IF (MACD<0,SUM(AMACD,BARSLAST(MACD>0)),0),LINETHICK0,COLORBLUE;

BV:=SUM(MACD,0);
红转绿:=CROSS(MACD,0);
绿转红:=CROSS(0,MACD);
BC:=BARSLAST(红转绿 OR 绿转红)+1;
最高红柱子:IF(MACD>0,HHV(MACD,BC),0),NODRAW;
最低绿柱子:IF(MACD<0,LLV(MACD,BC),0),NODRAW;

DRAWTEXT(绿转红 ,REF(最高红柱子,1),”+REF(INTPART((红柱面积)*10)/10,1)),COLORRED;
DRAWTEXT(红转绿 ,REF(最低绿柱子,1),”+REF(INTPART((绿柱面积)*10)/10,1)),COLORRED;
CDIFF:DIFF;CDEA:DEA;

彩带表示的macd 背离一目了然


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址