• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

自用经典【MACD】副图指标

钱龙公式 第一股票指标公式网 1年前 (2019-10-05) 48次浏览 0个评论 扫描二维码

自用经典【MACD】副图指标介绍

本人自用经典【MACD】副图指标与友友们分享,直接上源码。此指标的核心部分是【见凌见】老师的独创,俺喜欢的很(⊙o⊙)哦 ,本人只是修改了参数,组合添加了一些东东而已。其中红色柱线代表了主升浪,黄色柱线为短线底,深蓝柱线代表高位面临风线,绿色柱线则是代表数柱子买入法,(此方法是指:当MACD从远离0轴的高位死叉下来,一般来说,当产生第4-5根绿柱的时候,同时K线走出下跌抵抗性的K线,那么就是抢反弹的好时机。极限一般不超过第六根绿柱。数柱子买入法,是指双线离0轴较远距离高空死叉后第4-5根,极限第6根的买入法)。有些牛股,会再第二根就结束调整。第二根绿柱产生下跌抵抗形K线,也是良好介入点位。要注意观察该股的个性)。
总结了MACD的五大特点:
A:当DIF和DEA双线同时上穿0轴时,则预示着股价将形成一波向上的中期运动行情。
B:当MACD形成金叉时要明白;所有的在0轴下金叉都可视为反弹,只有在0轴上的金叉才是真正的拉升行情。其中;金叉位置离0轴越近,则形成向上的行情就越明显,爆发力就会越大。
C:股价在上升趋势时,MACD在0轴上形成的第一次金叉特性表现为;*在日线上,为短期快速上涨的起点(短线)。*在周线上,则为主升三浪拉升确认标志(中线)。
小技巧:***如果MACD在0轴上第一次金叉点和第一次死叉点相隔距离在13天以内(包括13天)的话,最容易形成暴涨行情。(数绿柱)
***如何逢低介入主升三浪拉升的股票?首先在日线中找到三浪拉升的股票,其次要在周线上观察MACD双线是否形成了在0轴之上的金叉(关键点),则是及时逢低买入升三浪拉升股升三浪拉升股票的重要条件。
D: ***当MACD与股票价格底背离时,就预示着其股价正处于低位建仓时期,可等待金叉买入。(所谓底背离是指:股价下跌,但MACD的两个金叉点却是依次抬高的。如连续出现两次底背离时就是大底)
***当MACD与股票价格顶背离时,就预示着其股价正处于高位派发时期,可等待死叉卖出。(所谓顶背离是指:股价上涨,但MACD的两个死叉点却是依次降低的。如连续出现两次顶背离时就是大顶)。
E:对于连续涨停的个股(必须是连续两个涨停板以上的),当红色柱线由长缩短时,说明股价上涨乏力,要随时等待卖出,以获得利润最大化。

源码如下:
DRAWGBKLAST(C>0,STRIP(RGB(145,145,185),RGB(140,140,180),1));
N1:=10; N2:=22; M:=7.5;
DIF:(EMA(C,N1)-EMA(C,N2))/(1+EMA(ABS(C),512))*7.5,COLOR0000FF;
DEA:EMA(DIF,M),COLOR09FFFF;
MACD:=2*(DIF-DEA),COLORSTICK;
PARTLINE(DIF,DIF>=REF(DIF,1),RGB(250,0,0),DIF<REF(DIF,1),RGB(0,0,250)),linethick1;
均衡:SMA(DIF,4,2),Color00FF00,LINETHICK1;
随行:IF(MACD< 0,MACD,0),ColorFFFFFF,LINETHICK1;
D2:=MACD;
STICKLINE(D2<REF(D2,1)AND D2>0,0,D2,5,0),Color979700;
STICKLINE(D2<REF(D2,1)AND D2>0,0,D2,4,0),ColorB5B500;
STICKLINE(D2<REF(D2,1)AND D2>0,0,D2,3,0),ColorD2D200;//兰
STICKLINE(D2<REF(D2,1)AND D2<0,0,D2,5,0),Color974B00;
STICKLINE(D2<REF(D2,1)AND D2<0,0,D2,4,0),ColorB55A00;
STICKLINE(D2<REF(D2,1)AND D2<0,0,D2,3,0),ColorD26900;//蓝
STICKLINE(D2>REF(D2,1)AND D2,0,D2,5,0),Color97004B;
STICKLINE(D2>REF(D2,1)AND D2,0,D2,4,0),ColorB5005A;
STICKLINE(D2>REF(D2,1)AND D2,0,D2,3,0),ColorD20069;//紫
STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,5,0),Color970097;
STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,4,0),ColorB500B5;
STICKLINE(D2>REF(D2,1)AND D2>0,0,D2,3,0),ColorD200D2;//粉
VAR1:=(EMA(C,N1)-REF(EMA(C,N1),1))/REF(EMA(C,N1),1);
VAR2:=(EMA(C,N2)-REF(EMA(C,N2),1))/REF(EMA(C,N2),1);
STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,5,1),COLOR000066;
STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,4,1),COLOR000077;
STICKLINE(VAR1>=VAR2 AND VAR2>0 AND C>EMA(C,N2),0,MACD,3,1),COLOR000099;
A:=MACD>0;
绿柱数:=BARSLAST(A)=5;
STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,5,0),COLOR00AA00;
STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,4,0),COLOR00CC00;
STICKLINE(绿柱数>REF(D2,1)AND 绿柱数>=0,0,D2,3,0),COLOR00EE00;//绿柱
OSC:=100*(CLOSE-MA(CLOSE,11.5));
MAOSC:=EMA(OSC,4.5);
STICKLINE(MACD<REF(MACD,1)AND CROSS(MAOSC,OSC),0,MACD,5,0),COLORFF0000;
STICKLINE(MACD>REF(MACD,1)AND CROSS(OSC,MAOSC),0,MACD,5,0),COLOR09FFFF;

自用经典【MACD】副图指标


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址