• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

主图变色线

钱龙公式 第一股票指标公式网 1年前 (2019-10-06) 38次浏览 0个评论 扫描二维码

主图变色线介绍

基本说明:主图均线
适用范围:个股/指数(均可)
指标位置:通达信主图
注意事项:1.由于线的颜色使用了黑色,所以如果主图背景是黑色的将会看不到,需用改一下指标颜色或者背景颜色(因为我一直用灰色背景,黑色是我常用色)

指标解析:
此线的本源位置是平滑的13日均线。我一直都不太在意均线的使用,一般我放在主图中的都是作为装饰。而13日均线是我唯一使用的、判断短期走势强弱一条均线。

这条线的颜色设置则是3种不同公式的MACD,颜色的不同代表MACD所处位置及方向不同。
以0轴和最高最低点的转折为变色关键点位
突破0轴且向上走—为红色
从最高点转折向下—为绿色
持续向下突破0轴—为黑色
从最低点转折向上—为白色
颜色设置合乎原理:红买绿卖,黑色下跌趋势确认,白色观察准备买入
为啥是三条线的说明:3条线分别是不同代码快慢不同的MACD,最下面的最快但是变化频繁,最上面的最慢(传统MACD)
其实我也考虑了3条线是否显得复杂麻烦,但是由于快慢节奏不同,极具参考意义,只好忍了,如果觉得影像美观也可以去掉,每条线由4段显示代码组成,我在代码中注释了“快”“中”“慢”,去掉任何一部分都不影响使用。

VAR1:=HIGH-REF(HIGH,1);
VAR2:=REF(LOW,1)-LOW;
VAR3:=EMA(IF(VAR1>0 AND VAR1>VAR2,VAR1,0),21);
VAR4:=EMA(IF(VAR2>0 AND VAR2>VAR1,VAR2,0),21);
VAR5:=VAR3*100/TR;
VAR6:=VAR4*100/TR;
VAR7:=EMA((VAR5-VAR6)/(VAR6+VAR5)*100,6)*2;
VAR8:=EMA(VAR7,6);
VAR9:=EMA(VAR7,20);
VAR10:=(VAR7-2*VAR9+VAR8)/2;
VAR11:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
VAR12:=EMA(VAR11,9);
VAR13:=(VAR11-VAR12)*2;
VAR14:=EMA(CLOSE,12)-EMA(CLOSE,26);
VAR15:=EMA(VAR14,9);
VAR16:=(VAR14-VAR15)*2;
VAR17:=MA(C,13);
VAR18:=SMA(VAR17,3,1);
{慢}
IF(VAR10>=0,VAR18,DRAWNULL),COLORRED;
IF(VAR10>=0 AND VAR10<=REF(VAR10,1),VAR18,DRAWNULL),COLORGREEN;
IF(VAR10<0,VAR18,DRAWNULL),COLORBLACK;
IF(VAR10<0 AND VAR10>=REF(VAR10,1),VAR18,DRAWNULL),COLORWHITE;
{中}
IF(VAR16>=0,VAR18*0.997,DRAWNULL),COLORRED;
IF(VAR16>=0 AND VAR16<=REF(VAR16,1),VAR18*0.997,DRAWNULL),COLORGREEN;
IF(VAR16<0,VAR18*0.997,DRAWNULL),COLORBLACK;
IF(VAR16<0 AND VAR16>=REF(VAR16,1),VAR18*0.997,DRAWNULL),COLORWHITE;
{快}
IF(VAR13>=0,VAR18*0.995,DRAWNULL),COLORRED;
IF(VAR13>=0 AND VAR13<=REF(VAR13,1),VAR18*0.995,DRAWNULL),COLORGREEN;
IF(VAR13<0,VAR18*0.995,DRAWNULL),COLORBLACK;
IF(VAR13<0 AND VAR13>=REF(VAR13,1),VAR18*0.995,DRAWNULL),COLORWHITE;

主图变色线


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址