• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

《黑马系列》指标模版之黑马顶底副图(源码,贴图,无未来)

钱龙公式 第一股票指标公式网 1年前 (2019-10-06) 24次浏览 0个评论 扫描二维码

《黑马系列》指标模版之黑马顶底副图(源码,贴图,无未来)介绍

结合网上论坛的主副图指标,把几个指标组合了一下,自己用的,感觉很不错,发上来供大家参考。指标里面有个股K线当天支撑位和压力位
源码:
{黑马顶底}

A0:=HHV(H,9)-LLV(L,9);
A1:=HHV(H,9)-C;
A2:=C-LLV(L,9);
A3:= A1/A0*100-70;
A4:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100;
A5:=(2*C+H+L)/4;
A6:=SMA(A2/A0*100,3,1);
A7:=LLV(L,34);
A8:=SMA(A6,3,1)-SMA(A3,9,1);
A9:=IF(A8>100,A8-100,0);
AA:=HHV(H,34);
AB:=A9*2;
AC:=EMA((A5-A7) / (AA-A7)*100,13);
AD:= EMA(0.667*REF(AC,1)+0.333*AC,2);
AE:=SMA(A4,20,1);
AF:=SMA(AB,2,1)-AB;
B0:=EMA(0.667*REF(AC,1)+0.333*AC,2)-AC;
B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,3,1)+100;
B6:=B5-B2;
B7:=IF(B6>60,B6-60,0);
STICKLINE(REF(B7,1)<B7,B7,REF(B7,1),5,0),COLORRED;
STICKLINE(REF(B7,1)>B7,B7,REF(B7,1),5,0),COLORFFFF00;
主力:EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2),LINETHICK2,COLORRED;
散户:EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7),LINETHICK2,COLORWHITE;
DRAWTEXT(CROSS(主力,散户) AND 主力<-10,-20,’升’),COLORYELLOW;
DRAWICON(CROSS(主力,散户) AND 主力<-10 AND 散户>REF(散户,1)OR CROSS(主力,散户) AND 散户<-35 ,-15,1);
加速探底:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,40,0.85),COLORYELLOW;
机会来临1:REF(IF(REF(C,1)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,40,0),1),COLOR9999FF;
A11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A11,5);
A21:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A31:=EMA(C,5);
A41:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A41,6,1)-2*SMA(SMA(A41,5,1),5,1),2));
A51:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A21<0,7),黑马线,’跑’),COLOR00FF00;
DRAWTEXT(CROSS(A11,黑马线)AND 黑马线<A51,黑马线,’黑马’),COLORYELLOW;
DRAWTEXT(CROSS(黑马线,A51)AND 趋势线<80,黑马线,’追涨’),COLOR688EC1;
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,’大黑马’),COLORFFFF00;
底部:=(A21<-10 AND A21>REF(A21,1))*25;
DRAWICON(底部 AND A31>REF(A31,1),25,1);
机会来临2:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,65,0),1),COLORF00FF0;

《黑马系列》指标模版之黑马顶底副图(源码,贴图,无未来)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址