• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

RSI划线(副图、源码、贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-06) 32次浏览 0个评论 扫描二维码

RSI划线(副图源码贴图)介绍

LC :=REF(CLOSE,1);
RSI1:SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100-100,COLORFFFFFF;
RSI2:SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100-100,COLOR00FFFF;
RSI3:SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100-100,COLORGREEN;
GC:=(RSI1+2*RSI2+3*RSI3)/6+50;
:CD:=EMA(GC,3);
GMCD:=:CD-50;
GMCDA:=if(:CD<ref(:CD,1)and :CD>0,1,0);
GMCDB:=IF(:CD>=ref(:CD,1)and :CD>0,1,0);
GMCDC:=IF(:CD>ref(:CD,1)and :CD<0,1,0);
GMCDD:=IF(:CD<=ref(:CD,1)and :CD<0,1,0);
STICKLINE(GMCDA=1,-50,GMCD,6,0),COLOR00AAFF;{黄色段}
STICKLINE(GMCDA=1,-50,GMCD,6.6,0),COLOR00BBFF;
STICKLINE(GMCDA=1,-50,GMCD,4.4,0),COLOR00CCFF;
STICKLINE(GMCDA=1,-50,GMCD,3.3,0),COLOR00DDFF;
STICKLINE(GMCDA=1,-50,GMCD,2.2,0),COLOR00EEFF;
STICKLINE(GMCDA=1,-50,GMCD,1.1,0),COLOR00FFFF;
STICKLINE(GMCDB=1,-50,GMCD,6,0),COLOR0000AA; {红色段}
STICKLINE(GMCDB=1,-50,GMCD,6.6,0),COLOR0011BB;
STICKLINE(GMCDB=1,-50,GMCD,4.4,0),COLOr0022CC;
STICKLINE(GMCDB=1,-50,GMCD,3.3,0),COLOR0033DD;
STICKLINE(GMCDB=1,-50,GMCD,2.2,0),COLOR0044EE;
STICKLINE(GMCDB=1,-50,GMCD,1.1,0),COLOR0055FF;
STICKLINE(GMCDC=1,-50,GMCD,6,0),COLORAA00BB;{向上粉红}
STICKLINE(GMCDC=1,-50,GMCD,6.6,0),COLORBB11BB;
STICKLINE(GMCDC=1,-50,GMCD,4.4,0),COLORCC22BB;
STICKLINE(GMCDC=1,-50,GMCD,3.3,0),COLORDD33BB;
STICKLINE(GMCDC=1,-50,GMCD,2.2,0),COLOREE44BB;
STICKLINE(GMCDC=1,-50,GMCD,1.1,0),COLORFF55BB;
STICKLINE(GMCDD=1,-50,GMCD,6,0),COLORFF7700;
STICKLINE(GMCDD=1,-50,GMCD,6.6,0),COLORFF8811;
STICKLINE(GMCDD=1,-50,GMCD,4.4,0),COLORFFAA22;
STICKLINE(GMCDD=1,-50,GMCD,3.3,0),COLORFFBB33;
STICKLINE(GMCDD=1,-50,GMCD,2.2,0),COLORFFDD44;
STICKLINE(GMCDD=1,-50,GMCD,1.1,0),COLORFFFF55;
TY:=RSI1;
AA:=REF(TY,3)=HHV(TY,2*3+1);
BB:=BACKSET(AA,3+1);
CC:=FILTER(BB,3) AND TY=HHV(TY,3+1);
AA2:=REF(TY,3)=LLV(TY,2*3+1);
BB2:=BACKSET(AA2,3+1);
CC2:=FILTER(BB2,3) AND TY=LLV(TY,3+1);
GG:=BARSTATUS=2 AND REF(CC,BARSLAST(CC));
HH:=BACKSET(GG,BARSLAST(CC)+1);
II:=HH>REF(HH,1);
JJ:=REF(BARSLAST(CC),1);
KK:=BACKSET(II,JJ+2);
LL:=KK>REF(KK,1);
DRAWLINE(LL,TY,II,TY,1),POINTDOT,COLORMAGENTA;
CS:=(REF(TY,BARSLAST(II))-REF(TY,BARSLAST(LL)))/(BARSLAST(LL)-BARSLAST(II));
阻力线:=REF(TY,BARSLAST(II))+BARSLAST(II)*CS;
阻力值:阻力线,LINETHICK0;
GG2:=BARSTATUS=2 AND REF(CC2,BARSLAST(CC2));
HH2:=BACKSET(GG2,BARSLAST(CC2)+1);
II2:=HH2>REF(HH2,1);
JJ2:=REF(BARSLAST(CC2),1);
KK2:=BACKSET(II2,JJ2+2);
LL2:=KK2>REF(KK2,1);
DRAWLINE(LL2,TY,II2,TY,1),POINTDOT,COLORGREEN;
阻力线:=REF(TY,BARSLAST(II))+BARSLAST(II)*CS;
DRAWICON(CROSS(TY,阻力线),RSI1*0.8,6);{上涨阻力降低三角符}
DRAWICON(CC2,RSI1*0.96,8);{下三角形}
DRAWICON(CC,RSI1*0.6,5);{上三角形}

RSI划线(副图、源码、贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址