• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

RSI自动画线源码(TDX-副图,源码,贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-07) 35次浏览 0个评论 扫描二维码

RSI自动画线源码(TDX-副图,源码,贴图)介绍

最好配合成交量来使用效果更佳。
源码:
HIGHN:=5;
LC :=REF(C,1);
RSI1:SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100,COLORRED,LINETHICK1;
LOWN:=HIGHN;
AA:=REF(RSI1,HIGHN)=HHV(RSI1,2*HIGHN+1);
QY:=BACKSET(AA,HIGHN+1);
CC:=FILTER(QY,HIGHN) AND RSI1=HHV(RSI1,HIGHN+1);
DRAWICON(CC,RSI1*1.02,2);
DDD:=BARSLAST(CC);
GDTS:=IF(CC,CURRBARSCOUNT,0);
DINGBU:=IF(DDD,REF(RSI1,DDD),RSI1);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
DINGBU1:=REF(DINGBU,DDD+1);
GDCS1:=CONST(DINGBUTS);
DINGBUTS1:=REF(DINGBUTS,DDD+1);
GDCS2:=CONST(DINGBUTS1);
DINGBU2:=REF(DINGBU1,DDD+1);
MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,RSI1,CURRBARSCOUNT=GDCS1,RSI1,1) COLORGREEN,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=GDCS2,RSI1,ISLASTBAR,REF(RSI1,GDCS2-1),1),COLORBLUE;
DRAWLINE(CURRBARSCOUNT=GDCS1,RSI1,ISLASTBAR,REF(RSI1,GDCS1-1),1),COLORCYAN;
AA1:=REF(RSI1,LOWN)=LLV(RSI1,2*LOWN+1);
QY1:=BACKSET(AA1,LOWN+1);
CC1:=FILTER(QY1,LOWN) AND RSI1=LLV(RSI1,LOWN+1);
介入:DRAWICON(CC1,RSI1*0.98,1);
DD1:=BARSLAST(CC1);
DDTS:=IF(CC1,CURRBARSCOUNT,0);
YDB:=IF(DD1,REF(RSI1,DD1),RSI1);
DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
DDCS1:=CONST(DDTS1);
ZDB:=REF(YDB,DD1+1);
DDTS2:=REF(DDTS1,DD1+1);
DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,RSI1,CURRBARSCOUNT=DDCS1,RSI1,1) COLORRED,LINETHICK1;
DRAWLINE(CURRBARSCOUNT=DDCS1,RSI1,ISLASTBAR,REF(RSI1,DDCS1-1),1),COLORMAGENTA;
DRAWLINE(CURRBARSCOUNT=DDCS2,RSI1,ISLASTBAR,REF(RSI1,DDCS2-1),1),COLORYELLOW;
80;
20;
顺便发2张图与大家分享:

RSI自动画线源码(TDX-副图,源码,贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址