• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

自用指标,判断超跌顶底的指标(副图,源码,贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-07) 29次浏览 0个评论 扫描二维码

自用指标,判断超跌顶底的指标(副图,源码,贴图)介绍

通过CCI指标判断,定义CCI超过150为短线顶部,跌破-150为超跌,数值可以根据自己的理解设置!
配合松班的主图,效果更佳!指标是站在前人的基础上,根据自己的需要做了一些修改,比较适合自己的操作!
源码如下:
VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
VARE:=LLV(LOW,30);
VARF:=HHV(VARD,30);
VAR10:=IF(MA(CLOSE,58),1,0);
快枪:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR10,COLORSTICK;
STICKLINE(快枪>0,0 ,快枪*1.2,2,0 ),COLOR00EEFF;
STICKLINE(快枪>0,0 ,快枪*0.8,2,0 ),COLOR00BBFF;
STICKLINE(快枪>0,0 ,快枪*0.6,2,0 ),COLOR0099FF;
STICKLINE(快枪>0,0 ,快枪*0.4,2,0 ),COLOR0066FF;
STICKLINE(快枪>0,0 ,快枪*0.2,2,0 ),COLOR0000FF;
TYP:=(HIGH+LOW+CLOSE)/3;
CCI20:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N));
{CCI84:(TYP-MA(TYP,M))/(0.015*AVEDEV(TYP,M));}

超跌:-175,CIRCLEDOT,COLORGREEN;
STICKLINE(CCI20<=-175,-175,-200,2,0),COLORBLUE;

顶部:150,CIRCLEDOT,COLORRED;
STICKLINE(CCI20>=150,150,200,2,0),COLORGREEN;

买入:-100,COLORRED;
抄底:IF(CROSS(CCI20,买入),-100,0),STICK,COLORYELLOW,LINETHICK2;

VARQ1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VARQ2:=SMA(ABS(LOW-VARQ1),13,1)/SMA(MAX(LOW-VARQ1,0),10,1);
VARQ3:=EMA(VARQ2,10);
VARQ4:=LLV(LOW,33);
VARQ5:=EMA(IF(LOW<=VARQ4,VARQ3,0),3)/5;
买赚钱:STICKLINE(VARQ5>REF(VARQ5,1),0,VARQ5,2,0),COLORRED;

自用指标,判断超跌顶底的指标(副图,源码,贴图)

自用指标,判断超跌顶底的指标(副图,源码,贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址