• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

启源SH十挡level2专业版特色指标(源码、贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-07) 42次浏览 0个评论 扫描二维码

启源SH十挡level2专业版特色指标(源码贴图)介绍

启源SH十挡level2专业版特色指标(源码贴图)

操盘手

MA5:MA(C,5),COLORF00FF0;
MA10:MA(C,10),COLORYELLOW;
MA21:MA(C,21),COLORE66878;
MA30:MA(C,30),COLORWHITE;
MA120:MA(C,120),COLOR399C7F,POINTDOT;
MA240:MA(C,240),COLOR000999,POINTDOT;
X1:=(C+L+H)/3;
X2:=EMA(X1,6);
X3:=EMA(X2,5);
DRAWICON(CROSS(X2,X3),L*0.98,7);
DRAWICON(CROSS(X3,X2),H*1.02,8);
STICKLINE(X2>=X3,LOW,HIGH,0.1,1),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,2,2),COLORRED;
STICKLINE(X2>=X3,CLOSE,OPEN,2,8),COLORBROWN;
STICKLINE(X2<X3,LOW,HIGH,0.1,1),COLORGREEN;
STICKLINE(X2<X3,CLOSE,OPEN,2,2),COLORGREEN;
STICKLINE(CROSS(X2,X3),OPEN,CLOSE,2,1),COLORYELLOW;
STICKLINE(CROSS(X3,X2),OPEN,CLOSE,2,1),COLORBLUE;

短线高手主图

m1 5
m2 10
m3 30
m4 60

MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);

VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR7:=0;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)

<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)

>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG

(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG

(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG

(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG

(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG

(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG

(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
买1:=VAR10;
买2:=(VAR11+VAR13+VAR15+VAR17);
卖1:=(VAR12+VAR14+VAR16+VAR18);
B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,’买入’),COLORRED;
S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN;
DRAWTEXT(卖1>0,HIGH*1.02,’卖出’),COLORGREEN;
{股灵吧决策}
VAR100:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));
VAR200:=(100 – ((90 * (HHV(HIGH,20) – CLOSE)) / (HHV(HIGH,20) – LLV(LOW,20))));
VAR300:=(100 – MA(((100 * (HHV(HIGH,5) – CLOSE)) / (HHV(HIGH,5) – LLV(LOW,5))),34));
F:IF(CROSS(VAR200,MA(VAR300,5)),LOW * 0.98,DRAWNULL),CROSSDOT,LINETHICK3,COLOREE00EE;
年:MA(CLOSE,22),LINETHICK2,COLORWHITE;

顶底趋势

Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
长趋势:3*Q3-2*Q4,COLORWHITE,LINETHICK3;
趋势线:EMA(Q3, 3),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(趋势线, 长趋势) AND REF(长趋势,1)>80, REF(长趋势,3),

‘顶’),COLORRED,LINETHICK5;
逢低买: DRAWTEXT(REF(CROSS(趋势线,长趋势),82) AND 趋势线>1.3*长趋势,长趋势,’逢低

买’),LINETHICK1;
买: DRAWTEXT(REF(CROSS(长趋势,趋势线),1) AND 长趋势>1.3*趋势线,趋势

线,’买’),COLORRED,LINETHICK1;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,’快逃’),COLOR00FF00;
金叉: CROSS(长趋势,趋势线);
DRAWTEXT(金叉,趋势线,’★’),COLORRED;

逃顶王

VAR2:=LLV(LOW,10);
VAR3:=HHV(HIGH,25);
阶段卖出: 3.2,COLORC6C600;
3.5,COLOR0088FF;
清仓卖出: 3.5,COLORFF75FF;
动力线:= EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4);
STICKLINE(动力线>REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLORRED;
STICKLINE(动力线<=REF(动力线,1) ,动力线 ,REF(动力线,1),3 ,1),COLOR00FF00;
底部:0.2,COLOR70DB93;
关注:0.5,COLORYELLOW;
DRAWICON( FILTER(CROSS(动力线,关注),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(清仓卖出,动力线),20),动力线+0.02,2);
DRAWICON( FILTER(CROSS(动力线,底部),20),动力线+0.02 ,1);
DRAWICON( FILTER(CROSS(阶段卖出,动力线),20),动力线+0.02,2);
强弱分界线:1.75,POINTDOT,LINETHICK2,COLOR70DB93;
数值:动力线,COLORA8A8A8;

QSDD

VARA:=REF(LOW,1);
VARB:=SMA(ABS(LOW-VARA),3,1)/SMA(MAX(LOW-VARA,0),3,1)*100;
VARC:=EMA(IF(CLOSE*1.3,VARB*10,VARB/10),3);
VARD:=LLV(LOW,30);
VARE:=HHV(VARC,30);
VARF:=IF(MA(CLOSE,58),1,0);
VARG:=EMA(IF(LOW<=VARD,(VARC+VARE*2)/2,0),3)/618*VARF;
VARH:=IF(VARG>100,100,VARG);
吸筹:STICKLINE(VARH>-120,0,VARH,6,1),COLORBLUE;
{
50,COLORRED;
FILLRGN(1,20,80),COLOR222222;
FILLRGN(1,90,100),COLOR000068;
FILLRGN(1,79,90),COLOR663366;
FILLRGN(1,10,20),COLOR666600;
FILLRGN(1, 0,10),COLOR663300;
}
A:=MA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19),COLORRED;
B:=-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
D:=EMA(-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4),LINETHICK2;

长期线:A+100,COLOR9900FF;
短期线:=B+100,COLOR888888;
中期线:D+100,COLORYELLOW,LINETHICK2;
见顶:=((REF(中期线,1)>85 AND REF(短期线,1)>85 AND REF(长期线,1)>65) AND CROSS(长期线,短期

线)) ,COLORGREEN;
顶部区域:=(中期线<REF(中期线,1) AND REF(中期线,1)>80) AND (REF(短期线,1)>95 OR REF(短期

线,2)>95 ) AND 长期线>60 AND 短期线<83.5
AND 短期线<中期线 AND 短期线<长期线+4,COLORGREEN;
顶部:=FILTER(顶部区域,4);
STICKLINE( {见顶 OR} 顶部,99,103,5,0 ),COLORRED,LINETHICK2;
底部区域:=(长期线<12 AND 中期线<8 AND (短期线<7.2 OR REF(短期线,1)<5) AND (中期线>REF(中期

线,1) OR 短期线>REF(短期线,1)))
OR (长期线<8 AND 中期线<7 AND 短期线<15 AND 短期线>REF(短期线,1)) OR (长期线<10 AND 中期线

<7 AND 短期线<1) ,COLORGREEN;
STICKLINE( 底部区域,-4,0,3,0 ),COLORGREEN;
低位金叉:=50*(长期线<15 AND REF(长期线,1)<15 AND 中期线<18 AND 短期线>REF(短期线,1) AND

CROSS(短期线,长期线) AND 短期线>中期线
AND (REF(短期线,1)<5 OR REF(短期线,2)<5 ) AND (中期线>=长期线 OR REF( 短期线,1)<1 ))

COLORYELLOW;
{减仓}
LC1:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC1),0),3,1) / SMA(ABS((CLOSE – LC1)),3,1)) * 100);
FF:=EMA(CLOSE,3);
DRAWTEXT(CROSS(85,RSI),75,’减仓’),COLORGREEN;
{跟着庄家进}
R1:=(((MA(CLOSE,5))-CLOSE)/CLOSE>3/100);
R2:=((MA(CLOSE,10))-(MA(CLOSE,5)))/(MA(CLOSE,5))>0.03;
R3:=(LLV(CLOSE,20)=LLV(CLOSE,30));
大:=(R1 AND R2 AND R3);
大A:=FILTER(大,5);
买:STICKLINE(大A,80,0,2,0),COLORYELLOW;
跟着庄家进:=IF(大A,1,0),COLORRED;
{底部选股}
VAR15:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR25:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR35:=SMA(VAR25,13,8);
VAR45:=SMA(VAR15,21,8);
X2:=CEILING(SMA(VAR35,13,8));
X1:=X2-VAR45 ;
底部选股:IF(X2-VAR45<(-80),30,0),COLORCYAN;
{超级短线买点}
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
短线买点:=IF(SS>13,MA(SS,2),SS);
Z:=21;
超级短线买点:IF(CROSS(短线买点,21),50,0),COLORWHITE;
{机构增减仓}
VAR28:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR38:=SMA(VAR28,4,1);
VAR48:=SMA(VAR38,2,1);
趋势线2:=VAR28;
均线:=MA(VAR28,10);
机构增仓:IF(VAR48<14 AND VAR38<11,80,0),COLOR0000FF;
机构减仓:IF(VAR48>82 AND VAR38>89,80,0),COLOR00FF00;
A11:=REF(C,1);
RSI11:=SMA(MAX(C-A11,0),6,1)/SMA(ABS(C-A11),6,1)*100;
A1:=C-MA(C,5)/MA(C,5)*100<1;
A2:=C-MA(C,13)/MA(C,13)*100<-10;
A3:=C-MA(C,34)/MA(C,34)*100<-15;
A4:=RSI11<18;
TYP := (HIGH + LOW + CLOSE)/3;
A5:=(TYP-MA(TYP,14)/(0.015*AVEDEV(TYP,14)))<-120;
组合底部:(A1 AND A2 AND A3 AND A4 AND A5)*100,COLOR00FFFF;
{}
VAR3A:=((HHV(H,21)-C)/(HHV(H,21)-LLV(L,21)))*100-10;
VAR4A:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5A:=SMA(VAR4A,13,8);
VAR6A:=SMA(VAR3A,21,8);
趋势:=CEILING(SMA(VAR5A,13,8)),LINETHICK2,COLOR0000FF;
看底:IF((趋势-VAR6A<(-65)),1,6),COLOR00FF00;
顶峰:IF((趋势-VAR6A>85),95,100),COLORF0F000;

波段王

n1 3

VAR1:=(CLOSE+HIGH+LOW+OPEN)/4;
VAR2:=SUMBARS(VOL,CAPITAL);
VAR3:=HHV(VAR1,VAR2);
VAR4:=LLV(VAR1,VAR2);
VAR5:=(2*VAR1-VAR4-REF(VAR4,1))/(VAR3-VAR4);
VAR6:=(VAR1-VAR4)/(VAR3-VAR4);
VAR7:=IF(VAR1<=VAR4,VAR5*60,VAR6*60);
VAR8:=600*(EMA(CLOSE,3)-EMA(LOW,30))/EMA(LOW,30);
VAR9:=EMA(VAR8,7);
VARA:=(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))*100;
VARB:=(-100)*(WINNER(120*CLOSE/100)-WINNER(100*CLOSE/100))+5;
VARC:=HHV(HIGH,9)-LLV(LOW,9);
VARD:=HHV(HIGH,9)-CLOSE;
VARE:=CLOSE-LLV(LOW,9);
VARF:=VARD/VARC*100-70;
VAR10:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR11:=(2*CLOSE+HIGH+LOW)/4;
VAR12:=SMA(VARE/VARC*100,3,1);
VAR13:=LLV(LOW,34);
VAR14:=SMA(VAR12,3,1)-SMA(VARF,9,1);
VAR15:=IF(VAR14>100,VAR14-100,0);
VAR16:=HHV(HIGH,34);
VAR17:=EMA((VAR11-VAR13)/(VAR16-VAR13)*100,8);
VAR18:=EMA(VAR17,5);

STICKLINE(VAR17-VAR18>0,VAR17,VAR18,8,1), ,COLORRED ;
STICKLINE(VAR17-VAR18<0,VAR17,VAR18,8,1), ,COLORGREEN ;

筹码分析

来势线: EMA(CLOSE,7)-EMA(CLOSE,21),COLORYELLOW;
福星: EMA(来势线,7), COLORSTICK,COLORRED;
VAR1:=CLOSE/REF(LLV(LOW,35),5)< 1;
决策: IF(VAR1,0.5,0), STICK,COLORBLUE;
必买: IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,1,-1),COLORYELLOW ,LINETHICK1 ;
必卖: IF(PEAKBARS(3,15,1)=1,1,2),COLORWHITE,LINETHICK1;
趋势线: (EMA(WINNER(CLOSE),7)-EMA(WINNER(CLOSE),35))*5,COLORRED;
逃顶线: EMA(CLOSE/REF(HHV(CLOSE,7),50),1),COLOR007000 ,LINETHICK1 ;
AA:0,COLORBROWN;
DRAWICON(CROSS(趋势线,AA),AA,1);
DRAWICON(CROSS(逃顶线,趋势线),逃顶线,2);

{抓涨停TDX}

{时间设置}
LTA:=FINANCE(7)+300000000;
GB:=2*IF(FINANCE(7)<100000000000,FLOOR(ABS((FINANCE(7)/1000000000-1))),FLOOR(ABS((FINANCE

(7)/1000000000-1)))/10),NODRAW ;
C1:=CLOSE;
V1:=TIME;
A1:=COUNT(BARSCOUNT(C)=1 AND TIME<102000 ,0 );
T:=IF(V1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000)),
(FLOOR(V1/10000)-11)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000))),NODRAW;
成交额:AMOUNT,NODRAW;
大额线:=50*3+300*GB,COLOR00FFFF;

VV2:=SUM(AMOUNT,T),NODRAW;
初正1:=IF(T=1 AND DYNAINFO(4)>=DYNAINFO(3),VV2,0);
初负1:=IF(T=1 AND DYNAINFO(4)<DYNAINFO(3),VV2,0);
初正2:=CONST(SUM(IF(T=1,初正1,0),T)),NODRAW;
初负2:=CONST(SUM(IF(T=1,初负1,0),T)),NODRAW;
初正:=CONST(SUM(IF(初正1>大额线 AND T=1,初正1,0),T)),NODRAW;
初负:=CONST(SUM(IF(初负1>大额线 AND T=1,初负1,0),T)),NODRAW;
T00:=IF(C1>REF(C1,1),0.9,-0.9);
T01:=IF(C1<REF(C1,1),-0.9,0.9);
T02:=T00+T01;
TT1:=BARSLAST(CROSS(T02,0));
TT2:=BARSLAST(CROSS(0,T02));
TT:=IF(T02=1.8,1,IF(T02=-1.8,-1,0));
正V1:=IF(TT=1 OR (TT=0 AND TT1>TT2),成交额,0);
负V1:=IF(TT=-1 OR (TT=0 AND TT1<TT2),成交额,0);
正总1:=初正1+SUM(正V1,T),NODRAW,COLOR0000FF;
负总1:=初负1+SUM(负V1,T),NODRAW,COLOR00FF00;
总:=(正总1+负总1)+初正2+初负2,NODRAW;
正V:=IF(正V1>大额线,正V1,0);
负V:=IF(负V1>大额线,负V1,0);
正总:初正+SUM(正V,T),NODRAW,COLOR0000FF;
负总:初负+SUM(负V,T),NODRAW,COLOR00FF00;
差%:(正总-负总)/总*100,COLOR00FF00,NODRAW;

TTA:=INTPART(2*T/5);
KP30:=T<240;
KPGD:=H=HHV(H,0) AND KP30;
GDSJ:=BARSLAST(KPGD);
{强弱界}
MMA30:=EMA(CLOSE,30);
强弱界定:=EMA(CLOSE,900);
DRAWBAND(MMA30,RGB(100,0,0),强弱界定,RGB(0,255,0));
DRAWICON(CROSS(MMA30,强弱界定),H,1);
CC:=CLOSE,COLORWHITE,LINETHICK2;
VAR7:=SMA(CC,6.18,1);
VAR8:=SMA(VAR7,3.14,1);
RCC:=DYNAINFO(3);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=4*(S2-S6);
KK:=1;

{暗轨}
{AA1:=PLOYLINE(CLOSE<COST(50) AND T>5,COST(20));
BB1:=PLOYLINE(CLOSE<COST(50) AND T>5,COST(80));
DRAWBAND(BB1,RGB(50,50,50),AA1,DRAWNULL);

{CYC}
VAR1:=AMOUNT/VOL/100;
VAR2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VAR3:=SUM(AMOUNT,5)/VAR1/100;
VAR4:=SUM(AMOUNT,13)/VAR1/100;
VAR5:=SUM(AMOUNT,34)/VAR1/100;
CYC5:=DMA(VAR2,VOL/VAR3);
CYC13:=DMA(VAR2,VOL/VAR4);
CYC34:=DMA(VAR2,VOL/VAR5);
DRAWBAND(CYC5,RGB(00,50,50),CYC13,DRAWNULL);
DRAWBAND(CYC13,RGB(00,150,150),CYC34,DRAWNULL);
{分时MACD}
昨收:=DYNAINFO(3);
HH:=DYNAINFO(5);
LL:=DYNAINFO(6);
FK:=MAX(HH-昨收,昨收-LL)*0.1;
ZS:=昨收-FK*3.2;
Q1:=昨收-FK*3.22;
Q2:=昨收-2*FK*3.22;
Q3:=昨收-3*FK*3.2;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
DIF:=(EMA(CLOSE,13) – EMA(CLOSE,24));
DEA:=(EMA(DIF,6));
MACD:=5*(DIF-DEA);
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),RCC*KK,MACD*4+RCC*KK,3,0),COLORFF00FF,LINETHICK3;
STICKLINE(MACD>=0 AND MACD< REF(MACD,1),RCC*KK,MACD*4+RCC*KK,3,0),COLORBLUE,LINETHICK3;
STICKLINE(MACD<0 AND MACD>=REF(MACD,1),RCC*KK,MACD*4+RCC*KK,3,0),COLOR4ABEFF,LINETHICK3;
STICKLINE(MACD<0 AND MACD< REF(MACD,1),RCC*KK,MACD*4+RCC*KK,3,0),COLORBLUE,LINETHICK3;
STICKLINE(DK>0,RCC*KK,RCC*KK+DK,0,1),COLORRED;
STICKLINE(DK<0,RCC*KK,RCC*KK+DK,0,1),COLORCYAN;
{多头MACD}
DIFF:=EMA(CLOSE,240)-EMA(CLOSE,240)*100;
DEAA:=EMA(DIFF,18);
多头MACD:=(-3*(DIFF-DEAA))*20,NODRAW;
ZD:=HHV(多头MACD,0);
ZX:=LLV(多头MACD,0);
CZ:=(Q2-Q3)/6;
FDM:=MAX(ABS(ZD),ABS(ZX))*1.5;
RB:=(Q2+Q3)/2+2*(Q2-Q3)/3/FDM*多头MACD;
STICKLINE(多头MACD>0,RB,(Q2+Q3)/2,2,1),LINETHICK1,COLOR0000FF;
STICKLINE(多头MACD<0,RB,(Q2+Q3)/2,2,1),LINETHICK1,COLOR00FF00;

{火焰山及底部信号}
FAA:=WINNER(CLOSE+CLOSE*15/100)*100;
FBB:=WINNER(CLOSE+CLOSE*0/100)*100;
FCC:=FAA-FBB;
FDD:=(WINNER(CLOSE-CLOSE*0.1/100)-WINNER(CLOSE-CLOSE*15/100))*100;
FEE:=FCC<3 AND FDD<0.5 AND OPEN!=LOW;
FA1:=DYNAINFO(6);
FA2:=IF(LOW>FA1,0,IF(HIGH<FA1,1,(FA1-LOW+0.01)/(HIGH-LOW+0.01)));
FA3:=VOL/WINNER(LOW);
FA4:=REF(HHV(CLOSE,120),1);
FA5:=REF(LLV(CLOSE,120),1);
FA6:=100*(CLOSE-FA5)/(FA4-FA5);
FA7:=FA2>0 OR FA2=1;
FA8:=FA7 AND FA3/REF(FA3,3)>=3 AND FA6<80;
FA9:=REF(FA8,1) OR REF(FA8,2) OR REF(FA8,3) OR REF(FA8,4);
FA10:=FA8 AND FA9;
FA11:=IF(FILTER(FA8,3),5,0);
FA12:=IF(FILTER(FA10,3) OR FEE,10,0);
EEEE:=(RCC-ZS)/5;
FVAR1:=REF(LOW,1);
FVAR2:=SMA(ABS(LOW-FVAR1),13,1)/SMA(MAX(LOW-FVAR1,0),13,1);
FVAR3:=EMA(FVAR2,13);
FVAR4:=LLV(LOW,34);
FVAR51:=EMA(IF(LOW<=FVAR4,FVAR3,0),3);
FVAR5:=IF(FVAR51>20,20,FVAR51);
DRAWTEXT(FA11,(Q2+Q3)/2*1.02,’↑进’),COLOR00FFFF;
DRAWTEXT(FA12,(Q2+Q3)/2*1.03,’,↑加’);
主力进场:STICKLINE(FVAR5>REF(FVAR5,1),(Q2+Q3)/2,(Q2+Q3)/2+FVAR5*EEEE,10,0 ),COLORRED;
洗盘:IF(FVAR5<REF(FVAR5,1),FVAR5,0),COLORGREEN,NODRAW;
STICKLINE(FVAR5<REF(FVAR5,1),(Q2+Q3)/2,(Q2+Q3)/2+FVAR5*EEEE,5,1),COLORGREEN;
FVAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA

((CLOSE-
LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
FVAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-

LLV
(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
FVAR8:=FVAR6<REF(FVAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(FVAR8 AND COUNT(FVAR8,30)=1,(Q2+Q3)/2+3*EEEE,’★迹’);
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
STICKLINE(二次金叉,(Q2+Q3)/2,(Q2+Q3)/2*1.01,4,0),COLORFF00FF;
DRAWTEXT(二次金叉,(Q2+Q3)/2*1.01,’ 二金’),COLORYELLOW;
HHH:=MA(CLOSE,10);
GGG:=MA(CLOSE,12);
上:=EMA((MA(HIGH,3) * 1.05),30);
下:=EMA((MA(LOW,3) * 0.96),30);
决战:STICKLINE((((CROSS(DIF,DEA) AND ((下 – REF(下,1)) > 0)) AND (MACD >= REF(MACD,1)))

AND
(DIF < 0)),(Q2+Q3)/2,(Q2+Q3)/2*1.01,1,0),COLOR0000FF;
DRAWTEXT((((CROSS(DIF,DEA) AND ((下 – REF(下,1)) > 0)) AND (MACD >= REF(MACD,1))) AND (DIF
<= 0)),(Q2+Q3)/2*1.01,’DIF金叉’),COLOR0000FF;
{两个主要买进信号}
RSV:=((CLOSE-LLV(LOW,240))/(HHV(HIGH,240)-LLV(LOW,240))*200-100);
K:=SMA(SMA(RSV,18,1),3,1);
D:=MA(EMA(K,18),3);
短买:=CROSS(K,D) AND K>0 AND CLOSE<DYNAINFO(3)*1.07;
DRAWTEXT(短买,(Q2+Q3)/2+(Q2-Q3)/1,’短买’),COLORFF00FF;
YY:=SMA(VOL,30,1);
量1:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30));
量:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30))>0.92;
短横:=((HHV(CLOSE,TTA)-LLV(CLOSE,TTA))/CLOSE)<0.04;
横后上涨:=(CLOSE/DYNAINFO(3))>=1.02=0 AND 短横 AND 量 AND CROSS(C,(MA(C*V,TTA)/MA(V,TTA)

+ AVEDEV(C,TTA)*2));
上涨:=FILTER((CROSS(横后上涨,0)AND 量 AND T>60
OR (T>60 AND CLOSE<DYNAINFO(3)*1.04 AND (量1<0.5 OR 量1=1) AND BARSLAST(CROSS(C,(MA

(C*V,TTA)/MA(V,TTA) + AVEDEV(C,TTA)*2)))<3
AND CROSS(C,MA(HHV(C,TTA),1)))),30);
DRAWTEXT(上涨,(Q2+Q3)/2+(Q2-Q3)/1,’★涨’),COLORRED,LINETHICK3;

HHHH:REF(H,GDSJ),COLORFFFFFF,POINTDOT,LINETHICK1;
过顶:IF(CROSS(C,HHHH),1,0),COLOR00FF00,POINTDOT,NODRAW;
冲高:IF(FILTER(CROSS(C,HHHH*1.01),15),1,0),COLOR00FFFF,POINTDOT,NODRAW;

DRAWBAND(VAR7,RGB(255,255,0),VAR8,RGB(0,255,255));
DRAWTEXT(过顶,HHHH*1.005,’↑’),COLOR00FF00;
DRAWTEXT(冲高,HHHH*1.005,’☆’),COLOR00FFFF;
C,LINETHICK2,COLORFFFFFF;

启源布林主图

中轨:MA(CLOSE,20),COLOR0080FF;
上轨:中轨+STD(CLOSE,20),COLORFFFF00;
下轨:中轨-STD(CLOSE,20),COLORFFFF00;
上极:中轨+2*STD(CLOSE,20),COLORBLUE;
下极:中轨-2*STD(CLOSE,20),COLORBLUE;

黑马波段主图

上线:=SMA(C,6.5,1);
下线:=SMA(C,13.5,1);
上线1:=SMA(C,3,1);
下线1:=SMA(C,8,1);
STICKLINE(上线>下线,上线,下线,2,2),COLORRED,LINETHICK2;
STICKLINE(下线>上线,上线,下线,2,2),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(上线,下线),LOW,’●
全仓买’),COLOR00FF00;
DRAWTEXT(CROSS(下线1,上线1),H,’◆
清仓’),COLORYELLOW;
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
UPR:=BBI+3*STD(BBI,13),LINETHICK2;
DWN:=BBI-3*STD(BBI,13);
安全:=MA(CLOSE,60),LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT( CROSS(82,RSI) , HIGH,’◆
减仓’) ,COLORFF9966,LINETHICK2;
A7:=(2*C+H+L)/4;
操作:MA(A7,5),LINETHICK2;
操作1:=MA(A7,5)*1.03,LINETHICK2;
操作2:=MA(A7,5)*0.97,LINETHICK2;
VAR1:LLV(A7,21);
VAR0:HHV(A7,21);
SK:=EMA((A7-VAR1)/(VAR0-VAR1)*100,7);
SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 AND VOL>=1.5*MA(VOL,5) AND
COUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW*0.98,’●
买进’) ,COLOR0099FF;
DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 AND
COUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) AND
REF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) AND
OPEN>REF(CLOSE,1),1,0),LOW*0.98,’●
买进’) ,COLORYELLOW;
D:=MA(CLOSE,80)-MA(CLOSE,10)/3;
DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08
AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,’●
抄底’),COLORYELLOW;
VAR12:=((VOL / CAPITAL) * 100);
VAR15:=HHVBARS(HIGH,50);
VAR17:=(((CLOSE – REF(OPEN,VAR15)) / REF(OPEN,VAR15)) * 100);
VAR22:=(REF(CLOSE,2) * 0.865);
VAR23:=(REF(CLOSE,13) * 0.772);
VAR24:=MIN(VAR22,VAR23);
超跌反弹:=(IF((((((CLOSE – VAR24) / CLOSE) < 0.03) AND (VAR17 < (0 – 35))) AND ((SUM

(VAR12,5) / 5) < 1.8)),1,0) * 5);
DRAWTEXT(超跌反弹,L,’♂’),COLORRED;
VAR2:=C<0.98*REF(C,1);
VAR3:=O<REF(C,1);
VAR4:=(C-REF(C,1))/REF(C,1)*100;
VAR5:=(C-REF(O,29))/REF(O,29)*100;
VAR6:=MA(COST(22)/L,3);
成功率99:=VAR6>1.5 AND VAR4>5 AND VAR5<-30;
DRAWTEXT(成功率99>0 AND REF(成功率99,1)=0,L,’↑99%’),COLORRED;
仓:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5);
仓1:=INDEXC;
仓2:=MA(仓1,5);
仓3:=MA(仓1,20);
仓4:=MA(仓1,30);
B2:=仓2>仓1*1.03 AND 仓3>仓1*1.13;
操盘手:=仓<6 AND B2;
DRAWTEXT(操盘手,L,’仓’),COLORRED;
底1:=IF((((((EMA(CLOSE,5) / EMA(EMA(CLOSE,9),16)) <= 0.85) AND ((CLOSE / REF(CLOSE,1)) >

0.905)) AND ((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),50,0);
底2:=((0 – ((100 * (HHV(HIGH,34) – CLOSE)) / (HHV(HIGH,34) – LLV(LOW,34)))) + 100);
底3:=((0 – ((100 * (HHV(HIGH,50) – CLOSE)) / (HHV(HIGH,50) – LLV(LOW,50)))) + 100);
底:=((0 – ((100 * (HHV(HIGH,70) – CLOSE)) / (HHV(HIGH,70) – LLV(LOW,70)))) + 100);
底4:=(((((CLOSE – MA(CLOSE,34)) / MA(CLOSE,34)) * 100) + 10) * 5);
底5:=(((((CLOSE – MA(CLOSE,50)) / MA(CLOSE,50)) * 100) + 10) * 5);
底6:=(((((CLOSE – MA(CLOSE,70)) / MA(CLOSE,70)) * 100) + 10) * 5);
S1:=((((((底2 + 底3) + 底) + 底4) + 底5) + 底6) / 6);
S2:=EMA(S1,3);
S3:=ABS((底4 – 底6));
S4:=((S1 + S3) / 2);
S5:=(((0 – 1) * (EMA((100 * (1 – WINNER(CLOSE))),1) – 50)) + 50);
S6:=(S5 + S4);
S7:=IF(((底1 > 0) AND (S6 < 0)),200,0);
S8:=IF((((((S4 < 0) AND (CLOSE = LLV(CLOSE,5))) AND ((CLOSE / REF(CLOSE,1)) > 0.905)) AND

((CLOSE / REF(CLOSE,1)) < 1.05)) AND (((VOL / CAPITAL) * 100) < 5)),(0 – 50),0);
S9:=IF(((S6 < 0) AND (S8 = (0 – 50))),100,0);
底C0:=(REF(CLOSE,2) * 0.865);
底C1:=(REF(CLOSE,13) * 0.772);
底C2:=MIN(底C0,底C1);
底C3:=((100 * VOL) / CAPITAL);
底C4:=IF(((((CLOSE – 底C2) / CLOSE) < (3 / 100)) AND ((SUM(底C3,5) / 5) < 1.8)),1,0);
底AA:=IF(((底C4 > 0) AND ((S8 < 0) OR (底1 > 0))),100,0);
V1:=(((((S7 > 0) AND (S9 > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR (底C4 >

0)) AND ((S8 < 0) OR (底1 > 0)));
V2:=((((S7 > 0) AND (S9 > 0)) AND ((SUM(((VOL / CAPITAL) * 100),5) / 5) < 1)) OR ((底C4 >

0) AND ((REF(CLOSE,1) / REF(CLOSE,2)) > 0.902)));
V3:=(V1 OR V2);
V4:=(底AA OR V3);
V5:=底AA;
G:=(MA(CLOSE,80) – (MA(CLOSE,10) / 3));
Z:=IF((V4 > 0),87,0);
Z1:=IF((V5 > 0),91,0);
Z2:=IF(((底AA > 0) AND (CLOSE < G)),97,0);
Z3:=MAX(MAX(Z2,Z),Z1);
DRAWTEXT(FILTER(((((Z > 80) AND (Z1 > 90)) AND (Z2 > 90)) AND (Z3 > 90)),13),L,’↑底

95%’),COLORRED;

战神买卖主图

m1 5
m2 10
m3 20
m4 60

MA1:MA(CLOSE,M1);
MA2:MA(CLOSE,M2);
MA3:MA(CLOSE,M3);
MA4:MA(CLOSE,M4);
VAR1:=EMA((C-(LLV(L,25)))/((HHV(H,25))-(LLV(L,25)))*100,5);
VAR2:=VAR1,COLORRED,LINETHICK2;
VAR3:=MA((V-REF(V,1))/REF(V,1),5);
VAR4:=(C-MA(C,24))/MA(C,24)*100;
VAR5:=VAR4*(1+VAR3);
VAR6:=REF(VOL,1);
VAR7:=SMA(MAX(VOL-VAR6,0),6,1)/SMA(ABS(VOL-VAR6),6,1)*100;
VAR8:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR9:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7>REF(VAR7,1);
VAR10:=VAR5>REF(VAR5,1) AND VAR2<REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR11:=VAR5<REF(VAR5,1) AND VAR2>REF(VAR2,1) AND VAR7<REF(VAR7,1);
VAR12:=VAR5>REF(VAR5,1);
VAR13:=VAR5<REF(VAR5,1);
VAR14:=VAR2<REF(VAR2,1);
VAR15:=VAR2>REF(VAR2,1);
VAR16:=VAR8 OR VAR10;
VAR17:=VAR9 OR VAR11;
VAR18:=VAR13 AND VAR14;
VAR19:=VAR16 OR VAR18;
VAR20:=VAR12 AND VAR15;
VAR21:=VAR17 OR VAR20;
VAR22:=LAST(VAR19,N1,1) AND VAR20;
VAR23:=LAST(VAR21,N2,1) AND VAR18;
DRAWTEXT(VAR22,L,’★买’),COLOR00FFFF;
DRAWTEXT(VAR23,H,’★卖’),COLORWHITE;

{黑马趋势}
A1:3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV

(L,55))*100,5,1);
黑马线:EMA(A1,5),LINETHICK2,COLOR6600FF;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)),LINETHICK2,COLORYELLOW;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A2<0,7),黑马线,’跑’),COLOR00FF00;
DRAWTEXT(CROSS(A1,黑马线)AND 黑马线<A5,黑马线,’黑马’);
DRAWTEXT(CROSS(黑马线,A5)AND 趋势线<80,黑马线,’追涨’);
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,’大黑马’);
底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED;
DRAWICON(底部 AND A3>REF(A3,1),25,4);
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)

>0.04,30,0),1),COLORF00FF0;
大势已去:IF(CROSS(黑马线,A1)AND 黑马线>70 AND 趋势线>80,90,100),COLORFF0000;

牛市操盘

MA5:MA(CLOSE,5),COLORFFFFFF;
MA10:MA(CLOSE,10),COLOR00FFFF;
MA21:MA (CLOSE,21),COLOR00FF00;
MA30:MA(CLOSE,30),COLOR0000FF;
买线:=EMA (C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
BUY1:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);DRAWTEXT(BUY1,LOW*0.95,’B’),COLORWHITE,LINETHICK5;
DRAWTEXT (SEL,HIGH*1.05,’S’),COLORWHITE,LINETHICK5;
STICKLINE(买线>=卖线,LOW,HIGH,0.1,0),COLORYELLOW;
STICKLINE(买线>=卖线,CLOSE,OPEN,3,3),COLORYELLOW;
STICKLINE(买线<卖线,CLOSE,OPEN,3,3),COLORGREEN;
STICKLINE(买线<卖线,LOW,HIGH,0.1,0),COLORGREEN;
STICKLINE(CROSS(买线,卖线) OR CROSS(卖线,买线),OPEN,CLOSE,2.5,0),COLORWHITE;

短线决杀

V1:=DMA((((HIGH+LOW)+(CLOSE*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
趋势线:MA((CLOSE-HY1)*100,2),COLORYELLOW;
线性:=((((((CLOSE*5)+(REF(CLOSE,1)*4))+(REF(CLOSE,2)*3))+(REF(CLOSE,3)*2))
+(REF(CLOSE,4)*1))/((((5+4)+3)+2)+1));
熊牛线:MA(线性,2),COLORGREEN;

主力多空

V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=MA((CLOSE – HY1) * 10,2);
操盘:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),0,多空趋势,3,3),COLORYELLOW;
减仓:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),0,多空趋势,3,3),COLORYELLOW;
反弹:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),0,多空趋势,3,3),COLORGREEN;
寻底:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),0,多空趋势,3,3),COLORGREEN;

机构持仓量

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:=(主力-均量);
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),0,主力能量,3,3),COLORYELLOW;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),0,主力能量,3,3),COLORYELLOW;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),0,主力能量,3,3),COLORGREEN;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),0,主力能量,3,3),COLORGREEN;

大户持仓量

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
大户能量:=(大户-均量);
操盘:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),0,大户能量,3,3),COLORYELLOW;
减仓:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),0,大户能量,3,3),COLORYELLOW;
反弹:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),0,大户能量,3,3),COLORGREEN;
寻底:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),0,大户能量,3,3),COLORGREEN;

中户持仓量

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
中户能量:=(中户-均量);
操盘:STICKLINE(中户能量>=0 AND 中户能量>=REF(中户能量,1),0,中户能量,3,3),COLORYELLOW;
减仓:STICKLINE(中户能量>=0 AND 中户能量< REF(中户能量,1),0,中户能量,3,3),COLORYELLOW;
反弹:STICKLINE(中户能量<0 AND 中户能量>=REF(中户能量,1),0,中户能量,3,3),COLORGREEN;
寻底:STICKLINE(中户能量<0 AND 中户能量< REF(中户能量,1),0,中户能量,3,3),COLORGREEN;

散户持仓量

换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(散户+主力+大户+中户)/4;
散户能量:=(散户-均量);
操盘:STICKLINE(散户能量>=0 AND 散户能量>=REF(散户能量,1),0,散户能量,3,3),COLORYELLOW;
减仓:STICKLINE(散户能量>=0 AND 散户能量< REF(散户能量,1),0,散户能量,3,3),COLORYELLOW;
反弹:STICKLINE(散户能量<0 AND 散户能量>=REF(散户能量,1),0,散户能量,3,3),COLORGREEN;
寻底:STICKLINE(散户能量<0 AND 散户能量< REF(散户能量,1),0,散户能量,3,3),COLORGREEN;

资金进出

A1:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
BL:=VOL/CAPITAL*100;
STICKLINE(A1>=0,0,A1,3,3),COLORYELLOW;
STICKLINE(A1<0,0,A1,3,3),COLORGREEN;

主力进出

DIF:=EMA(CLOSE,13)-EMA(CLOSE,28);
DEA:=EMA(DIF,8);
MACD:=(DIF-DEA)*2;
STICKLINE((MACD > 0),0,MACD,3,3),COLORYELLOW;
STICKLINE((MACD <= 0),0,MACD,3,3),COLORGREEN;
VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100);
VAR10:=SMA(VAR9,3,1);
VAR11:=SMA(VAR10,3,1);
VAR12:=SMA(VAR11,3,1);
主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<40),0,1);

波段指标

A4:=MA(CLOSE,20);
A5:=(CLOSE > MA(CLOSE,5));
A6:=(MA(CLOSE,5) > MA(CLOSE,10));
A7:=(CLOSE > MA(CLOSE,10));
A8:=(MA(CLOSE,5) > MA(CLOSE,20));
A9:=(CLOSE > MA(CLOSE,20));
A10:=REF(A4,1);
A11:=(A4 > A10);
趋势:(((((IF(A5,10,(0 – 10)) + IF(A6,10,(0 – 10))) + IF(A7,10,(0 – 10))) + IF(A8,10,(0 –

10))) + IF(A9,10,(0 – 10))) + IF(A11,10,(0 – 10))),COLORYELLOW;
零轴:0,COLORGREEN;

主力控盘

ZLCM:=EMA((WINNER(CLOSE) * 70),3);
SHCM:=EMA(((WINNER((CLOSE * 1.1)) – WINNER((CLOSE * 0.9))) * 80),3);
主力控盘:((ZLCM / (ZLCM + SHCM)) * 100),COLORYELLOW;
顶:90,COLORGRAY;
风险:80,COLORGREEN;
平衡:50,COLORGREEN;
安全:20,COLORGREEN;
底:0,COLORGRAY;

牛庄杀市主图

AAA:=(MA (CLOSE,13)+MA (CLOSE,17))/2;
CCC:=(STD(CLOSE,13)+STD(CLOSE,17))/2;
BBB:=AAA+2.1*CCC;
DDD:=AAA+0.72*CCC;
ZZZ:=IF(CCC>1.88 ,MA (DDD,3),DDD);
平仓:ZZZ*1.145,COLORCYAN;
风险:ZZZ*1.095,COLORGREEN;
回档:ZZZ*1.04,COLORYELLOW;
平衡:ZZZ*0.986,COLORWHITE;
反弹:ZZZ*0.918,COLORMAGENTA;
超低:ZZZ*0.880,COLORRED;
满仓:ZZZ*0.83,COLORBLUE;
VAR32:=CLOSE/REF(CLOSE, 1)>=1.062 AND HIGH/CLOSE<1.005 AND MA(CLOSE, 90)/CLOSE>=1.150;
VAR33:=VAR32 AND COUNT(VAR32, 20)=1 ;
VAR34:=(INDEXC-REF(INDEXC, 1))/REF(INDEXC, 1);
VAR35:=(CLOSE-REF(CLOSE, 1))/REF(CLOSE, 1);
VAR36:=IF(VAR34>0.010, 0.900, 1) AND IF(VAR34>(-0.025), 1, 1.200);
VAR37:=VAR36*(VAR35-VAR34)*100;
VAR38:=SUM(VAR37, 10);
VAR39:=SMA(VAR38, 40, 1);
VAR310:=VAR38>20;
VAR311:=CROSS(CLOSE, MA(CLOSE*1.055, 3)) AND CLOSE>OPEN*1.060 AND VOL>=REF(VOL, 1)*1.5 AND

CLOSE>=MA(CLOSE, 10);
VAR312:=VAR310 AND VAR311 ;
VAR313:=(-100)*(HHV(HIGH, 3)-CLOSE)/(HHV(HIGH, 3)-LLV(LOW, 3));
VAR314:= CROSS(VAR313, (-87)) AND OPEN=1.090*REF(CLOSE, 1) AND INDEXC>0.980*REF(INDEXC, 1)

AND CLOSE<=1.470*LLV(CLOSE, 58);
VAR315:=EMA(CLOSE, 12)-EMA(CLOSE, 26);
VAR316:=EMA(VAR315, 9);
VAR317:=2*(VAR315-VAR316);
VAR318:=(CLOSE-LLV(LOW, 9))/(HHV(HIGH, 9)-LLV(LOW, 9))*100;
VAR319:=SMA(VAR318, 3, 1);
VAR320:=SMA(VAR319, 3, 1);
VAR321:=EMA(IF(VAR316>REF(VAR316, 1), 1, (-1)), 14)*14;
VAR322:=EMA(IF(VAR320>REF(VAR320, 1), 1, (-1)), 14)*14*2;
VAR323:=(MA(CLOSE, 5)/MA(CLOSE, 70)-1)*100;
VAR324:=(VAR323+VAR322+VAR321)/3;
VAR325:=MA(CLOSE, 80)-MA(CLOSE, 10)/3;
VAR326:=IF(CLOSE AND MA(VOL, 5)/240 AND CLOSE>REF(CLOSE, 1)*1.0 AND CLOSE,88,0);

{VAR38>VAR39;}
VAR327:=IF(CLOSE/REF(CLOSE, 1)>1.050 AND VOL/CAPITAL*100<10 AND CLOSE<17 AND

HIGH/CLOSE<1.010 AND VAR326>0, 91, 0);
DRAWTEXT(VAR327>90,LOW*0.95,’杀’),COLORYELLOW;

顾比均线主图

M1:EMA(C,5),COLORRED,LINETHICK2;
M2:EMA(M1,5),COLORGREEN;
M3:EMA(M2,5),COLORGREEN;
M4:EMA(M3,5),COLORGREEN;
M5:EMA(M4,5),COLORGREEN;
M1S:IF(M1>REF(M1,1),M1,DRAWNULL),COLORYELLOW;
M2S:IF(M2>REF(M2,1),M2,DRAWNULL),,COLORYELLOW;
M3S:IF(M3>REF(M3,1),M3,DRAWNULL),,COLORYELLOW;
M4S:IF(M4>REF(M4,1),M4,DRAWNULL),,COLORYELLOW;
M5S:IF(M5>REF(M5,1),M5,DRAWNULL),,COLORYELLOW;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
DRAWTEXT(VAR19,L,’B’),COLORWHITE;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWTEXT(VAR1A,H*1.02,’S’),COLORWHITE;

趋势买卖

n 20
m 32
p1 80
p2 100

VAR1:=(C+H+O+L)/4;
卖出:XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
幅度:100*(卖出-买入)/买入,NODRAW;
MA1:=MA(VAR1,3);
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,MAX(卖出,MAX(OPEN,CLOSE)),3,0),COLORGREEN;
STICKLINE(卖出>MIN(C,O) AND 卖出<MAX(C,O),卖出,MAX(OPEN,CLOSE),3,0),COLORGREEN;
STICKLINE(卖出>LOW AND 卖出<HIGH,卖出,HIGH,0,0),COLORGREEN;
STICKLINE(卖出<LOW,OPEN,CLOSE,3,0),COLORGREEN;
STICKLINE(卖出<LOW,HIGH,LOW,0,0),COLORGREEN;
STICKLINE(买入>LOW AND 买入<HIGH,买入,MIN(MIN(OPEN,CLOSE),买入),3,0),COLORMAGENTA;
STICKLINE(买入>MIN(C,O) AND 买入<MAX(C,O),买入,MIN(OPEN,CLOSE),3,0),COLORMAGENTA;
STICKLINE(买入>LOW AND 买入<HIGH,买入,LOW,0,0),COLORMAGENTA;
STICKLINE(买入>HIGH,OPEN,CLOSE,3,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
DRAWTEXT(CROSS(LOW,买入),LOW*0.95,’B’),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖出,HIGH),HIGH*1.02,’S’),COLORGREEN;

百万指标

多:EMA(C,3),COLORYELLOW;
空:EMA(C,5),COLOR00FF00;
均衡:EMA(空,5),COLORWHITE,;
VARF1:=COUNT(CROSS(多,均衡),2)=1;
VARF2:=COUNT(CROSS(空,均衡),2)=1;
ZAI:=FILTER(VARF1 AND VARF2,2);
DRAWTEXT(ZAI,均衡,’升↑’),COLORFF00FF;
VV2:=REF(CLOSE,1);
VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;
DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2);
DRAWTEXT(REF(VV3,1)>81 AND VV3<80,HIGH*1.03,’空↓’),COLORYELLOW;
VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA

(CLOSE,13)*1.3,1,0),LOW,’☆’),COLORRED;
VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;
VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);
DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VARA>=VARB AND VARA<-17,3) AND REF(LOW,1)=LLV

(LOW,120),1,0),LOW,’★注意买入’);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,’空↓’),COLORYELLOW;
VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2:=REF(VAR1,1);
VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;
HY3:=IF(COUNT(VAR3<20,5)>=1 AND COUNT(VAR1=LLV(VAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND

VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY3,LOW,’买’),COLORRED;
S:=MA(VOL,5)/MA(VOL,60),COLORRED,,LINETHICK2;
A:=MA(S,5),COLORGREEN,,LINETHICK2;
BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
F:=MA(S,121);
RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
K:=SMA(RSV,15,1);
D:=SMA(K,15,1);
J:=3*K-2*D;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH*1.06,’逃’),COLORYELLOW ;
S1:=IF((J<11 AND BIAS>-11 AND CROSS( S,F) AND (S-F)

>0.010),2,0),STICK,LINETHICK3,COLORGREEN;
DRAWTEXT(S1=2,LOW,’注’), COLORGREEN;
中轨:HHV(MA(H,13),13),COLORRED,LINETHICK2;
趋势: LLV(MA(H,13),1),COLORGREEN,LINETHICK2;

红启动色

启动线:SUM(EMA((C+L)/2,2),5)/10.158,COLORRED;
平衡线:LLV(SUM( EMA((C+L)/2,2),5)/10.158,4),COLORGREEN;
平台线:LLV(SUM( EMA((C+L)/2,2),5)/10.158,10),COLORBLUE;
强弱线:EMA(启动线,21),COLORYELLOW;
STICKLINE(平台线<启动线,启动线,平台线,0.1,0),COLORFFCCAA;
STICKLINE(平衡线<启动线,启动线,平衡线,0.1,0),COLORRED;
VAR1:=2*MA(LLV((C+L)/2,8)*1.1,13)-EMA((C+L)/2,3)-((C+L)/2)*0.1;
VAR2:=IF((EMA((C+L)/2,3)-VAR1)*5>0,POW((EMA((C+L)/2,3)-VAR1)*5,2)/10,-1*POW((EMA

((C+L)/2,3)-VAR1)*5,2)/10);
VAR3:=IF(VAR2>0,VAR2-0,0);
STICKLINE(VAR3>0 AND REF(VAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),
强弱线,强弱线+0.2,4,0),COLORFFAACC;
DRAWTEXT(VAR3>0 AND REF(VAR3,1)=0 AND (C+L)/2>MA((C+L)/2,8),
强弱线+0.35,’注意’),LINETHICK3,COLORFFAACC;

操盘小护士

QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
跌:EMA(涨,4),LINETHICK1,COLORFFFF34;
多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;
空线:IF(CROSS(跌,80),70,100),COLORFF9900;
买1:EMA(跌,4),COLORWHITE;
买2:EMA(买1,4),COLORGREEN;
买M3:=EMA(买2,4);
买M4:=EMA(买M3,4);
STICKLINE(涨<REF(涨,1),涨,MA(涨,3),2,0 ),COLOR00CC00;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR0088FF;
DRAWICON(多线,30,1);
DRAWICON(CROSS(跌,80),70,2);
DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,’买入’),COLORCCFF99;
DRAWTEXT(多线>0,-20,’看涨’),COLOR0000FF;
VAR811:=SUMBARS(VOL,FINANCE(7)*100);
VAR822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR883:=(CLOSE-VAR822)/VAR822*100;
VAR884:=HHV(VAR883,VAR811);
VAR885:=LLV(VAR883,VAR811);
VAR886:=(VAR883-VAR885)/(VAR884-VAR885)*100;
K:=SMA(VAR886,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
MA1:=MA(J,3);
STICKLINE(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,涨,涨+20,6,0),COLORYELLOW;
DRAWTEXT(FILTER(J>MA1 AND J<=3,5)=1 AND 跌<0,60,’考虑买进’),COLORFFFFFF;
VAR1:=MA(CLOSE,152);
VAR2:=MA(CLOSE,194);
VAR3:=VAR2+2*STD(CLOSE,170);
VAR4:=VAR1+2*STD(CLOSE,170);
顶:CLOSE>(VAR3)*13*10,COLORBLUE,LINETHICK2;
VAR18:=HHV(HIGH,30);
VAR19:=LLV(LOW,30);
NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10;

VAR3B:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
VAR3C:=SMA(VAR3B,3,1);
VAR3D:=SMA(VAR3C,3,1);
VAR3E:=SMA(VAR3D,3,1);
VAR3F:=CROSS(VAR3D,VAR3E) AND VAR3D<20;
VAR40:=CROSS(VAR3E,VAR3D) AND VAR3D>80;
VAR41:=5;
DRAWTEXT(CROSS(VAR41,NL),30,’★做底’),COLORWHITE;

启源SH十挡level2专业版特色指标(源码、贴图)

启源SH十挡level2专业版特色指标(源码、贴图)

启源SH十挡level2专业版特色指标(源码、贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址