• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

既能看趋势同时又能找顶底的指标—(WR、DMI同图,源码,配图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-07) 33次浏览 0个评论 扫描二维码

既能看趋势同时又能找顶底的指标—(WRDMI同图,源码,配图)介绍

参数n:日线以上可取7或14,分钟图可取40。
源码:
{DMI}
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),N);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),N);
PDI: DMP*100/MTR;
MDI: DMM*100/MTR;
DRAWBAND(PDI,RGB(100,0,50),MDI,RGB(256,96,96));
ADX:EXPMEMA((PDI-MDI)/(PDI+MDI)*100,N),COLORFF00FF;
ADXR:EXPMEMA(ADX,N/2),COLOR00FF00;
{LTSH}
WR:100-100*(HHV(HIGH,40)-CLOSE)/(HHV(HIGH,40)-LLV(LOW,40)),COLORFFFFFF,LINETHICK2;
见顶:100,COLOR0000FF,LINETHICK2;
见底:0,COLOR00FF00,LINETHICK2;
STICKLINE(WR=100,101,110,5,0),COLOR0000FF;
STICKLINE(WR=0,101,110,5,0),COLOR00FF00;
STICKLINE(WR<100 AND WR>=99,101,110,5,1),COLOR00FFFF;
STICKLINE(WR<=0.6 AND WR>0,101,110,5,0),COLOR00FFFF;

【设计思路】
本指标实际上由两个大家很熟悉的指标“DMI”和“龙腾四海”组成。本人把DMI中的ADX、ADXR的表现方式进行了改动,变成了类似MACD的指标,可以观察大盘和个股的运行趋势。“龙腾四海”则是大家都知道的“威廉指标”的改良,顶为100,底为0,这比较符合人们的习惯。把这两个指标放在同一个图中显示,可以做到既能看趋势又能找顶底。缺点是,由于两个指标在同一图中,对DMI图形有些压缩,最好放大观看。
【使用方法】
(1)DMI和“龙腾四海”的常规用法,大家都知道或者可以在论坛上找到,这里不赘述。
(2)图中的红块代表WR=100,相当于红绿灯中的红灯,也就是股价(指数)见顶;黄色空心块代表WR值接近于100但没达到100,相当于红绿灯中的黄灯,起警示作用;绿块代表WR=0,相当于红绿灯中的绿灯,也就是股价(指数)见底;黄色实心块代表WR值在0和1之间,可以关注。
(3)抓住指标的顶底背离是我们逃顶抄底的关键,图中亦有说明。

上面是常规的使用方法,其中仍有许多奥妙有待我们挖掘,日后会有补充的。希望大家运用后能够给出自己的体会,而不是“灌水”。

既能看趋势同时又能找顶底的指标---(WR、DMI同图,源码,配图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址