• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

筹码分布(主图、源码、DLL、贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-08) 46次浏览 0个评论 扫描二维码

筹码分布(主图源码DLL贴图)介绍

{支撑压力(SSL)是筹码堆积的一种表现方法。它统计在一定时间周期中各价位的成交量,真实地反映了各价位上的成交堆积情况。
指标设有三种线:
1)价位线,即以收盘价连接得到的曲线,它代表了股价的走势,以白色曲线表示。
2)支撑压力线,即各个对应价位上的成交堆积,线的长度代表堆积的筹码的多少,以品红水平线表示。
3)获利成本价格线,即某获利盘比例所处的价位,线的长度代表样本区间范围,线条所处的位置就是对应的价位,以绿色水平线表示。
指标设有两个参数:
N:样本区间范围,即研究对象的周期数。
M:获利盘比例,即在样本区间范围内的获利筹码。
注意:由于公式中没有使用历史数据衰减系数,所以不能反映筹码的迁移过程,因此更适用于对较短时间周期的筹码堆积情况的分析。
}

input:N(130,1,10000),M(50,0,100);
Var1:="[email protected]"(N,M);
成本: Var1,colorgreen ;
Var6:="[email protected]"(n,5);
Var7:="[email protected]"(n,6);
Var8:="[email protected]"(n,7);
Var9:="[email protected]"(n,8);
VarA:="[email protected]"(n,9);
VarB:="[email protected]"(n,10);
VarC:="[email protected]"(n,11);
VarD:="[email protected]"(n,12);
VarE:="[email protected]"(n,13);
VarF:="[email protected]"(n,14);
Var10:="[email protected]"(n,15);
Var11:="[email protected]"(n,16);
Var12:="[email protected]"(n,17);
Var13:="[email protected]"(n,18);
Var14:="[email protected]"(n,19);
Var15:="[email protected]"(n,20);
Var16:="[email protected]"(n,21);
Var17:="[email protected]"(n,22);
Var18:="[email protected]"(n,23);
Var19:="[email protected]"(n,24);
Var1A:="[email protected]"(n,25);
Var1B:="[email protected]"(n,26);
Var1C:="[email protected]"(n,27);
Var1D:="[email protected]"(n,28);
Var1E:="[email protected]"(n,29);
Var1F:="[email protected]"(n,30);
Var20:="[email protected]"(n,31);
Var21:="[email protected]"(n,32);
Var22:="[email protected]"(n,33);
Var23:="[email protected]"(n,34);
Var24:="[email protected]"(n,35);
Var25:="[email protected]"(n,36);
Var26:="[email protected]"(n,37);
Var27:="[email protected]"(n,38);
Var28:="[email protected]"(n,39);
Var29:="[email protected]"(n,40);
Var2A:="[email protected]"(n,41);

POLYLINE(Var6>0,Var6),Color008364,LAYER7;
POLYLINE(Var7>0,Var7),Color008364,LAYER7;
POLYLINE(Var8>0,Var8),Color008364,LAYER7;
POLYLINE(Var9>0,Var9),Color008364,LAYER7{,color808080};
POLYLINE(VarA>0,VarA),Color008364,LAYER7;
POLYLINE(VarB>0,VarB),Color008364,LAYER7;
POLYLINE(VarC>0,VarC),Color008364,LAYER7;
POLYLINE(VarD>0,VarD),Color008364,LAYER7{,color808080};
POLYLINE(VarE>0,VarE),Color008364,LAYER7;
POLYLINE(VarF>0,VarF),Color008364,LAYER7;
POLYLINE(Var10>0,Var10),Color008364,LAYER7;
POLYLINE(Var11>0,Var11),Color008364,LAYER7{,color808080};
POLYLINE(Var12>0,Var12),Color008364,LAYER7;
POLYLINE(Var13>0,Var13),Color008364,LAYER7;
POLYLINE(Var14>0,Var14),Color008364,LAYER7;
POLYLINE(Var15>0,Var15),Color008364,LAYER7{,color808080};
POLYLINE(Var16>0,Var16),Color008364,LAYER7;
POLYLINE(Var17>0,Var17),Color008364,LAYER7;
POLYLINE(Var18>0,Var18),Color008364,LAYER7;
POLYLINE(Var19>0,Var19),Color008364,LAYER7{,color808080};
POLYLINE(Var1A>0,Var1A),Color008364,LAYER7;
POLYLINE(Var1B>0,Var1B),Color008364,LAYER7;
POLYLINE(Var1C>0,Var1C),Color008364,LAYER7;
POLYLINE(Var1D>0,Var1D),Color008364,LAYER7{,color808080};
POLYLINE(Var1E>0,Var1E),Color008364,LAYER7;
POLYLINE(Var1F>0,Var1F),Color008364,LAYER7;
POLYLINE(Var20>0,Var20),Color008364,LAYER7;
POLYLINE(Var21>0,Var21),Color008364,LAYER7{,color808080};
POLYLINE(Var22>0,Var22),Color008364,LAYER7;
POLYLINE(Var23>0,Var23),Color008364,LAYER7;
POLYLINE(Var24>0,Var24),Color008364,LAYER7;
POLYLINE(Var25>0,Var25),Color008364,LAYER7{,color808080};
POLYLINE(Var26>0,Var26),Color008364,LAYER7;
POLYLINE(Var27>0,Var27),Color008364,LAYER7;
POLYLINE(Var28>0,Var28),Color008364,LAYER7;
POLYLINE(Var29>0,Var29),Color008364,LAYER7{,color808080};
{}
空:=EMA(C,5);
均衡:EMA(空,5),COLORWHITE;
趋势:LLV(MA(H,13),1),COLORred;
{}
现价: if (DYNAINFO(4)=0,C,DYNAINFO(7)),colorwhite,POINTDOT;

k1:=l>ref(h,1);
k2:=barslast(k1);
k4:=h<REF(L,1);
k5:=barslast(k4);
k7:=k2<K5;
k3:=backset(BARSTATUS=2 and k7,k2+1);
k6:=backset(BARSTATUS=2 and not(k7),k5+1);
k8:=filter(backset(BARSTATUS=2 ,if(k7,k2+1,k5+1)),1000);
STICKLINE((k3 and (llv(l,k2)>ref(h,k2+1) or k1)) or (BARSTATUS=2 and k1),ref(h,k2+1),ref(l,k2),28,0),ColorC0C0C0,ALIGN1,LAYER7;
STICKLINE((k6 and (hhv(h,k5)<REF(L,K5+1) or k4)),ref(l,k5+1),ref(h,k5),28,0),ColorC0C0C0,ALIGN1,LAYER7;
DRAWTEXT(k1,ref(h,1),”+ref(h,1)),Color0000FF,VALIGN0,ALIGN2,LINETHICK2;
DRAWTEXT(k1,ref(h,1),’-‘+l),Color0000FF,VALIGN0,LINETHICK2;
DRAWTEXT(k4,ref(l,1),’-‘+h),Color00FF00,VALIGN2,LINETHICK2;
DRAWTEXT(k4,ref(l,1),”+ref(l,1)),Color00FF00,VALIGN2,ALIGN2,LINETHICK2;

DRAWTEXTABS(0,40,’上涨家数:’+NUMTOSTRN(DYNAINFO(69),0)+’ 家’),COLOR0000FF;
DRAWTEXTABS(0,55,’下跌家数:’+NUMTOSTRN(DYNAINFO(70),0)+’ 家’),COLOR00FF00;
DRAWTEXTABS(0,69,’平盘家数:’+NUMTOSTRN(DYNAINFO(71),0)+’ 家’),COLORFFFFFF;

筹码分布(主图、源码、DLL、贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址