• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

趋势看盘 (主图,源码,有图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-08) 62次浏览 0个评论 扫描二维码

趋势看盘 (主图,源码,有图)介绍

GJ:=(C+H+L+O)/4;
明日阻力:=L+(GJ-L)+(C-L);
明日支撑:=L+(C-GJ);
明日阻力2:=L+2*(GJ-L)+(C-L);
明日支撑2:=L+(C-GJ)-(GJ-L);
今日阻力:CONST(REF(明日阻力 , 1)),NODRAW;
今日支撑:CONST(REF(明日支撑 , 1)),NODRAW;
今日阻力2:CONST(REF(明日阻力2 , 1)),NODRAW;
今日支撑2:CONST(REF(明日支撑2 , 1)),NODRAW;
STICKLINE(ISLASTBAR,今日阻力,今日阻力2,10,0),COLOR555555;
DRAWTEXT(ISLASTBAR,今日阻力,’ 阻’),COLOR0000FF;
STICKLINE(ISLASTBAR,今日支撑,今日支撑2,10,0),COLOR555555;
DRAWTEXT(ISLASTBAR,今日支撑,’ 支’),COLOR00FF00;
{DRAWBAND(EMA(C,3),RGB(150,150,100),EMA(C,21),RGB(60,100,60));}

B1:=REF(CLOSE,1);
B2:=REF(CLOSE,2);
B3:=REF(CLOSE,3);
B4:=REF(CLOSE,4);
CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3);
CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3);
持股:=(CLOSE=CMAX AND (B1>=B2 OR B1>=B3)) OR ((B1=CMAX AND (B2=CMIN OR B3=CMIN)) AND CLOSE>=B2) OR
(B2=CMAX AND B3=CMIN AND CLOSE>=B1) OR (B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2);
STICKLINE(持股,B1,CLOSE,3.5,0),COLOR000099;
变盘:=CLOSE=CMAX AND B1=CMIN;
STICKLINE(变盘,B2,CLOSE,3.5,0),COLOR0099EF;
下跌:=(CLOSE=CMIN AND (B1<B2 OR B1<B3)) OR ((B1=CMIN AND (B2=CMAX OR B3=CMAX)) AND CLOSE<B2) OR
(B2=CMIN AND B3=CMAX AND CLOSE<B1) OR (B3=CMIN AND CLOSE<B1 AND CLOSE<B2);
STICKLINE(下跌,B1,CLOSE,3.5,0),COLOR009900;
STICKLINE(B1=CMAX AND CLOSE=CMIN,B2,CLOSE,3.5,0),COLOR009900;
买入:=(B1=CMIN AND CLOSE>=B2) OR ((B2=CMIN AND B1<=B3) OR
(B3=CMIN AND B1<=B2) AND B2<B4 AND CLOSE>=B1);
STICKLINE(买入,B1,B2,3.5,0),COLOR00FFFF;
抛售:=(B1=CMAX AND CLOSE<B2) OR ((B2=CMAX AND B1>B3) OR
(B3=CMAX AND B1>B2) AND B2>=B4 AND CLOSE<B1);
STICKLINE(抛售,B1,B2,3.5,0),COLORFFFFFF;
STICKLINE(C>=O,L,H,0,1),COLORRED;
{STICKLINE(C>=O,O,L,0,1),COLORRED}
STICKLINE(C<O,H,L,0,1),COLORGREEN;
{STICKLINE(C<O,O,H,0,1),COLORGREEN;}
STICKLINE(持股 OR 买入,O,C,1.5,0),COLORRED;
STICKLINE(下跌 OR 抛售,O,C,1.5,0),COLORGREEN;
STICKLINE(C>0,O,C,0,0),COLORFFFFFF;
WR:=-100*(HHV(HIGH,28)-CLOSE)/(HHV(HIGH,28)-LLV(LOW,28));
DRAWICON(FILTER(CROSS(WR,(0 – 81)),10),B1,13);
DRAWICON(FILTER(CROSS((0 -19),WR),10),H*1.02,15);
DRAWTEXT(FILTER(CROSS(WR,(0 – 81)),21),L*0.99,’ W&R’),COLORRED;
DRAWTEXT(FILTER(CROSS(0 -19,WR),21),H*1.01,’ W&R’),COLORGREEN;
TAB:=CURRBARSCOUNT=58;
IF((BARSLAST(TAB)>35),REF((C*2-REF(C,3)),3),DRAWNULL),COLOR007777;

{}
MA5:=MA(C,5);
A:=(3*C+L+O+H)/6;
垂帘:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)
+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)
+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)
+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210,COLORRED,POINTDOT;
听股:=MA(垂帘,13),COLORFFCCCC,CIRCLEDOT;
ZAR1:=SLOPE(EMA(CLOSE,2),5)*15+C;
ZAR2:=EMA(ZAR1,5);
ZARA:=EMA(EMA(EMA(EMA(EMA(EMA(EMA(EMA(ZAR2,5),5),5),5),5),5),5),5);
ZARB:=BARSLAST(CROSS(CLOSE,ZARA));
ZARC:=BARSLAST(CROSS(ZARA,CLOSE));
STICKLINE(CLOSE<ZARA,REF(CLOSE,ZARC),REF(CLOSE,ZARC),12,0),LINETHICK2,COLOR00FF00;
STICKLINE(CLOSE>ZARA AND CLOSE>REF(CLOSE,ZARB),REF(CLOSE,ZARB),垂帘,0,-1),LINETHICK1,COLORMAGENTA;
STICKLINE(CLOSE>ZARA AND CLOSE>REF(CLOSE,ZARB),REF(CLOSE,ZARB),REF(CLOSE,ZARB),12,0),COLORMAGENTA,LINETHICK2;
STICKLINE(CLOSE<ZARA AND CLOSE<REF(CLOSE,ZARC),REF(CLOSE,ZARC),垂帘,0,-1),LINETHICK4,COLOR00FF00;

{}
VAR41:= EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3);
VAR42:=EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3);
VAR4A:=REF(VAR41,1)>92 AND VAR41<92;
DRAWTEXT(VAR4A,H+0.12,’短卖’),COLOR00FF00;
DRAWTEXT(VAR4A,H+0.05,’●’),COLOR00FF00;
{STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C<O,H,L,0,0),COLORFFFF52;
STICKLINE(C>=O,C,O,5,0),COLORRED;
STICKLINE(C<O,C,O,5,0),COLORFFFF52;}
MA13:=MA(C,13),COLORWHITE,LINETHICK2;
MA55:=MA(C,55),COLORFF00FF;
MA125:=MA(C,125),COLORFFCC66;
MA250:=MA(C,250),COLORBLUE;
DRAWTEXT(CROSS(MA5,听股) AND MA5>听股 AND C>O,MA13-0.12,’垂帘听股’),COLORYELLOW;
T:=BARSLAST(L>REF(H,1));
E:=COUNT(L<REF(H,T+1),T)<2;
DRAWTEXT(L<REF(H,T+1 ) AND E,L-0.12,’缺口回补’),COLOR0099FF;
VLL:=CROSS(MA(C,13),MA(C,21));
DRAWTEXT(VLL,MA13-0.12,’圆弧底’);
{}
EMA13:=EMA(C,13),COLORWHITE;
EMA21:=EMA(C,21),COLORYELLOW;
EMA34:=EMA(C,34),COLORFF00FF;
EMA60:=MA(C,60),COLORFFCC66;
VAR2:=(2*CLOSE+HIGH+LOW)/4;
VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,’←低吸’),COLORLIRED;
DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,’←高抛’),COLORGREEN;
DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1);
DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);
卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42);
B11:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA;
S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,14)COLORBLUE,LINETHICK2;
A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
看多:=IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};
逃顶:=IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};
买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;
卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3;
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

趋势看盘 (主图,源码,有图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址