• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

再次完善[给力ddx成交量]18:23终极修订(源码 副图 贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-08) 41次浏览 0个评论 扫描二维码

再次完善[给力ddx成交量]18:23终极修订(源码 副图 贴图)介绍

特别注明,始作俑者为九散人。本人仅仅为进一步完善。
九散人原作,开盘价等于收盘价的情况,不尽合理,尽管影响不大,但不够严谨。
本人将开盘价等于收盘价的情况分为3种情况:
一种为涨,则变通为开盘价等于最低价等于昨日收盘价;
一种为跌,则变通为开盘价等于最高价等于昨日收盘价;
一种平盘,则买卖成交量各一半。
这样处理,尽管仍不算100%严谨,但已经影响微乎其微了。
同时,本人不喜欢做买卖提示,故去除原作中买卖提示。
因为取自于理想论坛同学的理念,所以不敢独享,再此分享给大家,祝各位新春愉快!

预量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预量,0,-1,-1),COLOR00C0C0;
实量:VOL,VOLSTICK,COLORLIGREEN;
STICKLINE(C=REF(C,1),0,V,0,0),COLORYELLOW;
STICKLINE(C>REF(C,1) AND C<O,0,V,0,0),COLOR3232FF;
STICKLINE(C<REF(C,1) AND C>O,0,V,0,0),COLORFFFF54;

BASED:=IF(O!=C,VOL/((H-L)*2-ABS(C-O)),IF(C>REF(C,1), VOL/((H-REF(C,1))*2-ABS(C-REF(C,1))),VOL/((REF(C,1)-L)*2-ABS(C-REF(C,1)))));
BUY:=IF(C>O,BASED*(H-L),IF(C<O,BASED*((H-O)+(C-L)),IF(C>REF(C,1),BASED*(H-REF(C,1)),IF(C<REF(C,1),BASED*((REF(C,1)-REF(C,1))+(C-L)),V*0.5))));
SALE:=IF(C>O,BASED*((H-C)+(O-L)),IF(C<O,BASED*(H-L),IF(C>REF(C,1),BASED*((H-C)+(REF(C,1)-REF(C,1))),IF(C<REF(C,1),BASED*(REF(C,1)-L),V*0.5))));

买净值%:IF(BUY>=SALE,(BUY-SALE)/VOL*100,0),NODRAW;
卖净值%:IF(BUY<=SALE,(SALE-BUY)/VOL*100,0),NODRAW;
LEN:=IF(BUY>SALE,BUY-SALE,SALE-BUY);
STICKLINE(BUY>SALE,0,LEN,0.1,0),COLOR00F7F7;
STICKLINE(BUY<SALE,0,LEN,0.1,0),COLORFF1717;

DDX:=BUY-SALE;
MADDX:=MA(DDX,5)*5;
DDX1:SMA(MADDX,3,1),COLORFFFFFF,LINETHICK1;
DDX2:SMA(DDX1,3,1),COLORF100F1,LINETHICK1;
DDX3:SMA(DDX2,3,1),COLOR00D900,LINETHICK1

再次完善[给力ddx成交量]18:23终极修订(源码 副图 贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址