• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

牌威廉指标改进——冲顶探底WRR指标(副图、源码、贴图)

钱龙公式 第一股票指标公式网 1年前 (2019-10-08) 36次浏览 0个评论 扫描二维码

牌威廉指标改进——冲顶探底WRR指标(副图源码贴图)介绍

金牌威廉指标由三条不同时间周期的威廉指标线构成:
WR13:100*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,13));
WR34:100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34));
WR89:100*(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89));
其中每条传统的威廉指标线都是显示上底(极值为100)下顶(极值为0),和许多指标显示的上顶下底不一样,直接影响了大家的使用习惯,有必要将其改造为上顶下底模式。有的软件是在传统的威廉指标后面-100,变成了上顶(极值为0)下底(极值为-100)模式。研究后,我采用了100-传统威廉指标,形成上顶(极值为100)下底(极值为0)模式:100-(HHV(H,N)-C)/(HHV(H,N)-LLV(L,N))*100,换算后为(C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100。这正是KDJ指标第一句RSV的写法,难怪说KDJ指标是在威廉指标基础上发展起来的哈。
金牌威廉指标是比较三条短、中、长不同周期的威廉指标关系来研判股价运行趋势的指标,其中一条线、两条线、三条线冲顶撞底的作用是特有的,我进行了分别设置,形成了WRR指标。
改进后的金牌威廉指标源码如下:
WR1:(C-LLV(L,N1))/(HHV(H,N1)-LLV(L,N1))*100,COLORWHITE;
WR2:(C-LLV(L,N2))/(HHV(H,N2)-LLV(L,N2))*100,COLORYELLOW;
WR3:(C-LLV(L,N3))/(HHV(H,N3)-LLV(L,N3))*100,COLORMAGENTA;
WRH:=MAX(MAX(WR1,WR2),WR3);
WRL:=MIN(MIN(WR1,WR2),WR3);
WRDL:=MIN(MAX(ABS(WR1-WR2),ABS(WR1-WR3)),ABS(WR2-WR3));
STICKLINE(WR1>94,100,101,2,0),COLORWHITE;
STICKLINE(WRH>95 && WRDL<2 && WR2>80,100,101,2,0),COLORYELLOW;
STICKLINE(WRH>95 && WRL>90 && WRDL<2 && WR2>90,100,101,2,0),COLORMAGENTA;
STICKLINE(WR1<5,-1,0,2,0),COLORWHITE;
STICKLINE(WRL<5 && WRDL<0.5,-1,0,2,0),COLORYELLOW;
STICKLINE(WRL<5 && WRH<10 && WRDL<0.5,-1,0,2,0),COLORMAGENTA;
N1默认13,N2默认34,N3默认89.
下图为上证指数近期日线截图,附图上面为金牌威廉,下面为WRR指标。

牌威廉指标改进——冲顶探底WRR指标(副图、源码、贴图)


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址