• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把“判官主图”改为选股公式

常见公式 第一股票指标公式网 3周前 (10-04) 4次浏览 0个评论 扫描二维码

股友提问要求:

请老师把主图出现“买底”信号做出选股 谢谢 老师

{N1:=5;N2:=10;N3:=20;N4:=30;P:=2;M:=20;N:=250;M1:=55; W:=21;P3:=500;}
DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,’14’,0);
生命线:=MA(C,60);
牛熊线:=MA(C,120);
DRAWBAND(生命线,RGB(200,50,55),牛熊线,RGB(0,100,50));
DRAWKLINE(H,O,L,C);
MA1:EMA(CLOSE,N1),COLOR00FFFF;
MA2:EMA(CLOSE,N2),COLORFF00FF;
MA3:EMA(CLOSE,N3),COLORFFFFFF,LINETHICK2;
MA4:=EMA(CLOSE,N4),COLOR00FF00;
HR:=HHV(HIGH,M1);
HRY:=LLV(LOW,M1);
HRY11:=HR*HRY;
HRY33:=SQRT(HRY11),COLORGREEN,LINETHICK2;
TJ1:=CROSS(MA1,MA2) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA4) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA2,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018
OR CROSS(MA1,MA3) AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;
TJ2:=(MAX(MA1,MAX(MA2,MA3))-MIN(MA1,MIN(MA2,MA3)))/
MIN(MA1,MIN(MA2,MA3))*100D AND MACD>0 AND V>1,2,0),COLORRED;
做空:=IF(K<D AND MACD1,-2,0),COLOR00FF00;
强洗:=IF(MACD>0 AND K1,1,0),COLOR0099FF;
弱升:=IF(MACDD AND V>1,-1,0),COLORFFFF00;
STICKLINE(做多 AND C<O,C,O,3,0),COLOR990099;
STICKLINE(做多 AND C=O,C,O,3,1),COLOR00FF00;
STICKLINE(强洗 AND C<O,C,O,3,0),COLOR999999;
STICKLINE(强洗 AND C<O,C,O,0.3,0),COLORFFFFFF;
STICKLINE(弱升 AND CREF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5REF(PL5,1));
走强2:=BARSLAST(PL10REF(PL10,1));
走强3:=BARSLAST(PL20REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20REF(PL10,1) AND ZTJD5=1,H*1.02,’⑴’),COLORFF0000;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,’⑵’),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,’⑶’),COLOR00FF00;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,’⑷’),COLORFF00FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,’⑸’),COLOR00FF00;
DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,’〖Ⅰ〗’),COLORFF00FF;
DRAWTEXT(EX2 AND DTJD10=2,H*1.05,’〖Ⅱ〗’),COLOR00FF00;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,’〖Ⅲ〗’),COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,’①’),LINETHICK3,COLORFFFF00;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,’②’),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2)
AND EX2,H*1.03,’③’),LINETHICK3,COLOR00FF00;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,’④’),LINETHICK3,COLOR00FFFF;
WLA:=EN1 AND DTJZ5=1;
WLC:=EN2 AND ZTJZ5=1;
WLⅠ:=EN2 AND DTJZ10=1;
WLⅢ:=EN3 AND ZTJZ10=1;
WL⑵:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
WL⑷:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;
WL②:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
WL④:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3;
WLT01:=(WLA OR WLC) AND (WLⅠOR WLⅢ);
WLT02:=(WLA OR WLC) AND (WL⑵ OR WL⑷ OR WL② OR WL④);
WLT03:=(WLⅠOR WLⅢ) AND (WL⑵ OR WL⑷ OR WL② OR WL④);
WLT:=WLT01 OR WLT03 OR WLT02;
DRAWTEXT(WLT,LOW*0.90,’买底’),COLORYELLOW;

TJ11:=EN2 AND ZTJZ5=1;
TJ22:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
TJ33:=EN2 AND DTJZ10=1;
TJ44:=EN3 AND ZTJZ10=1;
TJ55:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
XG22:=TJ11 OR TJ22 OR TJ33 OR TJ44 OR TJ55;

X1:=REF(C,1)/HHV(H,20)0.67;
X3:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)<0.33;
X4:=ABS(C-O)/CC;
X5:=COUNT(DOWN,7)>=5;
XG8:=X1 AND X2 AND X3 AND X4 AND X5;
DRAWTEXT(XG8,L*0.98,’←螺’),COLOR00FFFF;
AA:=REF(C,1)/REF(O,1)1.03;
CC:=C>REF(O,1);
TJ81:=AA AND BB AND CC;
X81:=REF(C,1)/HHV(H,20)C;
X82:=COUNT(DN,7)>=5;
X83:=C=HHV(C,3);
XG81:=TJ81 AND X81 AND X82;
XG82:=X81 AND X82 AND X83;
XG88:=XG81 OR XG82;
DRAWTEXT(XG88,L*0.96,’反’),COLOR00FFFF;

IF(生命线>=牛熊线,生命线,DRAWNULL),COLORRED;
IF(牛熊线>=生命线,牛熊线,DRAWNULL),COLORFF9900;
IF(生命线>=牛熊线,牛熊线,DRAWNULL),COLOR00FFFF;
IF(牛熊线>=生命线,生命线,DRAWNULL),COLOR00FF00;
S1:=REF(C,1)/LLV(L,W)>1.30;
S2:=(H-MAX(C,O))/(H-L)>0.60;
S3:=ABS(C-O)/C0.05 AND C0.05 AND C<O;
SAL3:=S1 AND ABS(C-O)/C0.67 AND C<O AND S3;
SAL:=SAL1 OR SAL2 OR SAL3 OR SAL4 OR SAL5;

LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4.1,1)/SMA(ABS(CLOSE-LC),4.1,1)*100;
黄买:=FILTER((REF(CLOSE,2)<CLOSE AND RSICLOSE AND RSI>80),7);
红买:=FILTER(CROSS(RSI,11),7);
红卖:=FILTER(CROSS(89,RSI),7);
绿买:=FILTER(CROSS(RSI,20),7);
绿卖:=FILTER(CROSS(80,RSI),7);
SL1:=红卖 AND 绿卖;
SL2:=红卖 AND 绿卖 AND 黄卖;
BU:=红买 AND 绿买;
SS1:=CROSS(MA(C,5),C);
SS2:=(REF(C,1)-C)/REF(C,1)>0.04;
SS3:=O<REF(C,1);
JJ1:=SS1 AND SS2 AND SS3;
SSL:=JJ1 AND S1;
SAL8:=FILTER(SAL OR SSL,5);
DRAWTEXT(SAL8 AND SL1 AND SL2,H*1.02,'卖'),COLOR00FF00;

E1:=BARSCOUNT(C);
AH:=HHV(H,200);
AL:=LLV(L,200);
B0:=(AH-AL)/40;
KB1:=H+B0;
KB2:=L-B0;
SJCK:=(E1+0)/34=FLOOR((E1+0)/34);
STICKLINE(SJCK,KB2,KB2-0.8*B0,1,0),COLORYELLOW,LINETHICK3;
DRAWTEXT(SJCK,KB2-B0,'时'),COLORYELLOW;
SJ:=EXIST(SJCK,5);
{J线中线共振买点}
RSV55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,LINETHICK2;
K55:=SMA(RSV55,2,1),NODRAW;
D55:=SMA(K55,2,1),NODRAW;
J55:=3*K55-2*D55,COLORFF00FF,LINETHICK1;
RSV89:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,LINETHICK2;
K89:=SMA(RSV89,2,1),NODRAW;
D89:=SMA(K89,2,1),NODRAW;
J89:=3*K89-2*D89,COLOR0000FF,LINETHICK2;
AB1:=LONGCROSS(J55,10,5);
AB2:=LONGCROSS(J89,10,5);
GZBT1:=FILTER(COUNT(AB1 OR AB2,2)=2,2);
GZBT2:=AB2 AND AB1;
GZBT:=GZBT1 OR GZBT2;
DRAWTEXT(GZBT,L*0.965,'◆J振'),COLORFF00FF;

P1:=5;
P2:=10;
P3:=20;
P4:=30;
P5:=60;
P6:=120;
P7:=240;
P8:=340;
N:=4;
WX:=MA(CLOSE,0);
M1:=MA(CLOSE,P1);
M2:=(MA(CLOSE,P2) * IF((N < 2),WX,1));
M3:=(MA(CLOSE,P3) * IF((N < 3),WX,1));
M4:=(MA(CLOSE,P4) * IF((N < 4),WX,1));
M5:=(MA(CLOSE,P5) * IF((N < 5),WX,1));
M6:=(MA(CLOSE,P6) * IF((N < 6),WX,1));
M7:=(MA(CLOSE,P7) * IF((N < 7),WX,1));
M8:=(MA(CLOSE,P8) * IF((N < 8),WX,1));
C1:=REF(CLOSE,1);
C2:=HHV(C1,2);
C3:=LLV(C1,1);
ET:=HHV(C1,2);
ET1:=REF(ET,1);
XB:=LLV(C1,1);
XB1:=REF(XB,1);
M:=BARSLAST(((CLOSE = XB1)));
M11:=REF(M,1);
N9:=BARSLAST(((CLOSE > ET) AND (C1 0) AND (M11 0) AND (N1 0) AND (M11 0) AND (N1 0),CLOSE,ET2);
H2:=IF((A = 1),CLOSE,C2);
H3:=IF(((M – N9) 0) OR (A = 1)),CLOSE,H3);
H6:=REF(H5,1);
H7:=REF(H5,2);
H8:=(H5 > H6);
H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) REF(H5,2)));
H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));
W:=((H8 OR H9) OR H10);
T9:=((H5 < H6) AND (H5 < REF(H5,2)));
T10:=((H4 = REF(H4,1)) AND (H5 REF(H3,1)) AND (H5 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));
BBP:=(((CLOSE – LLV(LOW,9)) / (HHV(HIGH,9) – LLV(LOW,9))) * 100);
DRAWTEXT((ISLASTBAR AND (BBP >= 96.5)),(H5 * 1.033),’明见短高,龙头除外’),COLOR00FF00;
DRAWTEXT((ISLASTBAR AND (BBP < 1)),((H5 + H4) / 1.96),'明见短低,跌停除外'),COLOR0000FF;
DRAWTEXT(((ISLASTBAR AND W) AND (BBP 1)),((H5 + H4) / 2),’看跌’),COLOR00FF00;
DRAWTEXT_FIX(1,0.0,0.00,0,EXTERNSTR(0,1))COLOR0077FF;
DRAWTEXT_FIX(1,0.0,0.98,0,’★五里理念★:严守纪律, 趋势为先,波段操作, 坚决止损! ‘),COLOR0078FF;

171415.com解答:

 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
DIFF:= EMA(CLOSE,12) – EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
做多:=IF(K>D AND MACD>0 AND V>1,2,0);
做空:=IF(K<D AND MACD<0 AND V>1,-2,0);
强洗:=IF(MACD>0 AND K<D AND V>1,1,0);
弱升:=IF(MACD<0 AND K>D AND V>1,-1,0);
 
GET:=ZIG(3,3);
PL5:=ZIG(3,5);
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
PL40:=ZIG(3,40);
走强1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走强2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走强3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
 
WLA:=EN1 AND DTJZ5=1;
WLC:=EN2 AND ZTJZ5=1;
WLⅠ:=EN2 AND DTJZ10=1;
WLⅢ:=EN3 AND ZTJZ10=1;
WL⑵:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;
WL⑷:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;
WL②:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2;
WL④:=EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3;
WLT01:=(WLA OR WLC) AND (WLⅠOR WLⅢ);
WLT02:=(WLA OR WLC) AND (WL⑵ OR WL⑷ OR WL② OR WL④);
WLT03:=(WLⅠOR WLⅢ) AND (WL⑵ OR WL⑷ OR WL② OR WL④);
A:=WLT01 OR WLT03 OR WLT02;
A;

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址