• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

自编公式选股:同时设置不同周期条件

常见公式 第一股票指标公式网 3周前 (10-04) 10次浏览 0个评论 扫描二维码

股友提问要求:

现请教一个问题,盼指导,不胜感激!!!!
我在选股时,想在一个条件中筛选出:1分钟金MACD叉并且同时5分钟MACD的DIFF>=DEA 学着编了个公式,但使用时好像1分金叉满足时,有的5分钟DIFF>=DEA没有同时满足,请教是公式编错了,还是其他问题,盼回复!!!!
公式付上:
DIFF1:=”MACD.DIFF# MIN1″(30,6,3);
DEA1:=”MACD.DEA# MIN1″(30,6,3);

DIFF5:=”MACD.DIFF# MIN5″(30,6,3);
DEA5:=”MACD.DEA# MIN5″(30,6,3);

金叉1:=CROSS(DIFF1,DEA1);
金叉5:=CROSS(DIFF5,DEA5);

XG:(金叉1 AND DIFF5>=DEA5) OR (金叉5 AND DIFF1>=DEA1);

股票池周期选择:1分钟

171415.com解答:

 DIFF1:="MACD.DIFF# MIN1"(30,6,3);

DEA1:="MACD.DEA# MIN1"(30,6,3);
 
DIFF5:="MACD.DIFF# MIN5"(30,6,3);
DEA5:="MACD.DEA# MIN5"(30,6,3);
 
金叉1:=CROSS(DIFF1,DEA1);
金叉5:=CROSS(DIFF5,DEA5);
 
XG:(金叉1 AND DIFF5>=DEA5) and (金叉5 AND DIFF1>=DEA1);
 
 
 

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址