• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

将7日线加涨停板回调的主图改为通达信可用的主图

常见公式 第一股票指标公式网 4周前 (10-06) 7次浏览 0个评论 扫描二维码

股友提问要求:

MA7:EMA(CLOSE,7);
M7:EMA(CLOSE,7);
MID:MA(CLOSE,20);
上轨:MID+2*STD(CLOSE,20),DOTLINE;
下轨:MID-2*STD(CLOSE,20),DOTLINE;

g1:=BARSLAST(CLOSE/REF(CLOSE,1)>=1.099);
g2:=ref(c,g1);
g3:=ref(o,g1);
HORILINE(g2 and g1<13,g2,20),LINETHICK2,COLORYELLOW;
HORILINE(g3 and g1<13,g3,20),LINETHICK2,COLORYELLOW;

涨停:=IF(REF(C,1)*1.1-C=1,1);
STICKLINE(涨停 AND COUNT(涨停,13)>=1,c,o,4.5,0),COLORYELLOW;
DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,h*1.015,’涨’),COLORYELLOW,LINETHICK2;
DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,h*1.028,’停’),COLORYELLOW;

V1:=v/ma(ref(v,1),5);V2:=indexv/ma(ref(indexv,1),5);v0:=v1/v2;

d4:=WINNER(c)*100;
s2:=WINNER(ref(c,1))*100;
d1:=oma7 and EMA(CLOSE,17)>ref(EMA(CLOSE,17),1) and hh;
DRAWTEXT(d1>0,l*0.98,’启动’),COLORYELLOW;
f1:=(d4>s2+20 or (cross(d4,86) and ref(d4,1)0 and c>ref(g2,1),l,’强势’),COLORYELLOW;

DIFF1:=EMA(INDEXC,12)-EMA(INDEXC,26);
DEA1 :=EMA(DIFF1,9);
MACD1:=2*(DIFF1-DEA1);
大盘:MACD1-REF(MACD1,1),LINETHICK0;
DRAWFLAGTEXT(大盘>0,l,’大盘稳健’),COLORYELLOW,LINETHICK5;
DRAWFLAGTEXT(大盘<0,l,'大盘风险'),DOTLINE,LINETHICK5;

171415.com解答:

 MA7:EMA(CLOSE,7);

M7:EMA(CLOSE,7);
MID:MA(CLOSE,20);
上轨:MID+2*STD(CLOSE,20),DOTLINE;
下轨:MID-2*STD(CLOSE,20),DOTLINE;
 
G1:=BARSLAST(CLOSE/REF(CLOSE,1)>=1.099);
G2:=REF(C,G1);
G3:=REF(O,G1);
IF(G1<=13,G2,DRAWNULL),COLORYELLOW,CIRCLEDOT;
STICKLINE(G1<=13,G2,G2,4,0),COLORYELLOW;
IF(G1<=13,G3,DRAWNULL),COLORYELLOW,CIRCLEDOT;
STICKLINE(G1<=13,G3,G3,4,0),COLORYELLOW;
 
涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);
HH:=REF(COUNT(涨停,13)>=1,1);
STICKLINE(涨停 AND COUNT(涨停,13)>=1,C,O,4.5,0),COLORYELLOW;
DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,H*1.015,’涨’),COLORYELLOW,LINETHICK2;
DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,H*1.028,’停’),COLORYELLOW;
 
V1:=V/MA(REF(V,1),5);V2:=INDEXV/MA(REF(INDEXV,1),5);V0:=V1/V2;
 
D4:=WINNER(C)*100;
S2:=WINNER(REF(C,1))*100;
D1:=O<MA7 AND C>MA7 AND EMA(CLOSE,17)>REF(EMA(CLOSE,17),1) AND HH;
DRAWTEXT(D1>0,L*0.98,’启动’),COLORYELLOW;
F1:=(D4>S2+20 OR (CROSS(D4,86) AND REF(D4,1)<80)) AND HH;
DRAWTEXT(F1>0 AND C>REF(G2,1),L,’强势’),COLORYELLOW;
 
DIFF1:=EMA(INDEXC,12)-EMA(INDEXC,26);
DEA1 :=EMA(DIFF1,9);
MACD1:=2*(DIFF1-DEA1);
大盘:MACD1-REF(MACD1,1),NODRAW;
DRAWTEXT_FIX(大盘>0 AND ISLASTBAR,0.005,0,0,’大盘稳健’),COLORYELLOW;
DRAWTEXT_FIX(大盘<0 AND ISLASTBAR,0.005,0,0,’大盘风险’),COLORYELLOW;

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址