• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

从最高点跌幅在10%或以上的选股公式

常见公式 第一股票指标公式网 4周前 (10-06) 9次浏览 0个评论 扫描二维码

股友提问要求:

高手老师们 好 有个思路请帮忙编写个选股公式 通达信大智慧皆可 我是用通达信的

股价当日最高价开始 下跌等于或超过10%

比如当日最高价是10元 ,后面的股价走式,不论走多少天 ,不论阴阳,只要跌幅等于或超过10%
就出个选股信号,

如果对定义的最高价跌幅没有过10%时 股价又创出新高超过了前个定义的 最高价 就从新开始计算

171415.com解答:

 

 
【选股】
波峰天数1:=PEAKBARS(1,10,1);
波峰值1:=REF(H,波峰天数1);
XG1:=CROSS(COUNT(CROSS(L<=波峰值1*0.9,0.5),波峰天数1)=1,0.5);
XX:=BARSLAST(XG1);
YY:=HHV(H,XX);
GD:=(YY>REF(YY,1) OR YY<REF(YY,1)) AND YY=REFX(YY,1);
FF:=BARSLAST(GD);
波峰值2:=REF(H,FF);
II:=(波峰值2>REF(波峰值2,1) OR 波峰值2<REF(波峰值2,1)) AND 波峰值2=REFX(波峰值2,1);
波峰天数2:=BARSLAST(II);
XG2:=CROSS(COUNT(CROSS(L<=REF(波峰值2*0.9,波峰天数2) AND 波峰天数2>0,0.5),波峰天数2)=1,0.5);
XXX:=BARSLAST(XG2);
YYY:=HHV(H,XXX);
GDD:=(YYY>REF(YYY,1) OR YYY<REF(YYY,1)) AND YYY=REFX(YYY,1);
FFF:=BARSLAST(GDD);
波峰值3:=REF(H,FFF);
III:=(波峰值3>REF(波峰值3,1) OR 波峰值3<REF(波峰值3,1)) AND 波峰值3=REFX(波峰值3,1);
波峰天数3:=BARSLAST(III);
XG3:=CROSS(COUNT(CROSS(L<=波峰值3*0.9,0.5),波峰天数3)=1,0.5);
XXXX:=BARSLAST(XG3);
YYYY:=HHV(H,XXXX);
GDDD:=(YYYY>REF(YYYY,1) OR YYYY<REF(YYYY,1)) AND YYYY=REF(YYYY,1);
FFFF:=BARSLAST(GDDD);
波峰值4:=REF(H,FFFF);
IIII:=(波峰值4>REF(波峰值4,1) OR 波峰值4<REF(波峰值4,1)) AND 波峰值4=REFX(波峰值4,1);
波峰天数4:=BARSLAST(IIII);
XG4:=CROSS(COUNT(CROSS(L<=波峰值4*0.9,0.5),波峰天数4)=1,0.5);
XXXXX:=BARSLAST(XG4);
YYYYY:=HHV(H,XXXXX);
GDDDD:=(YYYYY>REF(YYYYY,1) OR YYYYY<REF(YYYYY,1)) AND YYYYY=REFX(YYYYY,1);
FFFFF:=BARSLAST(GDDDD);
波峰值5:=REF(H,FFFFF);
IIIII:=(波峰值5>REF(波峰值5,1) OR 波峰值5<REF(波峰值5,1)) AND 波峰值5=REFX(波峰值5,1);
波峰天数5:=BARSLAST(IIIII);
XG5:=CROSS(COUNT(CROSS(L<=波峰值5*0.9,0.5),波峰天数5)=1,0.5);
XG1 OR XG2 OR XG3 OR XG4 OR XG5;
 
【主图或副图:黄横线为跌幅达到10%价格,用数字标明,低于此价用绿色实体显示K线】
波峰天数1:=PEAKBARS(1,10,1);
波峰值1:=REF(H,波峰天数1);
XG1:=CROSS(COUNT(CROSS(L<=波峰值1*0.9,0.5),波峰天数1)=1,0.5);
XX:=BARSLAST(XG1);
YY:=HHV(H,XX);
GD:=(YY>REF(YY,1) OR YY<REF(YY,1)) AND YY=REFX(YY,1);
FF:=BARSLAST(GD);
波峰值2:=REF(H,FF);
II:=(波峰值2>REF(波峰值2,1) OR 波峰值2<REF(波峰值2,1)) AND 波峰值2=REFX(波峰值2,1);
波峰天数2:=BARSLAST(II);
XG2:=CROSS(COUNT(CROSS(L<=REF(波峰值2*0.9,波峰天数2) AND 波峰天数2>0,0.5),波峰天数2)=1,0.5);
XXX:=BARSLAST(XG2);
YYY:=HHV(H,XXX);
GDD:=(YYY>REF(YYY,1) OR YYY<REF(YYY,1)) AND YYY=REFX(YYY,1);
FFF:=BARSLAST(GDD);
波峰值3:=REF(H,FFF);
III:=(波峰值3>REF(波峰值3,1) OR 波峰值3<REF(波峰值3,1)) AND 波峰值3=REFX(波峰值3,1);
波峰天数3:=BARSLAST(III);
XG3:=CROSS(COUNT(CROSS(L<=波峰值3*0.9,0.5),波峰天数3)=1,0.5);
XXXX:=BARSLAST(XG3);
YYYY:=HHV(H,XXXX);
GDDD:=(YYYY>REF(YYYY,1) OR YYYY<REF(YYYY,1)) AND YYYY=REF(YYYY,1);
FFFF:=BARSLAST(GDDD);
波峰值4:=REF(H,FFFF);
IIII:=(波峰值4>REF(波峰值4,1) OR 波峰值4<REF(波峰值4,1)) AND 波峰值4=REFX(波峰值4,1);
波峰天数4:=BARSLAST(IIII);
XG4:=CROSS(COUNT(CROSS(L<=波峰值4*0.9,0.5),波峰天数4)=1,0.5);
XXXXX:=BARSLAST(XG4);
YYYYY:=HHV(H,XXXXX);
GDDDD:=(YYYYY>REF(YYYYY,1) OR YYYYY<REF(YYYYY,1)) AND YYYYY=REFX(YYYYY,1);
FFFFF:=BARSLAST(GDDDD);
波峰值5:=REF(H,FFFFF);
IIIII:=(波峰值5>REF(波峰值5,1) OR 波峰值5<REF(波峰值5,1)) AND 波峰值5=REFX(波峰值5,1);
波峰天数5:=BARSLAST(IIIII);
XG5:=CROSS(COUNT(CROSS(L<=波峰值5*0.9,0.5),波峰天数5)=1,0.5);
标的价:IF(XG1,REF(H*0.9,波峰天数1),IF(XG2,REF(H*0.9,波峰天数2),
IF(XG3,REF(H*0.9,波峰天数3),IF(XG4,REF(H*0.9,波峰天数4),
IF(XG5,REF(H*0.9,波峰天数5),DRAWNULL))))),NODRAW;
STICKLINE(XG1,标的价,标的价,5,0),COLORYELLOW;
STICKLINE(XG2,标的价,标的价,5,0),COLORYELLOW;
STICKLINE(XG3,标的价,标的价,5,0),COLORYELLOW;
STICKLINE(XG4,标的价,标的价,5,0),COLORYELLOW;
STICKLINE(XG5,标的价,标的价,5,0),COLORYELLOW;
STICKLINE(XG1 OR XG2 OR XG3 OR XG4 OR XG5 ,标的价,L,0,0),COLORGREEN;
STICKLINE((XG1 OR XG2 OR XG3 OR XG4 OR XG5) AND MIN(C,O)<标的价,标的价,MIN(C,O),2.5,0),COLORGREEN;
 

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址