• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把虎口指标中出现二金信号改成选股公式

常见公式 第一股票指标公式网 4周前 (10-06) 4次浏览 0个评论 扫描二维码

股友提问要求:

请老师把虎口指标中出现二金信号改成选股公式,谢谢,源码如下
A0:=(2*C+H+L)/4;
均线:=MA(A0,3)>REF(MA(A0,3),1);
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
A2:=EMA(WINNER(C)*100,5);
A3:=MA(SMA(C-REF(C,1),3,1)/SMA(H-REF(C,1),3,1),3)*100;
K:MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3),LINETHICK1,COLORWHITE;
D:MA(K,3),COLORYELLOW,LINETHICK1;
J:3*K-2*D,COLORYELLOW,LINETHICK1;
A4:=SMA(MAX(C-REF(C,2),0),6,1)/SMA(ABS(C-REF(C,2)),6,1)*100;
A5:=MA(3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1)-2*SMA(SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1),3,1),3);
低吸:IF(CROSS(A4,14) OR A5>REF(A5,1) AND CROSS(K,A2)AND K80 AND CROSS(95,K),85,100);
入虎穴:K<5 AND LLV(C,3)/HHV(C,20)0.9 AND K<50;
A7:=CROSS(K,D)AND D<10 OR CROSS(K,D)AND CROSS(K,A5)AND DREF(K,1),5)AND 均线 ,D,’金叉’);
DRAWTEXT(CROSS(D,K)AND CROSS(A5,K)AND D>85,D,’死叉’);
DRAWTEXT(FILTER(K>REF(K,1)AND (CROSS(K,10)OR CROSS(K,A2))AND COUNT(A4=1,3),15,’抱虎仔’);
无限风光:A2>85 AND K>85 OR A2>90 OR K>90,LINETHICK0,COLORLIGRAY;
STICKLINE(无限风光,MAX(A2,K),100,5,1),COLORLIGRAY;
DRAWICON(CROSS(A3,-300)AND K<10,5,1);
A8:=BARSLAST(REF(CROSS(K,D),1));
二金:=(A8<15 AND DREF(K,A8+1) AND CROSS(K,D)AND A5<60);
DRAWTEXT(二金 AND 均线,K,'二金'),COLORYELLOW;
A9:=LLV(C,2)<REF(LLV(C,15),2);
DRAWTEXT(二金 AND A9,K,'底背离'),COLORRED;
DRAWTEXT(LONGCROSS(J,K,7)AND CROSS(J,A2)AND A2REF(A2,1),K,’穿三线’),COLORMAGENTA;
DRAWTEXT(CROSS(84,A4)AND CROSS(K,A4),90,’虎口’),COLOR00FF00;
A10:=MA((A0-MA(A0,13))/(0.15*AVEDEV(A0,13)),3);
DRAWICON(CROSS(A10,-15)AND J>REF(J,1),5,1);
DRAWICON(CROSS(20,A10),100,2);
IF(K<REF(K,1),K,DRAWNULL),COLORGREEN,LINETHICK1;
IF(D<REF(D,1),D,DRAWNULL),COLORGREEN,LINETHICK1;
IF(JREF(K,1),K,DRAWNULL),COLORRED,LINETHICK1;
IF(D>REF(D,1),D,DRAWNULL),COLORRED,LINETHICK1;

171415.com解答:

 A0:=(2*C+H+L)/4;

均线:=MA(A0,3)>REF(MA(A0,3),1);
A1:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
K:=MA(3*SMA(A1,6,1)-2*SMA(SMA(A1,5,1),5,1),3);
D:=MA(K,3);
A5:=MA(3*SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1)-2*SMA(SMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21))*100,5,1),3,1),3);
A8:=BARSLAST(REF(CROSS(K,D),1));
二金:=(A8<15 AND D<50 AND K>REF(K,A8+1) AND CROSS(K,D)AND A5<60);
选股:二金 AND 均线;

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址