• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把"波段趋势"公式修改成通达信的

常见公式 第一股票指标公式网 3周前 (10-07) 5次浏览 0个评论 扫描二维码

股友提问要求:

原版是同花顺的…源码如下:
波段趋势
DRAWGBK(DATE>900101,STRIP(RGB(160,60,230),RGB(0,0,0),0));
VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,89))/(HHV(H,89)-LLV(L,89))*100,5,1)-2*SMA(SMA((C-LLV(L,89))/(HHV(H,89)-LLV(L,89))*100,5,1),3,1);
趋势:EMA(VAR3,3)-10,colorcyan;
A10:IF(趋势>80,趋势,80),colorred,LINETHICK2;
DRAWICON(CROSS(趋势,0),0,1);

主力资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), colorred,LINETHICK2;
即将爆发线: 65,color00FFFF;
爆发线:80,color0000FF,LINETHICK1;
DRAWTEXT(CROSS(趋势,爆发线),主力资金,’★小心!’) ,coloryellow,LINETHICK3;
爆发警戒线: 50,COLOR00FF00;
抄底线:20,colorFFOO00,LINETHICK2;
DRAWTEXT(CROSS(趋势,抄底线),趋势,’★抄底’) ,coloryellow;
DRAWTEXT(CROSS(趋势,爆发警戒线),趋势,’★加仓’) ,coloryellow;
DRAWTEXT(CROSS(趋势,即将爆发线),趋势,’★加仓’) ,coloryellow;
DRAWTEXT(CROSS(爆发线,趋势),爆发线,’★空仓’) ,colorwhite;
DRAWTEXT(CROSS(即将爆发线,趋势),即将爆发线,’★减仓’) ,colorwhite;
DRAWTEXT(CROSS(即将爆发线,趋势),即将爆发线,’★减仓’) ,colorwhite;

安全提示:如果聊天中有涉及财产的操作,请一定先核实好友身份。发送验证问题或点击举报
神马腾飞 17:20:52
LC:= REF(C,1);
F1:=ZIG(3,15);
方向:IF((F1> REF(F1,1)),5,105),COLORFF08FF,LINETHICK2, CIRCLEDOT;
DRAWTEXT(CROSS(抄底线,方向),抄底线,’★逢低进场!’) ,colorred;
DRAWTEXT(CROSS(方向,抄底线),方向+20,’★逢高出场!’) ,colorwhite;

Var11:=EMA(HHV(HIGH,500),21);
Var22:=EMA(HHV(HIGH,250),21);
F1:=ZIG(3,15);
方向:IF((F1> REF(F1,1)),0,105),COLOR00FFFF,LINETHICK2, CIRCLEDOT;

80,colorred;20;
Var1:=HHV(HIGH,9)-LLV(LOW,9);
Var2:=HHV(HIGH,9)-CLOSE;
Var3:=CLOSE-LLV(LOW,9);
Var4:=Var2/Var1*100-70;
Var5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60));
Var6:=(2*CLOSE+HIGH+LOW)/4;
Var7:=SMA(Var3/Var1*100,3,1);
Var8:=LLV(LOW,34);
Var9:=SMA(Var7,3,1)-SMA(Var4,9,1);
Var10:=IF(Var9>100,Var9-100,0);
Var11:=HHV(HIGH,34);
Var12:=EMA((Var6-Var8)/(Var11-Var8)*100,13);
Var13:=EMA(0.667*REF(Var12,1)+0.333*Var12,2);
差值:(Var12-Var13)*5,POINTDOT,COLOR33CC00;
STICKLINE(差值>=0,0,差值*1,4,0),color0000ff;
STICKLINE(差值>=0,0,差值*0.8,4,0),color0066ff;
STICKLINE(差值>=0,0,差值*0.6,4,0),color0099ff;
STICKLINE(差值>=0,0,差值*0.4,4,0),color00ccff;
STICKLINE(差值>=0,0,差值*0.2,4,0),color00ffff;
STICKLINE(差值<=0,0,差值*1,4,0),colorgreen;
STICKLINE(差值<=0,0,差值*0.8,4,0),COLOR33CC00;
STICKLINE(差值<=0,0,差值*0.6,4,0),COLOR339900;
STICKLINE(差值<=0,0,差值*0.4,4,0),COLOR337700;
STICKLINE(差值29980715) XXX:=0 ;
ELSE XXX:=1;
VAR1:=HHV(HIGH,3);
VAR2Q:=REF(LOW,1);
VAR3Q:=((SMA(ABS((LOW – VAR2Q)),3,1) / SMA(MAX((LOW – VAR2Q),0),3,1)) * 100);
VAR4Q:=EMA(IF((CLOSE * 1.3),(VAR3Q * 10),(VAR3Q / 10)),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=((EMA(IF((LOW 100),100,VAR8Q);
STICKLINE((VAR9Q > (0 – 120)),0,VAR9Q,8,1),colorbrown;
VAR2:=((IF((WINNER((1.1 * CLOSE)) < 0),0,WINNER((1.1 * CLOSE))) – IF((WINNER((0.9 * CLOSE)) < 0),0,WINNER((0.9 * CLOSE)))) * 100);
VAR3:=IF((VAR1 < 0),0,VAR1);
VAR4:=IF((VAR2 9 AND FILTER(VTD120 AND FILTER(VTD120,10);
WEIX:= VTD2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),Linethick0;
红色警报A:STICKLINE(VTD2 AND FILTER(VTD1< REF(VTD1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VTD1+6,0,2,0);
VTDTJ:=SHD AND LDD AND WEIX;
STICKLINE(卖出A,60,100,2,0),LINETHICK2,color0000FF;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((((CLOSE – V1) / (V2 – V1)) * 4),4);
STICKLINE(CROSS(价位线,0.3),50,5,2,0),color00CCFF;
STICKLINE(CROSS(价位线,0.3),30,5,2,0),color0000FF;
卖出:STICKLINE(VTDTJ,60,100,2,0),color0000FF;
STICKLINE(红色警报A,60,100,2,0),color00FFFF;
STICKLINE(CROSS(3.5,价位线),80,100,2,0),colorFF9900;
AA3:=((((HHV(HIGH,21) – CLOSE) / (HHV(HIGH,21) – LLV(LOW,21))) * 100) – 10);
AA4:=(((CLOSE – LLV(LOW,21)) / (HHV(HIGH,21) – LLV(LOW,21))) * 100);
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8)*xxx;
STICKLINE(VTDTJ,60,100,5,0),colorgreen;
STICKLINE(VTDTJ,60,100,5,0),colorgreen;
JY0:=(3*C+H+L)/5;
流通盘:=IF(C-3,顶A4,-3);
大顶:= IF(顶B4>22,顶B4,22);
t9h:=IF(顶A4>22,顶A4,22);
小底:= IF(底A4<25,底A4,25);
t9l:=IF(底a4<0,底A4,0)*5;
大底:= IF(底B422 AND 顶A4>22,10)*xxx;
DRAWTEXT(t9h1*xxx,80,’SELL’);
STICKLINE(((走势 – AA6) > 85) OR “天狼剑_9.t9h”*5*xxx>110,98,90,15,1),color00aaaa;

VARA:=IF(MONTH<12,1,1);
VARB:=(2*CLOSE+HIGH+LOW)/4;
VARC:=LLV(LOW,34);
VARD:=HHV(HIGH,34);
主力A:EMA((VARB-VARC)/(VARD-VARC)*120,13)*VARA,LINETHICK1,colorred;
散户A:EMA(0.667*REF(主力A,1)+0.333*主力A,4),LINETHICK1,COLORFF9933;
FILLRGN((主力A*1),(散户A*1),主力A散户A,RGB(250,250,0));

171415.com解答:

 VAR1:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);

VAR2:=EMA(VAR1,8);
VAR3:=3*SMA((C-LLV(L,89))/(HHV(H,89)-LLV(L,89))*100,5,1)-2*SMA(SMA((C-LLV(L,89))/(HHV(H,89)-LLV(L,89))*100,5,1),3,1);
趋势:EMA(VAR3,3)-10,COLORCYAN;
A10:IF(趋势>80,趋势,80),COLORRED,LINETHICK2;
DRAWICON(CROSS(趋势,0),0,1);
 
主力资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED,LINETHICK2;
即将爆发线: 65,COLOR00FFFF;
爆发线:80,COLOR0000FF,LINETHICK1;
DRAWTEXT(CROSS(趋势,爆发线),主力资金,’★小心!’) ,COLORYELLOW,LINETHICK3;
爆发警戒线: 50,COLOR00FF00;
抄底线:20,COLORFF0000,LINETHICK2;
DRAWTEXT(CROSS(趋势,抄底线),趋势,’★抄底’) ,COLORYELLOW;
DRAWTEXT(CROSS(趋势,爆发警戒线),趋势,’★加仓’) ,COLORYELLOW;
DRAWTEXT(CROSS(趋势,即将爆发线),趋势,’★加仓’) ,COLORYELLOW;
DRAWTEXT(CROSS(爆发线,趋势),爆发线,’★空仓’) ,COLORWHITE;
DRAWTEXT(CROSS(即将爆发线,趋势),即将爆发线,’★减仓’) ,COLORWHITE;
DRAWTEXT(CROSS(即将爆发线,趋势),即将爆发线,’★减仓’) ,COLORWHITE;
 
 
 
 
 
 
LC:= REF(C,1);
F1:=ZIG(3,15);
方向:IF((F1> REF(F1,1)),5,105),COLORFF08FF,LINETHICK2, CIRCLEDOT;
DRAWTEXT(CROSS(抄底线,方向),抄底线,’★逢低进场!’) ,COLORRED;
DRAWTEXT(CROSS(方向,抄底线),方向+20,’★逢高出场!’) ,COLORWHITE;
 
VAR11:=EMA(HHV(HIGH,500),21); 
VAR22:=EMA(HHV(HIGH,250),21); 
 
 
80,COLORRED;20; 
VAR1A:=HHV(HIGH,9)-LLV(LOW,9); 
VAR2A:=HHV(HIGH,9)-CLOSE; 
VAR3A:=CLOSE-LLV(LOW,9); 
VAR4A:=VAR2A/VAR1A*100-70; 
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)); 
VAR6:=(2*CLOSE+HIGH+LOW)/4; 
VAR7:=SMA(VAR3A/VAR1A*100,3,1); 
VAR8:=LLV(LOW,34); 
VAR9:=SMA(VAR7,3,1)-SMA(VAR4A,9,1); 
VAR10:=IF(VAR9>100,VAR9-100,0); 
VAR11A:=HHV(HIGH,34); 
VAR12:=EMA((VAR6-VAR8)/(VAR11A-VAR8)*100,13); 
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2); 
差值:(VAR12-VAR13)*5,POINTDOT,COLOR33CC00; 
STICKLINE(差值>=0,0,差值*1,4,0),COLOR0000FF; 
STICKLINE(差值>=0,0,差值*0.8,4,0),COLOR0066FF; 
STICKLINE(差值>=0,0,差值*0.6,4,0),COLOR0099FF; 
STICKLINE(差值>=0,0,差值*0.4,4,0),COLOR00CCFF; 
STICKLINE(差值>=0,0,差值*0.2,4,0),COLOR00FFFF;
STICKLINE(差值<=0,0,差值*1,4,0),COLORGREEN; 
STICKLINE(差值<=0,0,差值*0.8,4,0),COLOR33CC00; 
STICKLINE(差值<=0,0,差值*0.6,4,0),COLOR339900; 
STICKLINE(差值<=0,0,差值*0.4,4,0),COLOR337700; 
STICKLINE(差值<=0,0,差值*0.2,4,0),COLOR005500;
 
 
VAR1Q:=HHV(HIGH,3);
VAR2Q:=REF(LOW,1);
VAR3Q:=((SMA(ABS((LOW – VAR2Q)),3,1) / SMA(MAX((LOW – VAR2Q),0),3,1)) * 100);
VAR4Q:=EMA(IF((CLOSE * 1.3),(VAR3Q * 10),(VAR3Q / 10)),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=((EMA(IF((LOW <= VAR5Q),((VAR4Q + (VAR6Q * 2)) / 2),0),3) / 618) * VAR7Q);
VAR9Q:=IF((VAR8Q > 100),100,VAR8Q);
STICKLINE((VAR9Q > (0 – 120)),0,VAR9Q,8,1),COLORBROWN;
VAR2W:=((IF((WINNER((1.1 * CLOSE)) < 0),0,WINNER((1.1 * CLOSE))) – IF((WINNER((0.9 * CLOSE)) < 0),0,WINNER((0.9 * CLOSE)))) * 100);
VAR3W:=IF((VAR1Q < 0),0,VAR1Q);
VAR4W:=IF((VAR2W < 0),0,VAR2W);
VAR1D:=REF(CLOSE,1);
VAR12D:=SMA(MAX(CLOSE-VAR1D,0),6,1)/SMA(ABS(CLOSE-VAR1D),6,1)*100;
卖出A:=IF( CROSS(80,VAR12D),1.5,0);
VTD1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
SHD:=VTD1>9 AND FILTER(VTD1<REF(VTD1,1),5);
LDD:=VTD1>20 AND FILTER(VTD1<REF(VTD1,1),5);
VTD2:=HHV(VTD1>20,10); 
WEIX:= VTD2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),LINETHICK0; 
红色警报A:STICKLINE(VTD2 AND FILTER(VTD1< REF(VTD1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VTD1+6,0,2,0);
VTDTJ:=SHD AND LDD AND WEIX;
STICKLINE(卖出A,60,100,2,0),LINETHICK2,COLOR0000FF;
V1:=LLV(LOW,10);
V2:=HHV(HIGH,25);
价位线:=EMA((((CLOSE – V1) / (V2 – V1)) * 4),4);
STICKLINE(CROSS(价位线,0.3),50,5,2,0),COLOR00CCFF;
STICKLINE(CROSS(价位线,0.3),30,5,2,0),COLOR0000FF;
卖出:STICKLINE(VTDTJ,60,100,2,0),COLOR0000FF;
STICKLINE(红色警报A,60,100,2,0),COLOR00FFFF;
STICKLINE(CROSS(3.5,价位线),80,100,2,0),COLORFF9900;
AA3:=((((HHV(HIGH,21) – CLOSE) / (HHV(HIGH,21) – LLV(LOW,21))) * 100) – 10);
AA4:=(((CLOSE – LLV(LOW,21)) / (HHV(HIGH,21) – LLV(LOW,21))) * 100);
AA5:=SMA(AA4,13,8);
走势:=CEILING(SMA(AA5,13,8));
AA6:=SMA(AA3,21,8);
STICKLINE(VTDTJ,60,100,5,0),COLORGREEN;
STICKLINE(VTDTJ,60,100,5,0),COLORGREEN;
JY0:=(3*C+H+L)/5;
流通盘:=IF(C<300,CAPITAL,1200000000);
JZ0:=V/流通盘*100;
JA1:=HHVBARS(H,55);
JA2:=SUM(JY0,JA1);
JA3:=SUM(JY0,2*JA1);
顶A1:=(JA2-JA3)/C;
JA4:=HHVBARS(H,55);
JA5:=SUM(JZ0,JA4);
JA6:=SUM(JZ0,2*JA4);
顶A2:=(JA5-JA6);
顶A3:= (顶A1+顶A2)/2;
顶A4:= MA(顶A3,1)+25;
JB1:=HHVBARS(H,120);
JB2:=SUM(JY0,JB1);
JB3:=SUM(JY0,2*JB1);
顶B1:=(JB2-JB3)/C;
JB4:=HHVBARS(H,120);
JB5:=SUM(JZ0,JB4);
JB6:=SUM(JZ0,2*JB4);
顶B2:=(JB5-JB6);
顶B3:= (顶B1+顶B2)/2;
顶B4:= MA(顶B3,5)+25;
DA1:=LLVBARS(L,65);
DA2:=SUM(JY0,DA1);
DA3:=SUM(JY0,2*DA1);
底A1:=(DA3-DA2)/C;
DA4:=LLVBARS(L,65);
DA5:=SUM(JZ0,DA4);
DA6:=SUM(JZ0,2*DA4);
底A2:=(DA6-DA5);
底A3:= (底A1+底A2)/2;
底A4:= EMA(底A3,1)-3;
DB1:=LLVBARS(L,850);
DB2:=SUM(JY0,DB1);
DB3:=SUM(JY0,2*DB1);
底B1:=(DB3-DB2)/C;
DB4:=LLVBARS(L,850);
DB5:=SUM(JZ0,DB4);
DB6:=SUM(JZ0,2*DB4);
底B2:=(DB6-DB5);
底B3:= (底B1+底B2)/2;
底B4:= MA(底B3,5)-3;
小顶:=IF(顶A4>-3,顶A4,-3);
大顶:= IF(顶B4>22,顶B4,22);
T9H:=IF(顶A4>22,顶A4,22);
小底:= IF(底A4<25,底A4,25);
T9L:=IF(底A4<0,底A4,0)*5;
大底:= IF(底B4<0,底B4,0);
T9H1:=FILTER(顶B4>22 AND 顶A4>22,10);
 
STICKLINE(((走势 – AA6) > 85) >110,98,90,15,1),COLOR00AAAA; 
 
 
 
VARA:=IF(MONTH<12,1,1);
VARB:=(2*CLOSE+HIGH+LOW)/4;
VARC:=LLV(LOW,34);
VARD:=HHV(HIGH,34);
主力A:EMA((VARB-VARC)/(VARD-VARC)*120,13)*VARA,LINETHICK1,COLORRED;
散户A:EMA(0.667*REF(主力A,1)+0.333*主力A,4),LINETHICK1,COLORFF9933;
DRAWBAND((主力A),RGB(250,250,0),(散户A),RGB(0,200,200));
 
 
 
 
 
 
 
 

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址