• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把好公式中的出现紫色柱做个选股公式

常见公式 第一股票指标公式网 3周前 (10-07) 7次浏览 0个评论 扫描二维码

股友提问要求:

请老师帮我把好公式中的出现紫色柱做个选股公式,谢谢!
源码:X5:=EXPMA(CLOSE,3);
X10:=EXPMA(CLOSE,7);
X20:=EXPMA(CLOSE,20);
五日斜率:=(X5-REF(X5,1))*100/REF(X5,1),LINETHICK2,COLORYELLOW;
十日斜率:=(X10-REF(X10,1))*100/REF(X10,1),LINETHICK2,COLORBLUE;
二十斜率:=(X20-REF(X20,1))*100/REF(X20,1),LINETHICK2,COLORWHITE;
XX5:=XMA(五日斜率,4),LINETHICK2,COLORYELLOW;
XX10:=XMA(十日斜率,7),LINETHICK2,COLORBLUE;
XX200:=XMA(二十斜率,20);
AA1:=XX200>=0.7 AND REF(XX200,1) XX10 AND XX10>XX200
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)=0.7 AND REF(XX200,1) XX10 AND XX10>XX202
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)=0.7 AND REF(XX200,1) XX10 AND XX10>XX204
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)=0.7 AND REF(XX200,1) XX10 AND XX10>XX206
AND REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)=0.7 AND REF(XX207,1)=0.7 AND REF(XX2071,1)=0.7 AND REF(XX2072,1)=0.7 AND REF(XX208,1)=0.7 AND REF(XX2081,1)=0.7 AND REF(XX2082,1)<XX2082 AND CROSS(XX10,XX2082)
AND CROSS(XX5,XX2082);
AA?CCJ: IF((AA1 OR AA2 OR AA3 OR AA4 OR AA7 OR AA71 OR AA72 OR AA8 OR AA81
OR AA82)=1,100,0),STICK,COLORMAGENTA,LINETHICK2;
DRAWTEXT(AA1=1,10,'★AA1'),COLORRED;
DRAWTEXT(AA2=1,15,'★AA2'),COLORRED;
DRAWTEXT(AA3=1,20,'★AA3'),COLORRED;
DRAWTEXT(AA4=1,25,'★AA4'),COLORRED;
DRAWTEXT(AA7=1,30,'★AA7'),COLORRED;
DRAWTEXT(AA71=1,35,'★AA71'),COLORRED;
DRAWTEXT(AA72=1,40,'★AA72'),COLORRED;
DRAWTEXT(AA8=1,45,'★AA8'),COLORRED;
DRAWTEXT(AA81=1,50,'★AA81'),COLORRED;
DRAWTEXT(AA82=1,55,'★AA82'),COLORRED;

171415.com解答:

 X5:=EXPMA(CLOSE,3);

 X10:=EXPMA(CLOSE,7);
 X20:=EXPMA(CLOSE,20);
 五日斜率:=(X5-REF(X5,1))*100/REF(X5,1),LINETHICK2,COLORYELLOW;
 十日斜率:=(X10-REF(X10,1))*100/REF(X10,1),LINETHICK2,COLORBLUE;
 二十斜率:=(X20-REF(X20,1))*100/REF(X20,1),LINETHICK2,COLORWHITE;
 XX5:=XMA(五日斜率,4),LINETHICK2,COLORYELLOW;
 XX10:=XMA(十日斜率,7),LINETHICK2,COLORBLUE;
 XX200:=XMA(二十斜率,20);
 AA1:=XX200>=0.7 AND REF(XX200,1)<XX200 AND XX5> XX10 AND  XX10>XX200 
    AND  REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX200,2) ;
 XX202:=XMA(二十斜率,22);
 AA2:=XX202>=0.7 AND REF(XX200,1)<XX200  AND XX5> XX10 AND  XX10>XX202 
    AND  REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX202,2) ;
 XX204:=XMA(二十斜率,24);
 AA3:=XX204>=0.7  AND REF(XX200,1)<XX200 AND XX5> XX10 AND  XX10>XX204 
    AND  REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX204,2) ;
 XX206:=XMA(二十斜率,26);
 AA4:=XX206>=0.7  AND REF(XX200,1)<XX200 AND XX5> XX10 AND  XX10>XX206 
    AND  REF(XX5,2)<REF(XX10,2) AND REF(XX10,2)< REF(XX206,2) ;
 XX207:=XMA(二十斜率,20);
 AA7:=XX207>=0.7 AND REF(XX207,1)<XX207 AND CROSS(XX10,XX207) 
    AND CROSS(REF(XX5,1),REF(XX207,1));
 XX2071:=XMA(二十斜率,23);
 AA71:=XX2071>=0.7 AND REF(XX2071,1)<XX2071 AND CROSS(XX10,XX2071) 
    AND CROSS(REF(XX5,1),REF(XX2071,1));
 XX2072:=XMA(二十斜率,26);
 AA72:=XX2072>=0.7 AND REF(XX2072,1)<XX2072 AND CROSS(XX10,XX2072) 
    AND CROSS(REF(XX5,1),REF(XX2072,1));
 XX208:=XMA(二十斜率,20);
 AA8:=XX208>=0.7 AND REF(XX208,1)<XX208 AND CROSS(XX10,XX208) 
    AND CROSS(XX5,XX208);
 XX2081:=XMA(二十斜率,23);
 AA81:=XX2081>=0.7 AND REF(XX2081,1)<XX2081 AND CROSS(XX10,XX2081) 
    AND CROSS(XX5,XX2081);
 XX2082:=XMA(二十斜率,26);
 AA82:=XX2082>=0.7 AND REF(XX2082,1)<XX2082 AND CROSS(XX10,XX2082) 
    AND CROSS(XX5,XX2082);
(AA1 OR AA2 OR AA3 OR AA4 OR AA7 OR AA71 OR AA72 OR AA8 OR AA81
 OR AA82)=1;

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址