• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

主图显示MACD上穿零轴或下穿零轴变色公式

常见公式 第一股票指标公式网 1周前 (10-10) 3次浏览 0个评论 扫描二维码

股友提问要求:

请老师帮忙编写一个主图能显示MACd上穿零轴时候,K线实体变一个色(例如变成粉色)。当MACD下穿零轴的时候,K线实体变另外一个颜色。。。。谢谢老师。

171415.com解答:

 DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
上穿:=CROSS(MACD,0);
STICKLINE(上穿,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(上穿,H,L,0,0),COLORRED;
跌破:=CROSS(0,MACD);
STICKLINE(跌破,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌破,H,L,0,1),COLORGREEN;

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址