• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

将这个底背离选股公式改成通达信的选股公式

常见公式 第一股票指标公式网 2周前 (10-11) 4次浏览 0个评论 扫描二维码

股友提问要求:

{底背离}
{INPUT:N(20,0,80);}
{1.MACD}
DIFF :=EMA(CLOSE,7) – EMA(CLOSE,13);
DEA := EMA(DIFF,3);
MACD := 2*(DIFF-DEA);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)C AND REF(K,A2+1)C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);{RSI底背离}

TYB:= (HIGH + LOW + 2*CLOSE)/4;
CCI4:=(TYB-MA(TYB,28))/(0.015*AVEDEV(TYB,28));
B4:=LAST(MA(C,5)REF(CCI4,1) AND CROSS(CCI4,-100); { CCI底背离’}

XG:((B1 AND B2) OR (B2 AND B3) OR (B1 AND B3) OR ( B4 AND CCI4<-90) ) AND D<N ;
这个公式本来就是别人改好的,可是我用的时候出现这个提示

前公式 : DBLXG (条件选股公式)
错误句 : { CCI底背离'}

XG:((B1 AND B2) OR (B2 AND B3) OR (B1 AND B3) OR ( B4 AND CCI4<-90) ) AND D<N
详细信息 : 未知字符串 N
错误起始位置 : 959 ; 长度: 1

请老师帮助,十分感谢。

171415.com解答:

 

 
N:=20; 
{1.MACD}
DIFF :=EMA(CLOSE,7) – EMA(CLOSE,13);
DEA  := EMA(DIFF,3);
MACD := 2*(DIFF-DEA);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);{MACD底背离}
{2.KDJ}
RSV:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)<K AND CROSS(K,D);{KDJ底背离}
{3.RSI}
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)<RSI1 AND CROSS(RSI1,RSI2);{RSI底背离}
TYB:= (HIGH + LOW + 2*CLOSE)/4;
CCI4:=(TYB-MA(TYB,28))/(0.015*AVEDEV(TYB,28));
B4:=LAST(MA(C,5)<MA(C,10),10,5)  AND CCI4>REF(CCI4,1) AND CROSS(CCI4,-100);  { CCI底背离’}
XG:((B1 AND B2) OR (B2 AND B3) OR (B1 AND B3) OR ( B4 AND CCI4<-90) ) AND D<N ;
 

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址