• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

合并资金流量和流量统计指标而不压缩

常见公式 第一股票指标公式网 3周前 (10-11) 7次浏览 0个评论 扫描二维码

股友提问要求:

源码:一、统计源码

五换:SUM(100*V/CAPITAL,5),COLORRED,NODRAW;
二十换:SUM(100*V/CAPITAL,20),COLORRED,NODRAW;
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
量能饱和:IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=流入-流出;
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(VOL,0,190,1));

DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,118,88),ABS(画),DRAWNULL),RGB(0,30,50),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,115,114),CONST(总额/10000),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,114,113),CONST(流入*10000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,113,112),CONST(流出*10000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,108,107),CONST(总额3/10000),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,107,106),CONST(流入3*10000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,106,105),CONST(流出3*10000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,101,100),CONST(总额5/10000),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,100,99),CONST(流入5*10000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,99,98),CONST(流出5*10000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,94,93),CONST(总额10/10000),DRAWNULL),RGB(150,10,0),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,93,92),CONST(流入10*10000),DRAWNULL),RGB(250,0,250),0,DRAWNULL);
DRAWBAND(IF(BETWEEN(CURRBARSCOUNT,92,91),CONST(流出10*10000),DRAWNULL),RGB(0,255,255),0,DRAWNULL);
DRAWTEXT(CURRBARSCOUNT=118,画*0.86,’总额亿’),COLORRED;
DRAWTEXT(CURRBARSCOUNT=118,画*0.74,’流入亿’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=118,画*0.62,’流出亿’),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=118,画*0.50,’净流亿’),COLOR0099FF;
DRAWTEXT(CURRBARSCOUNT=112,画*0.95,’1日’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=106,画*0.95,’3日’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=100,画*0.95,’5日’),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=94,画*0.95,’10日’),COLORMAGENTA;

DRAWNUMBER(CURRBARSCOUNT=113,画*0.89,CONST(总额/100000000)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=113,画*0.77,CONST(流入)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=113,画*0.65,CONST(流出)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=113,画*0.53,CONST(净流)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=107,画*0.89,CONST(总额3/100000000)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=107,画*0.77,CONST(流入3)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=107,画*0.65,CONST(流出3)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=107,画*0.53,CONST(净流3)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=101,画*0.89,CONST(总额5/100000000)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=101,画*0.77,CONST(流入5)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=101,画*0.65,CONST(流出5)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=101,画*0.53,CONST(净流5)), COLORDDFFFF;
DRAWNUMBER(CURRBARSCOUNT=95,画*0.89,CONST(总额10/100000000)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=95,画*0.77,CONST(流入10)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=95,画*0.65,CONST(流出10)),COLORYELLOW;
DRAWNUMBER(CURRBARSCOUNT=95,画*0.53,CONST(净流10)),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=103,画*0.38,画*0.41,100,1),COLOR00DDDD;
STICKLINE(CURRBARSCOUNT=103,画*0.385,画*0.405,量能饱和,0),COLOR0033FF;

资金流量:
{资金流量}
TYP := (HIGH + LOW + CLOSE)/3;
V1:=SUM(IF(TYP>REF(TYP,1),TYP*VOL,0),14)/SUM(IF(TYP<REF(TYP,1),TYP*VOL,0),14);
MFI:100-(100/(1+V1)),LINETHICK2;

171415.com解答:

 {资金流量}

AA:=IF(BETWEEN(CURRBARSCOUNT,118,88),ABS(画),DRAWNULL);
TYP := (HIGH + LOW + CLOSE)/3;
V1:=SUM(IF(TYP>REF(TYP,1),TYP*VOL,0),14)/SUM(IF(TYP<REF(TYP,1),TYP*VOL,0),14);
MFG:=100-(100/(1+V1)),LINETHICK2;
BB:=CONST(LLV(MFG,140));
DD:=CONST(HHV(MFG,140));
EE:=CONST(HHV(AA,140));
MFI:(MFG-BB)/(DD-BB)*EE,COLORYELLOW,LINETHICK2;
 

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址