• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

通达信交易系统公式

常见公式 第一股票指标公式网 2周前 (10-12) 3次浏览 0个评论 扫描二维码

股友提问要求:

小弟想用通达信测试以下公式,当DIF指标上穿0轴那天收盘价为买入价,买入后某天收盘价若大于买入价的1.05倍时卖出。

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
BUY:=IF(CROSS(DIF,0),C,DRAWNULL);
{多头买入(买开)} ENTERLONG:CROSS(DIF,0) ;
{多头卖出(卖平)} EXITLONG: C>(1.05*BUY);

测试结果有多次买入,没有卖出,不知问题出在何处,请高手指点如何改正,小弟在此谢过!

171415.com解答:

 DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
BUY:=IF(CROSS(DIF,0),C,DRAWNULL);
{多头买入(买开)} ENTERLONG:CROSS(DIF,0) ;
{多头卖出(卖平)} EXITLONG: C>(1.05*ref(c,barslast(BUY)));

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址