• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

依据“趋势跟踪”改写选股公式

常见公式 第一股票指标公式网 2周前 (10-12) 5次浏览 0个评论 扫描二维码

股友提问要求:

股友提问要求条件选股:写个根据在下指标,选出主升浪红色区域以阴线收盘的股票公式,如下图所示:
{趋势跟踪通达信版本副图指标}
{【趋势跟踪】指标使用说明:
趋势为王守铁律,顺势而为主升期;
临界出现防风险,挖坑不涨早休息!}
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:(A1+A2+A3+A4+A5+A6)/6*100,COLOR00FF00;
主升浪:趋势>=50,COLOR0000FF,POINTDOT,NODRAW;
↓:趋势<50,COLORFFFFFF,POINTDOT,NODRAW;
周期:IF(主升浪,BARSLAST(CROSS(主升浪,0.1))+1,0),COLORFF00FF,POINTDOT,NODRAW;
临界:IF(CROSS(98,趋势),1,0),COLOR00FF00,POINTDOT,NODRAW;
WKQY:=BARSLAST(CROSS(50,趋势))<MIN(BARSLAST(CROSS(趋势,1)),BARSLAST(CROSS(趋势,-1)));
挖坑:BETWEEN(趋势,-1,50) AND WKQY,COLOR00FFFF,POINTDOT,NODRAW;
{以下设置副图显示方式}
DRAWBAND(趋势,RGB(250,0,0),50,RGB(0,0,0));
AA:=IF(挖坑,趋势,50);
DRAWBAND(50,RGB(250,250,0),AA,RGB(0,0,0));
STICKLINE(主升浪,周期*0.8,周期*0.95,3,0),COLOR0000FF;
STICKLINE(主升浪,周期*1.05,周期*1.2,3,0),COLOR0000FF;
STICKLINE(主升浪 AND C0,50,50,1,0),COLOR000000;
%:趋势,COLOR00FF00;
{以下设置文字提示部分}
DRAWTEXT(CURRBARSCOUNT=60,20,’====★趋势为王.顺势而为!★====’),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=58,-30,’■只做主升, 挖坑低吸!’),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=58,-60,’●临界不涨, 逢高离场!’),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=60,-90,’========’),COLOR00FF00;

171415.com解答:

 MA5:=MA(CLOSE,5);

MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
A1:=IF(C>=MA5,1,-1);
A2:=IF(C>=MA10,1,-1);
A3:=IF(C>=MA20,1,-1);
A4:=IF(MA5>=REF(MA5,1),1,-1);
A5:=IF(MA10>=REF(MA10,1),1,-1);
A6:=IF(MA20>=REF(MA20,1),1,-1);
趋势:=(A1+A2+A3+A4+A5+A6)/6*100;
主升浪:CROSS(MA5,MA20) AND MA5>MA10 AND 趋势>=50;

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址