• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

给“牛熊背离”指标做两个选股指标

常见公式 第一股票指标公式网 1周前 (10-13) 6次浏览 0个评论 扫描二维码

股友提问要求:

“牛熊背离”源码:
N1:=5;
N2:=10;
N3:=21;
N4:=60;
牛熊:EMA(CLOSE,N4),COLORGREEN,LINETHICK3;
DIFF:=EMA(CLOSE,12) – EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)0,1,0),L-0.1,’MACD底背’),COLORGREEN;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
A2:=BARSLAST(REF(CROSS(K,D),1));
B2:=REF(C,A2+1)>C AND REF(K,A2+1)0,1,0),L-0.25,’KDJ底背’),COLORYELLOW;
LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));
B3:=REF(C,A3+1)>C AND REF(RSI1,A3+1)0,1,0),L-0.4,’RSI底背’),COLORBLUE;
C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));
D1:=REF(C,C1+1)DIFF AND CROSS(DEA,DIFF);
DRAWTEXT(IF(D1>0,1,0),H+0.1,’MACD顶背’),COLORWHITE;
C2:=BARSLAST(REF(CROSS(D,K),1));
D2:=REF(C,C2+1)K AND CROSS(D,K);
DRAWTEXT(IF(D2>0,1,0),H+0.25,’KDJ顶背’),COLORWHITE;
C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));
D3:=REF(C,C3+1)RSI1 AND CROSS(RSI2,RSI1);
DRAWTEXT(IF(D3>0,1,0),H+0.4,’RSI顶背’),COLORYELLOW;
SG:EMA(HHV(H,1),8),COLORGRAY;
X1:EMA(CLOSE,N1),COLORYELLOW;
JJ:=(H+L+3*C)/5;

请老师帮忙做两个选股指标:第一种是选出黄线上穿绿线(牛熊线)的股票。第二种是选出黄线位于牛熊线之上的股票。

171415.com解答:

 {黄线上穿绿线}

CROSS(EMA(C,5),EMA(C,60));
{黄线位于牛熊线之上}
EMA(C,5)>EMA(C,60);
 

第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址