• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

牛象条件选股公式有错误

常见公式 第一股票指标公式网 2周前 (10-14) 5次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请高手帮忙修改下面这个通达信的公式为条件选股公式
示图在附件里面:
1:请选出附图301里当日出现牛象提示的股票.如附图302.
2:请选出附图303里当日出现买点一的股票。如附图304.
请分开写出二个条件选股公式。

公式源码:

MA20:MA(C,20),COLORWHITE,LINETHICK2;
MA120:MA(C,120),COLORFFCCCC,LINETHICK2;
MA250:MA(C,250),COLORFFCC66,LINETHICK2;
乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;
TT1:=CROSS(MA20,MA120) AND CROSS(MA20,MA250) AND V>REF(V,1);
TT2:=MA20>REF(MA20,2) AND V>REF(V,1) AND CROSS(C,MA20);
STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT1,L-0.13,’金叉’),COLORYELLOW;
STICKLINE(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L-0.13,’并线开花’),COLORYELLOW;
STICKLINE(TT2,L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(TT2,L-0.13,’买点1′),COLORYELLOW;
STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;
DRAWTEXT(CROSS(C,乖离线) ,H+0.13,’卖点’),COLOR00FF00;
STICKLINE(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L,L-0.09,4,0),COLORFFCC66;
DRAWTEXT(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L-0.13,’牛象’),COLORFFCC66;
STICKLINE(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L,L-0.09,4,0),COLORFF00FF;
DRAWTEXT(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.13,’买点2′),COLORFF00FF ;
A1:=SUM(AMOUNT,3)/SUM(VOL,3)/100;
A2:=SUM(AMOUNT,8)/SUM(VOL,8)/100;
A3:=SUM(AMOUNT,21)/SUM(VOL,21)/100;
DIFF:=(EMA(CLOSE,12) – EMA(CLOSE,26));
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA);
V1:=C-(A1+MA(C,3))/2;
V2:=C-(A2+MA(C,8))/2;
V3:=C-(A3+MA(C,21))/2;
VA1:=(C+V3-V1+MACD);
VA4:=(C+V2-V1+MACD);
短线:EMA(VA1,6),LINETHICK2,COLORYELLOW;

 

解答如下:
MA20:=MA(C,20);
MA250:=MA(C,250);
牛象:MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址