• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

在DMI指标里加一个金叉的箭头

常见公式 第一股票指标公式网 2周前 (10-14) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

TR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR,COLORRED;
MDI:DMM*100/TR,COLORYELLOW;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORGREEN;
ADXR:=(ADX+REF(ADX,6))/2,COLOR66FF66;
DRAWTEXT(CROSS(PDI,MDI)AND PDI>ADX,PDI,’火箭’);
DRAWTEXT(CROSS(MDI,PDI)AND MDI>ADX,MDI,’炸弹’);

条件:PDI上穿MDI的地方加一个红箭头,MDI死叉PDI加一个绿色的箭头,谢谢了
 

 
解答如下:
TR:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N,1);
HD:=HIGH-REF(HIGH,1);
LD:=REF(LOW,1)-LOW;
DMP:=SMA(IF(HD>0 AND HD>LD,HD,0),N,1);
DMM:=SMA(IF(LD>0 AND LD>HD,LD,0),N,1);
PDI:DMP*100/TR,COLORRED;
MDI:DMM*100/TR,COLORYELLOW;
ADX:SMA(ABS(MDI-PDI)/(MDI+PDI)*100,N,1),COLORGREEN;
ADXR:=(ADX+REF(ADX,6))/2,COLOR66FF66;
DRAWTEXT(CROSS(PDI,MDI)AND PDI>ADX,PDI,’火箭’);
DRAWTEXT(CROSS(MDI,PDI)AND MDI>ADX,MDI,’炸弹’);
DRAWICON(CROSS(PDI,MDI),PDI,1);
DRAWICON(CROSS(MDI,PDI),PDI,2);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址