• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

编写通达信上攻背离的选股公式

常见公式 第一股票指标公式网 2周前 (10-14) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

A03:=(EMA((AMOUNT/100000),1)/3);
A04:=(WINNER(CLOSE)/ 0.3);
A05:=IF((BARSCOUNT(CLOSE) >100),A03,A04);
量:A05 LINETHICK2 ;
动量:(EMA(量, 13.000) * 1.5)LINETHICK2;
A01:=IF((量 > 动量),量,0);
A08:=BARSLAST((A01 > 0));
A09:=REF(量,A08);
趋势:IF((量 <= A01),量,A09),LINETHICK2,COLORRED;
盘整天数:BARSLAST((A01 > 0)),LINETHICK0,COLORMAGENTA;
量价同行:IF(趋势>量,趋势,DRAWNULL),COLORCYAN,LINETHICK2;
A0D:=((((REF(量, 1.000) = REF(趋势, 1)) AND (量 >= REF(量, 1))) AND (量 >= 动量)) AND (REF(量, 1) <= REF(量, 2)));
量价突破选股:IF(((((量 = 趋势) AND (CLOSE > REF(CLOSE, 1))) AND (量 > REF(量, 1))) AND (REF(A08, 2) > 0)), 888,0),LINETHICK0;
量价同行选股:IF((量 = 趋势), 888,0)LINETHICK0;
量价背离选股:IF((REF(((动量 > REF(动量,1)) AND (MA(CLOSE, 5) < REF(MA(CLOSE, 5), 1))), 1) AND 量价突破选股), 888,0),LINETHICK0;
再次上攻选股:IF(A0D, 888,0),LINETHICK0;
DRAWICON(量价突破选股>0,量,9);
DRAWICON(A0D>0,量,6);
DRAWTEXT(再次上攻选股>0,(量*0.7),’再次上攻’),COLORMAGENTA;
DRAWTEXT(量价背离选股>0,(量*1.149),’背离后上攻’),COLORGREEN;
DRAWTEXT(量价突破选股>0,(量*0.699),’上攻’),COLORCYAN;

股友提问要求分别写出上攻、背离上攻和再次上攻三个选股公式
 

 
解答如下:
1
A03:=(EMA((AMOUNT/100000),1)/3);
A04:=(WINNER(CLOSE)/ 0.3);
A05:=IF((BARSCOUNT(CLOSE) >100),A03,A04);
量:=A05;
动量:=(EMA(量, 13.000) * 1.5);
A01:=IF((量 > 动量),量,0);
A08:=BARSLAST((A01 > 0));
A09:=REF(量,A08);
趋势:=IF((量 <= A01),量,A09);
上攻:((((量 = 趋势) AND (CLOSE > REF(CLOSE, 1))) AND (量 > REF(量, 1))) AND (REF(A08, 2) > 0));

2
A03:=(EMA((AMOUNT/100000),1)/3);
A04:=(WINNER(CLOSE)/ 0.3);
A05:=IF((BARSCOUNT(CLOSE) >100),A03,A04);
量:=A05;
动量:=(EMA(量, 13.000) * 1.5);
A01:=IF((量 > 动量),量,0);
A08:=BARSLAST((A01 > 0));
A09:=REF(量,A08);
趋势:=IF((量 <= A01),量,A09);
再次上攻:((((REF(量, 1.000) = REF(趋势, 1)) AND (量 >= REF(量, 1))) AND (量 >= 动量)) AND (REF(量, 1) <= REF(量, 2)));

3
A03:=(EMA((AMOUNT/100000),1)/3);
A04:=(WINNER(CLOSE)/ 0.3);
A05:=IF((BARSCOUNT(CLOSE) >100),A03,A04);
量:=A05;
动量:=(EMA(量, 13.000) * 1.5);
A01:=IF((量 > 动量),量,0);
A08:=BARSLAST((A01 > 0));
A09:=REF(量,A08);
趋势:=IF((量 <= A01),量,A09);
量价突破选股:=IF(((((量 = 趋势) AND (CLOSE > REF(CLOSE, 1))) AND (量 > REF(量, 1))) AND (REF(A08, 2) > 0)), 888,0);
背离后上攻:(REF(((动量 > REF(动量,1)) AND (MA(CLOSE, 5) < REF(MA(CLOSE, 5), 1))), 1) AND 量价突破选股);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址