• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

这个成交量指标会不会漂移

常见公式 第一股票指标公式网 3个月前 (10-15) 4次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请老师看看这个成交量指标会不会漂移,1指标第一句中的WINNER是不是未来函数?2指标的K和D的金叉会不会漂移?假如K和D的金叉不会漂移的话,我在600725云维股份的周线图上在1999.5.21的那根K线对应的该指标的红箭头(即K和D的金叉),当是把K线图继续压缩,1999.5.21的那根K线对应的就不是红箭头了,红箭头到了1999.5.07的那根K线上了。这是不是一种未来,请老师告我。源码如下:
筹码空间:IF(WINNER(CLOSE),WINNER(CLOSE)*100,20),VOLSTICK;

TX80:80,POINTDOT, COLORYELLOW;
DX20:20,POINTDOT, COLORGREEN;
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
K: EMA((CLOSE-VAR1)/(VAR2-VAR1)*100,6),COLORRED;
D: EMA(0.667*REF(K,1)+0.333*K,2),COLORGREEN;
VAR3:=LLV(LOW,55);
VAR4:=HHV(HIGH,34);
VAR5:=EMA((CLOSE-VAR3)/(VAR4-VAR3)*100,3);
VAR6:=(K+VAR5)/2;
VAR7:=EMA(0.667*REF(VAR5,1)+0.333*K,2);
VAR8:=EMA(VAR6,5);
VAR9:EMA(0.667*REF(VAR8,1)+0.333*VAR8,2);
DRAWICON(LONGCROSS(D,K,0.1),D,2),COLORRED;
DRAWICON(LONGCROSS(K,D,0.1),K,1),COLORGREEN;
 

 
解答如下:
1、有些软件会把winner检测成为来函数,所以看有否未来要看人脑,不能靠软件。
2、指标里用到了hhv、llv函数,也就是在指定日期里最高值、最低值函数,虽不属未来函数,但信号有产生漂移的可能,具体原因可以参考这个帖子http://www.55188.com/thread-3365821-1-1.html。这也是你那个红箭头发生漂移的原因。
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址