• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把“精准趋势”公式修改成条件选股公式

常见公式 第一股票指标公式网 1周前 (10-15) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

希望实现,将“小红箭头”的票,选出来。如图:
代码如下:
买入基础:=EMA(C,5)>REF(EMA(C,5),1) AND EMA(C,10)>=REF(EMA(C,10),1);
VAR1:=EMA(INDEXC,5);
VAR2:=EMA(INDEXC,10);
VAR3:=EMA(INDEXC,20);
VAR4:=VAR1>=REF(VAR1,1) AND 买入基础;
VAR5:=VAR2>=REF(VAR2,1) AND 买入基础;
VAR6:=VAR3>=REF(VAR3,1) AND 买入基础;
STICKLINE(VAR6,40,50,4.5,0),COLOR1068B4,LINETHICK2;
STICKLINE(VAR6,40,50,4,0),COLOR1078B4,LINETHICK2;
STICKLINE(VAR6,40,50,3.5,0),COLOR1088B4,LINETHICK2;
STICKLINE(VAR6,40,50,3,0),COLOR1098B4,LINETHICK2;
STICKLINE(VAR6,40,50,2.5,0),COLOR10A8B4,LINETHICK2;
STICKLINE(VAR6,40,50,2,0),COLOR10B8B4,LINETHICK2;
STICKLINE(VAR6,40,50,1.5,0),COLOR10C8B4,LINETHICK2;
STICKLINE(VAR6,40,50,1,0),COLOR10D8B4,LINETHICK2;
STICKLINE(VAR5,30,40,4.5,0),COLOR102070,LINETHICK2;
STICKLINE(VAR5,30,40,4,0),COLOR102080,LINETHICK2;
STICKLINE(VAR5,30,40,3.5,0),COLOR102090,LINETHICK2;
STICKLINE(VAR5,30,40,3,0),COLOR1020A0,LINETHICK2;
STICKLINE(VAR5,30,40,2.5,0),COLOR1020B0,LINETHICK2;
STICKLINE(VAR5,30,40,2,0),COLOR1020C0,LINETHICK2;
STICKLINE(VAR5,30,40,1.5,0),COLOR1020D0,LINETHICK2;
STICKLINE(VAR5,30,40,1,0),COLOR1020E0,LINETHICK2;
STICKLINE(VAR4,20,30,4.5,0),COLOR105510,LINETHICK2;
STICKLINE(VAR4,20,30,4,0),COLOR106610,LINETHICK2;
STICKLINE(VAR4,20,30,3.5,0),COLOR107710,LINETHICK2;
STICKLINE(VAR4,20,30,3,0),COLOR108810,LINETHICK2;
STICKLINE(VAR4,20,30,2.5,0),COLOR109910,LINETHICK2;
STICKLINE(VAR4,20,30,2,0),COLOR10AA10,LINETHICK2;
STICKLINE(VAR4,20,30,1.5,0),COLOR10BB10,LINETHICK2;
STICKLINE(VAR4,20,30,1,0),COLOR10CC10,LINETHICK2;{大盘均线}
VAR7:=EMA(INDEXV,5);
VAR8:=EMA(INDEXV,10);
VAR9:=EMA(INDEXV,20);
VAR10:=VAR7>=REF(VAR7,1) AND 买入基础;
VAR11:=VAR8>=REF(VAR8,1) AND 买入基础;
VAR12:=VAR9>=REF(VAR9,1) AND 买入基础;
{STICKLINE(VAR12,70,80,8,0),COLOR108010,LINETHICK2;
STICKLINE(VAR12,70,80,7,0),COLOR109010,LINETHICK2;
STICKLINE(VAR12,70,80,6,0),COLOR10A010,LINETHICK2;
STICKLINE(VAR12,70,80,5,0),COLOR10B010,LINETHICK2;}
STICKLINE(VAR12,70,80,4,0),COLOR10C010,LINETHICK2;
STICKLINE(VAR12,70,80,3,0),COLOR10D010,LINETHICK2;
STICKLINE(VAR12,70,80,2,0),COLOR10E010,LINETHICK2;
STICKLINE(VAR12,70,80,1,0),COLOR10F010,LINETHICK2;
{STICKLINE(VAR11,60,70,8,0),COLORFF45FF,LINETHICK2;
STICKLINE(VAR11,60,70,7,0),COLORFF55FF,LINETHICK2;
STICKLINE(VAR11,60,70,6,0),COLORFF65FF,LINETHICK2;
STICKLINE(VAR11,60,70,5,0),COLORFF75FF,LINETHICK2;}
STICKLINE(VAR11,60,70,4,0),COLORFF85FF,LINETHICK2;
STICKLINE(VAR11,60,70,3,0),COLORFF95FF,LINETHICK2;
STICKLINE(VAR11,60,70,2,0),COLORFFA5FF,LINETHICK2;
STICKLINE(VAR11,60,70,1,0),COLORFFB5FF,LINETHICK2;
STICKLINE(VAR10,50,60,4.5,0),COLOR1055FF,LINETHICK2;
STICKLINE(VAR10,50,60,4,0),COLOR1066FF,LINETHICK2;
STICKLINE(VAR10,50,60,3.5,0),COLOR1077FF,LINETHICK2;
STICKLINE(VAR10,50,60,3,0),COLOR1088FF,LINETHICK2;
STICKLINE(VAR10,50,60,2.5,0),COLOR1099FF,LINETHICK2;
STICKLINE(VAR10,50,60,2,0),COLOR10AAFF,LINETHICK2;
STICKLINE(VAR10,50,60,1.5,0),COLOR10BBFF,LINETHICK2;
STICKLINE(VAR10,50,60,1,0),COLOR10CCFF,LINETHICK2;{大盘均量线}

{以下语句是股道趋势及其买卖点}
A1:=LLV(LOW,5)=LLV(LOW,45) AND CLOSE>=OPEN*1.04;
A2:=CLOSE>(REF(HIGH,1)+REF(LOW,1))/2;
买入:=A1 AND A2;
A3:=REF(CLOSE,1);
A4:=SMA(MAX(CLOSE-A3,0),6,1)/SMA(ABS(CLOSE-A3),6,1)*100;
卖出:=CROSS(80,A4);
低吸线: 20,POINTDOT,COLOR1090FF;
强弱线: 50,POINTDOT,COLORBBBB00 ;
高抛线: 80,POINTDOT,COLOR109C10;
A5:=LLV(LOW,18);
A6:=HHV(HIGH,18);
A7:=EMA((CLOSE-A5)/(A6-A5)*100,13);
股道趋势:EMA(0.618*REF(A7,1)+0.382*A7,3),COLORYELLOW,LINETHICK2;
PLOYLINE(股道趋势<=REF(股道趋势,1),股道趋势),COLORBLUE,LINETHICK2;
A8:=MA(C,1)/MA(REF(C,18),18)*100;
A9:=MA(FORCAST(A8,20),6);
攻击点:=IF(FILTER(CROSS(A8,A9),5)=1,50,0);{买1}
DRAWICON(攻击点,股道趋势*0.98,1);
DRAWICON(卖出,股道趋势,2);{卖}
DRAWICON(买入,股道趋势,1);{买2};

 

解答如下:
A8:=MA(C,1)/MA(REF(C,18),18)*100;
A9:=MA(FORCAST(A8,20),6);
攻击点:FILTER(CROSS(A8,A9),5);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址