• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

老师基于此MACD给改革选股

常见公式 第一股票指标公式网 2周前 (10-16) 4次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

这是本人自己用的,不过也是在理想淘出来的指标,希望老师给改成两个个选股第一是0下金叉选股,第二是0下二次金叉选股
A:EMA(CLOSE,9)-EMA(CLOSE,18);
B:EMA(A,7),LINETHICK1;
MACD:=2*(A-B);
STICKLINE(MACD>=0,MACD,0,0,0),COLORF00FF0;
STICKLINE(MACD<0,MACD,0,1,0),COLORF00FF0;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0,0 ),COLORFFFF00;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0 ),COLORFFFF00;
IF(A<0,A,0),COLORRED,LINETHICK1;
IF(A<0,0,A),COLORRED,LINETHICK1;
IF(A<B,A,B),COLOR00FF00,LINETHICK1;
IF(A>B,B,B),COLORWHITE,LINETHICK1;
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,0.5,0),1),COLORGREEN;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
E:=CROSS(83,RSI);
STICKLINE( E,E,0.5,1,0),COLOR00FFFF;
DRAWTEXT(E,0.85,’ 逃顶’),COLORGREEN;
低位金叉:CROSS(A,B) AND A<-0.1,COLORRED;
STICKLINE(低位金叉,0,0.5,2,0),COLORRED;
JCCOUNT:=COUNT(CROSS(A,B),BARSLAST(B>=0));
二次金叉:CROSS(A,B) AND B<0 AND COUNT(JCCOUNT=2,21)=1,COLORYELLOW;
STICKLINE(二次金叉,0,0.2,2,0),COLORYELLOW;
DRAWICON(二次金叉,B*0.9,25) ;
DRAWICON(LLV(MACD,4)>0 AND MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2) AND REF(MACD,2)>REF(MACD,3),MACD,2);
DRAWICON(HHV(MACD,4)<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3),MACD,1);
 
 
解答如下:
A:=EMA(CLOSE,9)-EMA(CLOSE,18);
B:=EMA(A,7),LINETHICK1;
MACD:=2*(A-B);
低位金叉:=CROSS(A,B) AND A<-0.1;
JCCOUNT:=COUNT(CROSS(A,B),BARSLAST(B>=0));
低位二次金叉:=CROSS(A,B) AND B<0 AND COUNT(JCCOUNT=2,21)=1 AND MACD<0;
低位金叉 OR 低位二次金叉;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址