• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把九散人的自用DDX成交量改为DZH可用的

常见公式 第一股票指标公式网 2周前 (10-17) 1次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

源码如下:
VOLUME:VOL,VOLSTICK;
VAR1:=VOL/((H-L)*2-ABS(C-O));
主买:=IF(C>O,VAR1*(H-L),IF(C<O,VAR1*((H-O)+(C-L)),VOL/2)),COLORRED,NODRAW;
主卖:=IF(C>O,0-VAR1*((H-C)+(O-L)),IF(C<O,0-VAR1*(H-L),0+V/2)),COLOR00FF00,NODRAW;
【差】:(主买+主卖),NODRAW,COLOR0000FF;
K:=IF(【差】>0,【差】,-【差】);
STICKLINE(【差】>0,0,K,2.5,0),COLOR000088;
STICKLINE(【差】>0,0,K,1.8,0),COLOR0000AA;
STICKLINE(【差】>0,0,K,1.2,0),COLOR0000CC;
STICKLINE(【差】>0,0,K,0.4,0),COLOR0000EE;
STICKLINE(【差】<0,0,K,2.5,0),COLOR008800;
STICKLINE(【差】<0,0,K,1.8,0),COLOR00AA00;
STICKLINE(【差】<0,0,K,1.2,0),COLOR00CC00;
STICKLINE(【差】<0,0,K,0.4,0),COLOR00EE00;
AA1:=VOL<REF(LLV(VOL,20),1);
AA2:=VOL<REF(LLV(VOL,60),1);
AA3:=VOL<REF(LLV(VOL,100),1);
STICKLINE(AA1,0,V,1,1),COLORBLUE;
STICKLINE(AA2,0,V,0.6,1),COLORMAGENTA;
STICKLINE(AA3,0,V,0.3,1)COLORWHITE;
DDX:=主买+主卖;
DX:=MA(DDX,5)*5;
DDX1:SMA(DX,3,1),COLORRED,LINETHICK1;
DDX2:SMA(DDX1,3,1),COLORYELLOW,LINETHICK1;
DDX3:EMA(DDX2,5),COLORF0F000,LINETHICK1;
X1:=(3*C+L+H+O)/6;
F:=(EMA(CLOSE,5)-EMA(CLOSE,21))*4;
VAR10:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR20:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR30:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR40:=(20*X1+19*REF(X1,1)+18*REF(X1,2)+17*REF(X1,3)+16*REF(X1,4)+15*REF(X1,5)+
14*REF(X1,6)+13*REF(X1,7)+12*REF(X1,8)+11*REF(X1,9)+10*REF(X1,10)+9*REF(X1,11)+8*REF(X1,12)
+7*REF(X1,13)+6*REF(X1,14)+5*REF(X1,15)+4*REF(X1,16)+3*REF(X1,17)+2*REF(X1,18)+REF(X1,20))/210;
MTM:=C-REF(C,1);
DX1:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR40,13);
卖1:=HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1);
DRAWTEXT(FILTER(卖1=1,1),VOLUME*-0.1,’卖’),COLOR00C800;
买1:=LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2));
DRAWTEXT(FILTER(DDX1>=DDX2 AND 买1=1,5),VOLUME*-0.1,’买’),COLORYELLOW;
 
 
解答如下:
VOLUME:VOL,VOLSTICK;
VAR1:=VOL/((H-L)*2-ABS(C-O));
主买:IF(C>O,VAR1*(H-L),IF(C<O,VAR1*((H-O)+(C-L)),VOL/2)),COLORRED,LINETHICK0;
主卖:IF(C>O,0-VAR1*((H-C)+(O-L)),IF(C<O,0-VAR1*(H-L),0+V/2)),COLOR00FF00,LINETHICK0;
【差】:(主买+主卖),LINETHICK0,COLOR0000FF;
K:=IF(【差】>0,【差】,-【差】);
STICKLINE(【差】>0,0,K,8,0),COLOR000088;
STICKLINE(【差】>0,0,K,5,0),COLOR0000AA;
STICKLINE(【差】>0,0,K,3,0),COLOR0000CC;
STICKLINE(【差】>0,0,K,1,0),COLOR0000EE;
STICKLINE(【差】<0,0,K,8,0),COLOR008800;
STICKLINE(【差】<0,0,K,5,0),COLOR00AA00;
STICKLINE(【差】<0,0,K,3,0),COLOR00CC00;
STICKLINE(【差】<0,0,K,1,0),COLOR00EE00;
AA1:=VOL<REF(LLV(VOL,20),1);
AA2:=VOL<REF(LLV(VOL,60),1);
AA3:=VOL<REF(LLV(VOL,100),1);
STICKLINE(AA1,0,V,8,1),COLORBLUE;
STICKLINE(AA2,0,V,8,1),COLORMAGENTA;
STICKLINE(AA3,0,V,8,1),COLORWHITE;
DDX:=主买+主卖;
DX:=MA(DDX,5)*5;
DDX1:SMA(DX,3,1),COLORRED,LINETHICK1;
DDX2:SMA(DDX1,3,1),COLORYELLOW,LINETHICK1;
DDX3:EMA(DDX2,5),COLORF0F000,LINETHICK1;
X1:=(3*C+L+H+O)/6;
F:=(EMA(CLOSE,5)-EMA(CLOSE,21))*4;
VAR10:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
VAR20:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
VAR30:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
VAR40:=(20*X1+19*REF(X1,1)+18*REF(X1,2)+17*REF(X1,3)+16*REF(X1,4)+15*REF(X1,5)+
14*REF(X1,6)+13*REF(X1,7)+12*REF(X1,8)+11*REF(X1,9)+10*REF(X1,10)+9*REF(X1,11)+8*REF(X1,12)
+7*REF(X1,13)+6*REF(X1,14)+5*REF(X1,15)+4*REF(X1,16)+3*REF(X1,17)+2*REF(X1,18)+REF(X1,20))/210;
MTM:=C-REF(C,1);
DX1:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(VAR40,13);
卖1:=HHV(DX1,2)=HHV(DX1,7) AND COUNT(DX1>50,2) AND CROSS(MA(DX1,2),DX1);
DRAWTEXT(FILTER(卖1=1,1),VOLUME*-0.1,’卖’),COLOR00C800;
买1:=LLV(DX1,2)=LLV(DX1,7) AND COUNT(DX1<0,2) AND CROSS(DX1,MA(DX1,2));
DRAWTEXT(FILTER(DDX1>=DDX2 AND 买1=1,5),VOLUME*-0.1,’买’),COLORYELLOW;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址