• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

将骑牛主图改成大智慧版本

常见公式 第一股票指标公式网 2周前 (10-17) 4次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

源码
{骑牛主图3}
{红三角、晶红三角、脸笑均为参考买点,卖点自己摸索,一般绿色风险线大于红色精品2线可持股}
AA:=(2*C+H+L)/4;
操作线:MA(AA,5),LINETHICK2;
风险线:MA(CLOSE,13),LINETHICK3,COLORGREEN;
精品1:=EMA(EMA(EMA(CLOSE,2),2),2);
精品2:(MA(精品1,13) * 0.999),COLORWHITE,linethick3;
道2:=6*HHV(精品2,3)-5*精品2,COLORBLACK,linethick3;
PARTLINE(精品2=道2,精品2),LINETHICK3,COLORRED;
PARTLINE(精品2<道2,精品2),LINETHICK3,COLORWHITE;
牛股:=CROSS((100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8))),99);
攻:=ref(c,ref(hhvbars(v,21),0));
进攻:=ma(close,1)linethick0;
指挥:=V>1*ref(V,1) and (c/ref(C,1)-1)*100>9.5 and 进攻>=攻,COLORRED;
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
中线:=IF(J>K,J,0),COLOR00FFFF,LINETHICK2;
黑马:=中线>0 and ref(中线,1)=0;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
四线:=FILTER((VAR4AA>90),45);
AA05:=MA(C,5);
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
AA10:=MA(C,10);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10),COLORRED;
脸笑:=(if(牛股,1,0)+if(黑马,1,0)+if(四线,1,0)+if(狙击,1,0))>=2;
DRAWICON(脸笑,l*0.98,1),ALIGN1;
红三角:=CROSS(c,操作线) and c/ref(c,1)>1.03 and 操作线>风险线;
DRAWTEXT(红三角,l*0.98,’▲’),ALIGN0,PXDN20,COLORRED;
DK:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3),COLORWHITE;
晶红三角:DRAWTEXT(CROSS(DK,1),l*0.98,’▲’),ALIGN0,PXDN20,COLORMAGENTA;

请将这个指标改成大智慧版本,谢谢
 

 
解答如下:
AA:=(2*C+H+L)/4;
操作线:MA(AA,5),LINETHICK2;
风险线:MA(CLOSE,13),LINETHICK3,COLORGREEN;
精品1:=EMA(EMA(EMA(CLOSE,2),2),2);
精品2:(MA(精品1,13) * 0.999),COLORWHITE,linethick3;
道2:=6*HHV(精品2,3)-5*精品2;
PARTLINE(精品2,精品2=道2),LINETHICK3,COLORRED;
PARTLINE(精品2,精品2<道2),LINETHICK3,COLORWHITE;
牛股:=CROSS((100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8))),99);
攻:=ref(c,ref(hhvbars(v,21),0));
进攻:=ma(close,1);
指挥:=V>1*ref(V,1) and (c/ref(C,1)-1)*100>9.5 and 进攻>=攻;
RSV:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
K:=SMA(RSV,5,1);
D:=SMA(K,5,1);
J:=3*K-2*D;
中线:=IF(J>K,J,0);
黑马:=中线>0 and ref(中线,1)=0;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
四线:=FILTER((VAR4AA>90),45);
AA05:=MA(C,5);
BB05:=atan((aa05/ref(aa05,1)-1)*100)*180/3.1416;
AA10:=MA(C,10);
BB10:=atan((aa10/ref(aa10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
BB30:=atan((aa30/ref(aa30,1)-1)*100)*180/3.1416;
狙击:=filter(BB30>30 and BB10>45 and cross(BB05,60),10);
脸笑:=(if(牛股,1,0)+if(黑马,1,0)+if(四线,1,0)+if(狙击,1,0))>=2;
DRAWICON(脸笑,l*0.98,1),ALIGN1;
红三角:=CROSS(c,操作线) and c/ref(c,1)>1.03 and 操作线>风险线;
DRAWTEXT(红三角,l*0.98,’▲’),ALIGN0,COLORRED;
DK:=EMA((CLOSE-MA((2*CLOSE+HIGH+LOW)/4,30))/MA((2*CLOSE+HIGH+LOW)/4,30)*100,3);
DRAWTEXT(CROSS(DK,1),l*0.98,’▲’),ALIGN0,COLORMAGENTA;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址