• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把合必涨,逢低买入的红心信号,迫击反转三个指标合成一个选股公

常见公式 第一股票指标公式网 2周前 (10-17) 2次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请求老师和高手把请求老师把合必涨,逢低买入的红心信号,迫击反转三个指标做成一个选股公式,并可用于30分钟到日线的选股。
指标均来自理想论坛,在这里对原创作者表示最衷心的感谢。

合必涨
Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var3:=SMA(Var0,3,1);
Var1:=SMA(Var3,4,1)-10;
Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var5:=SMA(Var4,3,1);
Var2:=SMA(Var5,4,1)-90;
STICKLINE(REF(Var1,1)<Var1,Var1,REF(Var1,1),10,0),COLOR0000FF;
0, CIRCLEDOT;
STICKLINE(REF(Var1,1)>Var1,Var1,REF(Var1,1),5,0),COLOR00ff00;
STICKLINE(REF(Var2,1)>Var2,Var2,REF(Var2,1),10,0),COLOR0000FF;
STICKLINE(REF(Var2,1)<Var2,Var2,REF(Var2,1),5,0),COLOR00ff00;
0,COLOR0000FF;
Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

Var3:=SMA(Var0,3,1);
Var1:=SMA(Var3,4,1)-10;
Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var5:=SMA(Var4,3,1);
Var2:=SMA(Var5,4,1)-90;
STICKLINE(REF(Var1,1)<Var1,Var1,REF(Var1,1),10,0),COLOR0000FF;
0, CIRCLEDOT;
STICKLINE(REF(Var1,1)>Var1,Var1,REF(Var1,1),5,0),COLOR00ff00;
STICKLINE(REF(Var2,1)>Var2,Var2,REF(Var2,1),10,0),COLOR0000FF;
STICKLINE(REF(Var2,1)<Var2,Var2,REF(Var2,1),5,0),COLOR00ff00;
0,COLOR0000FF;

逢低买入的红星信号
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
长趋势:3*Q3-2*Q4,COLORWHITE,LINETHICK3;
趋势线:EMA(Q3, 3),COLORRED,LINETHICK3;
DRAWTEXT(CROSS(趋势线, 长趋势) AND REF(长趋势,1)>80, REF(长趋势,3), ‘顶’),COLORRED,LINETHICK5;
逢低买: DRAWTEXT(REF(CROSS(趋势线,长趋势),82) AND 趋势线>1.3*长趋势,长趋势,’逢低买’),LINETHICK1;
买: DRAWTEXT(REF(CROSS(长趋势,趋势线),1) AND 长趋势>1.3*趋势线,趋势线,’买’),COLORRED,LINETHICK1;
VAR3:=PEAKBARS(3,15,1)<10;
VAR5:=IF(VAR3=1,2,0);
顶:= IF(VAR5=2,2,0);
顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;
DRAWTEXT(顶A=50,45,’快逃’),COLOR00FF00;
金叉: CROSS(长趋势,趋势线);
DRAWTEXT(金叉,趋势线,’★’),COLORRED;
迫击反转
AA1:=filter(low=llv(low,13),8);
AA2:=if(LLV(low,3)=llv(low,13) and close<ref((high+low)/2,1),max(ref(llv(low,12),barslast(AA1)+1)-low,0),0);
AA3:=ema(AA2,3)*3;
AA4:=sumbars(AA3>0,21);
AA5:=sum(AA3,AA4)/21;
AA6:=ref(AA3,1)=hhv(AA3,3) and ref(AA3,1)>AA5*3 and count(close/ref(close,1)<0.9025,8)=0 and isup and llv(low,3)/hhv(high,18)<0.88;
AA7:=(count("ddx.ddx">0,5)>0 or not("ddx.ddx1"<"ddx.ddx2" and "ddx.ddx2"<"ddx.ddx3")) and count("ddx.ddx">ref("ddx.ddx",1),10)>=4;
反转:filter(AA6 and AA7,5),colorblack;

stickline(close,0,AA3,8,1),coloryellow;
stickline(反转,0,AA3,8,0),colorred;
 

 
解答如下:
{合必涨}
Var0:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var3:=SMA(Var0,3,1);
Var1:=SMA(Var3,4,1)-10;
Var4:=(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))*100;
Var5:=SMA(Var4,3,1);
Var2:=SMA(Var5,4,1)-90;
AA:=REF(Var1,1)<Var1 OR REF(Var2,1)>Var2;
{逢低买入的红星信号}
Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;
Q3:=SMA(Q2, 9, 1);
Q4:=SMA(Q3, 3, 1);
长趋势:=3*Q3-2*Q4;
趋势线:=EMA(Q3, 3);
金叉:=CROSS(长趋势,趋势线);
{迫击反转}
AA1:=filter(low=llv(low,13),8);
AA2:=if(LLV(low,3)=llv(low,13) and close<ref((high+low)/2,1),max(ref(llv(low,12),barslast(AA1)+1)-low,0),0);
AA3:=ema(AA2,3)*3;
AA4:=sumbars(AA3>0,21);
AA5:=sum(AA3,AA4)/21;
AA6:=ref(AA3,1)=hhv(AA3,3) and ref(AA3,1)>AA5*3 and count(close/ref(close,1)<0.9025,8)=0 and isup and llv(low,3)/hhv(high,18)<0.88;
AA7:=(count("ddx.ddx">0,5)>0 or not("ddx.ddx1"<"ddx.ddx2" and "ddx.ddx2"<"ddx.ddx3")) and count("ddx.ddx">ref("ddx.ddx",1),10)>=4;
反转:=filter(AA6 and AA7,5);
(AA OR 金叉) AND 反转;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址