• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

将此分时横突做一分时预警公式

常见公式 第一股票指标公式网 1周前 (10-17) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

请老师将其出现"突破"二字时做一选股公式.谢谢.
源码如下:
时长:=if(HOUR>=10 AND HOUR<15 ,1,0);{10点至 15点}
均线:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0)));
均线H:(均线*1.007 ),COLORFF6600;
均线L:(均线/1.005 ),COLOR00FF00;
FILLRGN(均线L,均线,c>均线L and c<均线H),COLORYELLOW;
均线横盘:=C<均线H and C>均线L;
量比:=sum(vol,0)*240/dynainfo(38)/barscount(c);
量比5分钟:=sum(量比,5);
量比10:=sum(量比,10);
上个5分钟量比:=量比10-量比5分钟;
放量:=sum(VOL,6)>REF(ma(VOL,30),1)*10;
CC:CLOSE,COLORWHITE,LINETHICK2;
横盘:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1;
横涨:量比5分钟>上个5分钟量比 and 横盘 and 时长 and 放量 and (CC>均线H) and DYNAINFO(22)<DYNAINFO(23),LINETHICK0;
横跌:=横盘 and 时长 and 放量 and CROSS(均线L,CC) ;
DRAWTEXT(CROSS(横涨,0),均线,’▲’),COLORRED,LAYER0;
突破:FILTER(横涨,100),LINETHICK0;
下破:=FILTER(横跌,50);
DRAWTEXT(突破,均线H,’★突破’),COLORFF00FF,LAYER0;
DRAWTEXT(下破,均线L,’★下破’),COLOR00FF00,LAYER0;
VERTLINE(突破,3),COLORFF00FF,LINETHICK2;
VERTLINE(下破,3),COLOR00FF00,LINETHICK2;
MA30:=EMA(CLOSE,30);
强弱界定:EMA(CLOSE,900);
STICKLINE((MA30>强弱界定),MA30,强弱界定,1,0),Color0000FF;
STICKLINE((MA30<强弱界定),MA30,强弱界定,1,0),Color00FF00;
DRAWICON(CROSS(MA30,强弱界定),H,7),LAYER0;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
DRAWTEXTABS(10,180,’■所属板块:’+BKNAME),ColorYELLOW,linethick1;
流通盘大小:=FINANCE2(37)/1000000*100;
DRAWTEXTABS(280,200,’流通盘大小:’+NUMTOSTRN(流通盘大小,2)+’亿’),LINETHICK1,ColorYELLOW;
每股收益:=FINANCE2(3);
每股市盈率:=DYNAINFO(39);
每股净资产:=FINANCE2(4);
销售毛利率:=FINANCE2(12);
主营收入同比:=FINANCE2(11);
净利润同比增长:=FINANCE2(10);
DRAWTEXTABS(170,200,’每股收益:’+NUMTOSTRN(每股收益,2)+’元’),COLOR00FF00;
DRAWTEXTABS(170,220,’每股市盈率:’+NUMTOSTRN(每股市盈率,1)+’倍’),COLORRED;
DRAWTEXTABS(170,240,’每股净资产:’+NUMTOSTRN(每股净资产,2)+’元’),COLORRED;
DRAWTEXTABS(20,200,’销售毛利率:’+NUMTOSTRN(销售毛利率,2)+’%’),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(20,220,’主营收入同比增长:’+NUMTOSTRN(主营收入同比,2)+’%’),LINETHICK1,COLOR00FF00;
DRAWTEXTABS(20,240,’净利润同比增长:’+NUMTOSTRN(净利润同比增长,2)+’%’),LINETHICK1,COLOR00FF00;
 
 
解答如下:
时长:=if(HOUR>=10 AND HOUR<15 ,1,0);
均线:=IF(BETWEEN(C/(SUM(AMOUNT,0)/SUM(VOL*100,0)),1.05,0.95)=0,MA(C,0),(SUM(AMOUNT,0)/SUM(VOL*100,0)));
均线H:=(均线*1.007 );
均线L:=(均线/1.005 );

均线横盘:=C<均线H and C>均线L;
量比:=sum(vol,0)*240/dynainfo(38)/barscount(c);
量比5分钟:=sum(量比,5);
量比10:=sum(量比,10);
上个5分钟量比:=量比10-量比5分钟;
放量:=sum(VOL,6)>REF(ma(VOL,30),1)*10;
CC:=CLOSE;
横盘:=((HHV(CLOSE,BARSCOUNT(CLOSE))-LLV(CLOSE,BARSCOUNT(CLOSE)))/CLOSE)<1;
横涨:=量比5分钟>上个5分钟量比 and 横盘 and 时长 and 放量 and (CC>均线H) and DYNAINFO(22)<DYNAINFO(23);
突破:FILTER(横涨,100);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址