• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把macd公式改为大智慧2用

常见公式 第一股票指标公式网 4天前 2次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

MACD:"MACD.MACD",COLORSTICK;
WW:=MACD<MIN(REF(MACD,1),REFX(MACD,1));
QQ:=MACD>MAX(REF(MACD,1),REFX(MACD,1));
TT:=BARSLAST(WW);
DD:=BARSLAST(QQ);
AA:=WW
AND
C<REF(C,REF(TT,1)+1) AND MACD>REF(MACD,REF(TT,1)+1) ;
AC:=QQ
AND C>REF(C,REF(DD,1)+1) AND
MACD<REF(MACD,REF(DD,1)+1);
DRAWLINE(TT=0,MACD,AA,MACD,0);
DRAWLINE(DD=0,MACD,AC,MACD,0);

帮忙把公式改成大智慧2的谢谢

 
解答如下:
"REFX"—-通达信、飞狐特有未来函数。大智慧没有此函数的相应替代函数。故而,改不了。
如果非得改的话,只有这样,但可能与你原来的有差别。
====================
MACD:"MACD.MACD",COLORSTICK;
WW:=MACD<MIN(REF(MACD,1),REF(MACD,1));
QQ:=MACD>MAX(REF(MACD,1),REF(MACD,1));
TT:=BARSLAST(WW);
DD:=BARSLAST(QQ);
AA:=WW
AND
C<REF(C,REF(TT,1)+1) AND MACD>REF(MACD,REF(TT,1)+1) ;
AC:=QQ
AND C>REF(C,REF(DD,1)+1) AND
MACD<REF(MACD,REF(DD,1)+1);
DRAWLINE(TT=0,MACD,AA,MACD,0);
DRAWLINE(DD=0,MACD,AC,MACD,0);

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址