• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

判断现在是否买入状态买入信号改为选股公式

常见公式 第一股票指标公式网 4周前 (10-29) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

高手帮忙编写个出现买入信号的选股公式
原码:RSV=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
a=SMA(RSV,3,1);
b=SMA(a,3,1);
e=3*a-2*b;
MA$1:MA(CLOSE,n);
IF(a<0) a=0;
IF(a>100) a=100;
IF(b<0) b=0;
IF(b>100) b=100;
IF(e<0) e=0;
IF(e>100) e=100;

IsNowBuy:=FALSE;

sBUY:=CLOSE<1.2*LLV(LOW,7) AND CLOSE>MA(CLOSE,5) AND a>50 AND CROSS(MA(CLOSE,5),MA(CLOSE,10)); //买入信号
DRAWICON (sBUY,LOW,"buy");

//判断现在是否买入状态
IF(sBuy==TRUE OR IsNowBuy[1]==TRUE)
IsNowBuy:=TRUE;
//

 
解答如下:
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
a:=SMA(RSV,3,1);
sBUY:CLOSE<1.2*LLV(LOW,7) AND CLOSE>MA(CLOSE,5) AND a>50 AND CROSS(MA(CLOSE,5),MA(CLOSE,10));
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址