• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

据这个指标做个量突和雨水两个选股公式

常见公式 第一股票指标公式网 4周前 (10-30) 8次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

{乘风自用换手VOL}
DRAWGBK(CLOSE=CLOSE,COLORRGB(30,30,60),COLORRGB(30,30,60),1);
预测额:=IF(DATE<>CURRENTDATE OR OPENMINUTES(CURRENTTIME)=1,AMOUNT,(AMOUNT/OPENMINUTES(CURRENTTIME))*240), LINETHICK;
n:=20;
SAT:=IF((预测额/CLOSE)/(HHV(预测额,N)/HHV(CLOSE,N))*100>100,100,(预测额/CLOSE)/(HHV(预测额,N)/HHV(CLOSE,N))*100);
预测量:=IF(DATE<>CURRENTDATE OR OPENMINUTES(CURRENTTIME)=1,VOL,(VOL/OPENMINUTES(CURRENTTIME))*240), LINETHICK;
量:=VOL;
V0001:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,V0001*(HIGH-LOW),IF(CLOSE<OPEN,V0001*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),Color6d0076,POINTDOT,LINETHICK0,PRECISION0;
主卖:IF(CLOSE>OPEN,0-V0001*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-V0001*(HIGH-LOW),0-VOL/2)),ColorFFD1BE,POINTDOT,LINETHICK0,PRECISION0;
净买:主买+主卖,COLORMAGENTA,LINETHICK0,PRECISION0;
换手率:=VOL/CAPITAL*100;
hs:=换手率;
量比:IF(BARPOS=DATACOUNT,DYNAINFO(17),VOL/REF(MA(VOL,5),1)),LINETHICK0,COLORYELLOW,PRECISION2;
A:=MA(换手率,2);
X:=LLV(A,20),linethick;
X1:=(A-LLV(A,20))=0;
换手最小:=IF(ALL (A>0,5) AND FILTERX(X1,5),X1,0),COLORRED;
小天:BARSLAST(换手最小),LINETHICK,color008888;
X2:=HHV(A,20);
X3:=(A-X2)=0;
换手最大:=IF(ALL(REF(A,1)<X2,5) AND FILTERX(X3,5),1,0),COLORGREEN;

STICKLINE(CLOSE<=REF(CLOSE,1) , VOL,0,8.5,0), Color808040;
STICKLINE(CLOSE>REF(CLOSE,1), VOL,0,8.5,1) {ColorFF4D80}ColorFF87FF,LINETHICK2;

STICKLINE(净买>0,0,主买,5,0),color102088;
STICKLINE(净买>0,0,主买,4,0),color1020aa;
STICKLINE(净买>0,0,主买,3,0),color1020bb;
STICKLINE(净买>0,0,主买,2,0),color1020bb;
STICKLINE(净买>0,0,主买,1,0),color1020dd;
STICKLINE(净买>0,0,主买,0.5,0),color1020ee;
STICKLINE(净买<=0,0,主买,5,0),color102088;
STICKLINE(净买<=0,0,主买,4,0),color1020aa;
STICKLINE(净买<=0,0,主买,3,0),color1020bb;
STICKLINE(净买<=0,0,主买,2,0),color1020cc;
STICKLINE(净买<=0,0,主买,1,0),color1020dd;
STICKLINE(净买<=0,0,主买,0.5,0),color1020ee;

STICKLINE(净买>0,v,主买,5,0),COLORFF7700;
STICKLINE(净买>0,v,主买,4,0),COLORFF8811;
STICKLINE(净买>0,v,主买,3,0),COLORFFAA22;
STICKLINE(净买>0,v,主买,2,0),COLORFFBB33;
STICKLINE(净买>0,v,主买,1,0),COLORFFDD44;
STICKLINE(净买>0,v,主买,0.5,0),COLORFFFF55;
STICKLINE(净买<=0,v,主买,5,0),COLORFF7700;
STICKLINE(净买<=0,v,主买,4,0),COLORFF8811;
STICKLINE(净买<=0,v,主买,3,0),COLORFFAA22;
STICKLINE(净买<=0,v,主买,2,0),COLORFFBB33;
STICKLINE(净买<=0,v,主买,1,0),COLORFFDD44;
STICKLINE(净买<=0,v,主买,0.5,0),COLORFFFF55;

STICKLINE(c,量比*15000,0,2,0),COLORYELLOW;

{线形}
h13:=HHV(MA(VOL,13),13),COLORGREEN;
l13:=LLV(MA(VOL,5),13),COLORBROWN,LINETHICK2;
PARTLINE(CLOSE,l13),COLORBROWN,LINETHICK2;
PARTLINE(CLOSE,h13),COLORGREEN;
mv5:MA(VOL,5),color8888FF,PRECISION0;
mv13:MA(VOL,13),COLORMAGENTA,PRECISION0;
mv34:MA(VOL,34),LINEDOT,COLORWHITE,PRECISION0;
{信号和文字提示}
PARTLINE(MA(SUM(主买,34),10)<SUM(主买,34),-300),COLORMAGENTA,LINETHICK2;
PARTLINE(MA(SUM(主买,34),10)>=SUM(主买,34) ,-300),COLORBLUE,LINETHICK2;
DRAWICON(MA(SUM(主买,34),10)>REF(MA(SUM(主买,34),10),1),-300,12);
DRAWICON(MA(SUM(主买,34),10)<=REF(MA(SUM(主买,34),10),1),-300,11);

天量:=VOL=HHV(VOL,0);
VERTLINE(天量),LINEDOT,COLORYELLOW;
DRAWTEXT(REF(COUNT(VOL>l13,8)=8,1) and VOL<l13,VOL,’量\n缩’),COLORWHITE,ALIGN;
DRAWTEXT(REF(COUNT(VOL<mv34,8)=8,1) and VOL>mv34,VOL,’量\n突’),COLORWHITE,ALIGN;
F:=100*(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
今小昨:=IF(CLOSE<REF(OPEN,1) AND F<0,1,0);
Sa1:=今小昨;
今小前:=IF(CLOSE<REF(OPEN,2) AND F<0,1,0),LINETHICK0;
Sa2:=今小前;
STICKLINE(Sa1=0 AND REF(Sa1,1)=1 AND Sa2=0 AND REF(Sa2,1)=1 AND CROSS(ZIG(3,3),REF(ZIG(3,3),1)),VOL*2,0,0.1,0),LINEDOT,colorFF00FF;//此信号是未来函数

{二十四节气}
立春:=FILTER(MONTH=2 AND (DAY=3 OR DAY=5 ),2);
雨水:=FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
惊蛰:=FILTER(MONTH=3 AND (DAY=5 OR DAY=7 ),2);
春分:=FILTER(MONTH=3 AND (DAY=20 OR DAY=22),2);
清明:=FILTER(MONTH=4 AND (DAY=4 OR DAY=6 ),2);
谷雨:=FILTER(MONTH=4 AND (DAY=19 OR DAY=21),2);
立夏:=FILTER(MONTH=5 AND (DAY=6 OR DAY=8 ),2);
小满:=FILTER(MONTH=5 AND (DAY=20 OR DAY=22),2);
芒种:=FILTER(MONTH=6 AND (DAY=5 OR DAY=7 ),2);
夏至:=FILTER(MONTH=6 AND (DAY=20 OR DAY=22),2);
小暑:=FILTER(MONTH=7 AND (DAY=6 OR DAY=8 ),2);
大署:=FILTER(MONTH=7 AND (DAY=22 OR DAY=24),2);
立秋:=FILTER(MONTH=8 AND (DAY=7 OR DAY=9 ),2);
处暑:=FILTER(MONTH=8 AND (DAY=22 OR DAY=24),2);
白露:=FILTER(MONTH=9 AND (DAY=7 OR DAY=9 ),2);
秋分:=FILTER(MONTH=9 AND (DAY=22 OR DAY=24),2);
寒露:=FILTER(MONTH=10 AND (DAY=7 OR DAY=9 ),2);
霜降:=FILTER(MONTH=10 AND (DAY=22 OR DAY=24),2);
立冬:=FILTER(MONTH=11 AND (DAY=7 OR DAY=9 ),2);
小雪:=FILTER(MONTH=11 AND (DAY=22 OR DAY=24),2);
大雪:=FILTER(MONTH=12 AND (DAY=6 OR DAY=8 ),2);
冬至:=FILTER(MONTH=12 AND (DAY=21 OR DAY=23),2);
小寒:=FILTER(MONTH=1 AND (DAY=5 OR DAY=7 ),2);
大寒:=FILTER(MONTH=1 AND (DAY=19 OR DAY=21),2);
DRAWTEXT(立春,100,’立春’),COLORgreen,ALIGN;
DRAWTEXT(雨水,100,’雨水’),COLORgreen,ALIGN;
DRAWTEXT(惊蛰,100,’惊蛰’),COLORgreen,ALIGN;
DRAWTEXT(春分,100,’春分’),COLORgreen,ALIGN;
DRAWTEXT(清明,100,’清明’),COLORgreen,ALIGN;
DRAWTEXT(谷雨,100,’谷雨’),COLORgreen,ALIGN;
DRAWTEXT(立夏,100,’立夏’),COLORMAGENTA,ALIGN;
DRAWTEXT(小满,100,’小满’),COLORMAGENTA,ALIGN;
DRAWTEXT(芒种,100,’芒种’),COLORMAGENTA,ALIGN;
DRAWTEXT(夏至,100,’夏至’),COLORMAGENTA,ALIGN;
DRAWTEXT(小暑,100,’小暑’),COLORMAGENTA,ALIGN;
DRAWTEXT(大署,100,’大署’),COLORMAGENTA,ALIGN;
DRAWTEXT(立秋,100,’立秋’),COLORYELLOW,ALIGN;
DRAWTEXT(处暑,100,’处暑’),COLORYELLOW,ALIGN;
DRAWTEXT(白露,100,’白露’),COLORYELLOW,ALIGN;
DRAWTEXT(秋分,100,’秋分’),COLORYELLOW,ALIGN;
DRAWTEXT(寒露,100,’寒露’),COLORYELLOW,ALIGN;
DRAWTEXT(霜降,100,’霜降’),COLORYELLOW,ALIGN;
DRAWTEXT(立冬,100,’立冬’),COLORWHITE,ALIGN;
DRAWTEXT(小雪,100,’小雪’),COLORWHITE,ALIGN;
DRAWTEXT(大雪,100,’大雪’),COLORWHITE,ALIGN;
DRAWTEXT(冬至,100,’冬至’),COLORWHITE,ALIGN;
DRAWTEXT(小寒,100,’小寒’),COLORWHITE,ALIGN;
DRAWTEXT(大寒,100,’大寒’),COLORWHITE,ALIGN;

svol:=INTPART(SUM(VOL,0)/CAPITAL);
tj0:=svol>REF(svol,1) or BARSSINCE(CLOSE)=0;
S1:=BARSLAST(tj0)+1,PRECISION,COLORWHITE;//时间1
tj2:=S1<REF(S1,1);//取点
S2:=IF(tj2,REF(S1,1)+1,S1),PRECISION,COLORMAGENTA;//时间2
S3:=SUM(tj2,0),COLORMAGENTA;
阶段总额(万元):=SUM(AMOUNT/10000,S2)*100,PRECISION,LINETHICK,Color008BFA;//换手100%AMOUNT
阶段总量(手):=SUM(VOL,S2)*100,PRECISION,LINETHICK,COLORCYAN;//换手100%VOL
阶段成本(元):=(阶段总额(万元)/(阶段总量(手)/100)),LINETHICK,PRECISION2,COLORRED;
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,’■阶段平均成本:’+NUMTOSTR(阶段成本(元)[SYSPARAM(1)],2)+'(元)’),align4,COLORCYAN;
{取点}
Zk1:=STKINDI(” ,’kdj.k’,0,7);
Zd2:=STKINDI(” ,’kdj.d’,0,7);
ZF1:=STKINDI(” ,’macd.diff’,0,7);
ZA2:=STKINDI(” ,’macd.dea’,0,7);
{建仓统计}
JCD:=FILTER(CROSS(Zk1,Zd2) and Zd2<30,13);{周KD金叉位置}
取点:=BARSLAST(JCD);
吸筹区:=IF(取点>0 and 取点<61,取点,0);
ZS1:=吸筹区;
ZS2:=吸筹区+1;
ZS3:=换手率/5;{庄家筹码估算}
ZSA:=IF(ZS1>0,SUM((ZS3),吸筹区+1),0);{统计庄家筹码}
{控制画线高度}
n1:=SYSPARAM(3);
nn:=n1-SYSPARAM(2)+1;
hh:=HHV(VOL,nn);
ll:=LLV(VOL,nn);
最高:=hh[n1];
最低:=ll[n1];
中:=最低+(最高-最低)*0.5;
//PARTLINE(RANGE(BARPOS,SYSPARAM(2),SYSPARAM(1)+1) and ZS1>0,中),COLORCYAN,LINETHICK2;//建仓横线
VERTLINE(JCD),LINEDOT,COLORRED;//建仓点竖线

{左侧数字}
三日总换手:=SUM(换手率,3);
五日总换手:=SUM(换手率,5);
十日总换手:=SUM(换手率,10);
二十日总换手:=SUM(换手率,20);
DRAWTEXTEX(CLOSE,1,120,60,’\n\n■十日总换手■’),COLORRED;
DRAWTEXTEX(CLOSE,1,120,115,’\n\n今总:’+NUMTOSTR(十日总换手,2)+’ %’+’\n’+’昨总:’+NUMTOSTR(REF(十日总换手,1),2)+’ %’+’\n’+’前总:’
+NUMTOSTR(REF(十日总换手,2),2)+’ %’+’\n’+’前一:’+NUMTOSTR(REF(十日总换手,3),2)+’ %’+’\n’+’前二:’+NUMTOSTR(REF(十日总换手,4),2)+’ %’),colorFFFF;
DRAWTEXTEX(CLOSE,1,120,390,’\n\n■二十日总换手■’),COLORRED;
DRAWTEXTEX(CLOSE,1,120,435,’\n\n今总:’+NUMTOSTR(二十日总换手,2)+’ %’+’\n’+’昨总:’+NUMTOSTR(REF(二十日总换手,1),2)+’ %’+’\n’+’前总:’
+NUMTOSTR(REF(二十日总换手,2),2)+’ %’+’\n’+’前一:’+NUMTOSTR(REF(二十日总换手,3),2)+’ %’+’\n’+’前二:’+NUMTOSTR(REF(二十日总换手,4),2)+’ %’),COLORWHITE;
DRAWTEXTEX(CLOSE,1,1,60,’\n\n■三日总换手■’),COLORRED;
DRAWTEXTEX(CLOSE,1,1,115,’\n\n今总:’+NUMTOSTR(三日总换手,2)+’ %’+’\n’+’昨总:’+NUMTOSTR(REF(三日总换手,1),2)+’ %’+’\n’+’前总:’
+NUMTOSTR(REF(三日总换手,2),2)+’ %’+’\n’+’前一:’+NUMTOSTR(REF(三日总换手,3),2)+’ %’+’\n’+’前二:’+NUMTOSTR(REF(三日总换手,4),2)+’ %’),colorFFFF;
DRAWTEXTEX(CLOSE,1,1,390,’\n\n■五日总换手■’),COLORRED;
DRAWTEXTEX(CLOSE,1,1,435,’\n\n今总:’+NUMTOSTR(五日总换手,2)+’ %’+’\n’+’昨总:’+NUMTOSTR(REF(五日总换手,1),2)+’ %’+’\n’+’前总:’
+NUMTOSTR(REF(五日总换手,2),2)+’ %’+’\n’+’前一:’+NUMTOSTR(REF(五日总换手,3),2)+’ %’+’\n’+’前二:’+NUMTOSTR(REF(五日总换手,4),2)+’ %’),COLORWHITE;
{可移动变化数字}
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1)&&SYSPARAM(1)>ZS1,中*2.5,’ ■主力建仓天数:’+NUMTOSTR(ZS1[SYSPARAM(1)],0)+'(天)’),PXDN30,align2,COLORYELLOW;
DRAWTEXT(BARSCOUNT(CLOSE)=SYSPARAM(1)&&SYSPARAM(1)>ZS1,中*2.5,’ \n■估算主力筹码:’+NUMTOSTR(ZSA[SYSPARAM(1)],2)+’%’),PXDN30,align2,COLORMAGENTA;
DRAWICON(FILTER(CROSS(ZF1,ZA2),5),0,4),align;
DRAWICON(FILTER(CROSS(Zk1,Zd2),5),0,8),align;
DRAWICON(FILTER(CROSS(Zd2,Zk1),5),0,9),align;
DRAWTEXT(SYSPARAM(1)=BARPOS,中*2.5,’ \n \n■爆发力度: ‘+NUMTOSTR(sat[SYSPARAM(1)],2)),COLORRED,PXDN30,align2;
STICKLINE(SAT>REF(SAT,1)+5 AND VOL>REF(VOL,1),REF(VOL,1)*0.98,REF(VOL,1),10,0),COLORWHITE;
VERTLINE(ALL (A>0,5) AND FILTERX(X1,5)),COLORRED;
DRAWTEXT(SYSPARAM(1)=BARPOS and ALL(A>0,5) AND FILTERX(X1,5),10,’■换手特小’),COLORRED,align4;
DRAWTEXT(SYSPARAM(1)=BARPOS and ALL(REF(A,1)<X2,5) AND FILTERX(X3,5),10,’■换手过大’),COLORGREEN,align4;

换手极低:=hs<=1;
换手冷清:=hs>1 and hs<=3;
换手正常:=hs>3 and hs<=5;
换手活跃:=hs>5 and hs<=9;
换手热烈:=hs>9 and hs<=13;
换手旺盛:=hs>13 and hs<=20;
换手过热:=hs>20 and hs<30;
换手异常:=hs>=30;

DRAWTEXT(换手极低 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手极低:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORGRAY;
DRAWTEXT(换手冷清 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手冷清:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORBLUE;
DRAWTEXT(换手正常 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手正常:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORWHITE;
DRAWTEXT(换手活跃 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手活跃:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORYELLOW;
DRAWTEXT(换手热烈 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手热烈:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORRED;
DRAWTEXT(换手旺盛 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手旺盛:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORMAGENTA;
DRAWTEXT(换手过热 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手过热:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORBROWN;
DRAWTEXT(换手异常 AND BARPOS=SYSPARAM(1),中*2.5,’ \n \n \n■换手异常:’+NUMTOSTR(换手率[SYSPARAM(1)],2)+’% ‘),PXDN30,align2,COLORGREEN;
比率:=(预测量-REF(VOL,1))/REF(VOL,1)*100;
DRAWTEXT(预测量>REF(VOL,1) and BARPOS=SYSPARAM(1),中*2.5,
‘ \n \n \n \n ■预测量:’+NUMTOSTR(预测量[SYSPARAM(1)],0)+'(+’+NUMTOSTR(比率[SYSPARAM(1)],2)+’% ‘+’)’),PXDN30,align2,COLORRED;
DRAWTEXT(预测量<=REF(VOL,1) and BARPOS=SYSPARAM(1),中*2.5,
‘ \n \n \n \n ■预测量:’+NUMTOSTR(预测量[SYSPARAM(1)],0)+'(-‘+NUMTOSTR(比率[SYSPARAM(1)],2)+’% ‘+’)’),PXDN30,align2,COLORGREEN;

{界定右侧字符区域}
STICKLINE(ISLASTBAR AND CLOSE>0,中*2.1,中*2.1,12,0),COLORWHITE,SHIFT1;
STICKLINE(ISLASTBAR AND CLOSE>0,中*2.1,中*2.1,12,0),COLORWHITE,SHIFT2;
STICKLINE(ISLASTBAR AND CLOSE>0,中*2.1,中*2.1,12,0),COLORWHITE,SHIFT3;
STICKLINE(ISLASTBAR AND CLOSE>0,中*2.1,中*2.1,12,0),COLORWHITE,SHIFT4;
STICKLINE(ISLASTBAR AND CLOSE>0,中*2.1,中*2.1,12,0),COLORWHITE,SHIFT5;

STICKLINE(ISLASTBAR AND CLOSE>0,中*1.5,中*1.5,12,0),COLORYELLOW,SHIFT1;
STICKLINE(ISLASTBAR AND CLOSE>0,中*1.5,中*1.5,12,0),COLORYELLOW,SHIFT2;
STICKLINE(ISLASTBAR AND CLOSE>0,中*1.5,中*1.5,12,0),COLORYELLOW,SHIFT3;
STICKLINE(ISLASTBAR AND CLOSE>0,中*1.5,中*1.5,12,0),COLORYELLOW,SHIFT4;
STICKLINE(ISLASTBAR AND CLOSE>0,中*1.5,中*1.5,12,0),COLORYELLOW,SHIFT5;

STICKLINE(ISLASTBAR AND CLOSE>0,中*0.9,中*0.9,12,0),COLORRED,SHIFT1;
STICKLINE(ISLASTBAR AND CLOSE>0,中*0.9,中*0.9,12,0),COLORRED,SHIFT2;
STICKLINE(ISLASTBAR AND CLOSE>0,中*0.9,中*0.9,12,0),COLORRED,SHIFT3;
STICKLINE(ISLASTBAR AND CLOSE>0,中*0.9,中*0.9,12,0),COLORRED,SHIFT4;
STICKLINE(ISLASTBAR AND CLOSE>0,中*0.9,中*0.9,12,0),COLORRED,SHIFT5;

{5日换手柱状右侧显示}
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<1,0,REF(hs,4)*5000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<1,0,REF(hs,3)*5000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<1,0,REF(hs,2)*5000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<1,0,REF(hs,1)*5000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<1,0,hs*5000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000<2 and FINANCE(7)/10000>=1,0,REF(hs,4)*10000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<2 and FINANCE(7)/10000>=1,0,REF(hs,3)*10000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<2 and FINANCE(7)/10000>=1,0,REF(hs,2)*10000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<2 and FINANCE(7)/10000>=1,0,REF(hs,1)*10000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<2 and FINANCE(7)/10000>=1,0,hs*10000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000<4 and FINANCE(7)/10000>=2,0,REF(hs,4)*20000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<4 and FINANCE(7)/10000>=2,0,REF(hs,3)*20000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<4 and FINANCE(7)/10000>=2,0,REF(hs,2)*20000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<4 and FINANCE(7)/10000>=2,0,REF(hs,1)*20000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<4 and FINANCE(7)/10000>=2,0,hs*20000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000<6 and FINANCE(7)/10000>=4,0,REF(hs,4)*30000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<6 and FINANCE(7)/10000>=4,0,REF(hs,3)*30000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<6 and FINANCE(7)/10000>=4,0,REF(hs,2)*30000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<6 and FINANCE(7)/10000>=4,0,REF(hs,1)*30000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<6 and FINANCE(7)/10000>=4,0,hs*30000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000<9 and FINANCE(7)/10000>=6,0,REF(hs,4)*45000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<9 and FINANCE(7)/10000>=6,0,REF(hs,3)*45000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<9 and FINANCE(7)/10000>=6,0,REF(hs,2)*45000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<9 and FINANCE(7)/10000>=6,0,REF(hs,1)*45000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<9 and FINANCE(7)/10000>=6,0,hs*45000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000<12 and FINANCE(7)/10000>=9,0,REF(hs,4)*65000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<12 and FINANCE(7)/10000>=9,0,REF(hs,3)*65000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<12 and FINANCE(7)/10000>=9,0,REF(hs,2)*65000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<12 and FINANCE(7)/10000>=9,0,REF(hs,1)*65000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<12 and FINANCE(7)/10000>=9,0,hs*65000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000<20 and FINANCE(7)/10000>=12,0,REF(hs,4)*90000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<20 and FINANCE(7)/10000>=12,0,REF(hs,3)*90000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<20 and FINANCE(7)/10000>=12,0,REF(hs,2)*90000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<20 and FINANCE(7)/10000>=12,0,REF(hs,1)*90000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000<20 and FINANCE(7)/10000>=12,0,hs*90000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=20 AND FINANCE(7)/10000<35,0,REF(hs,4)*150000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=20 AND FINANCE(7)/10000<35,0,REF(hs,3)*150000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=20 AND FINANCE(7)/10000<35,0,REF(hs,2)*150000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=20 AND FINANCE(7)/10000<35,0,REF(hs,1)*150000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=20 AND FINANCE(7)/10000<35,0,hs*150000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=35 AND FINANCE(7)/10000<50,0,REF(hs,4)*250000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=35 AND FINANCE(7)/10000<50,0,REF(hs,3)*250000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=35 AND FINANCE(7)/10000<50,0,REF(hs,2)*250000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=35 AND FINANCE(7)/10000<50,0,REF(hs,1)*250000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=35 AND FINANCE(7)/10000<50,0,hs*250000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=50 AND FINANCE(7)/10000<100,0,REF(hs,4)*550000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=50 AND FINANCE(7)/10000<100,0,REF(hs,3)*550000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=50 AND FINANCE(7)/10000<100,0,REF(hs,2)*550000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=50 AND FINANCE(7)/10000<100,0,REF(hs,1)*550000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=50 AND FINANCE(7)/10000<100,0,hs*550000,8,0),SHIFT1,color1472FF;

STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=100,0,REF(hs,4)*1000000,8,0),SHIFT5,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=100,0,REF(hs,3)*1000000,8,0),SHIFT4,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=100,0,REF(hs,2)*1000000,8,0),SHIFT3,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=100,0,REF(hs,1)*1000000,8,0),SHIFT2,color1472FF;
STICKLINE(ISLASTBAR AND FINANCE(7)/10000>=100,0,hs*1000000,8,0),SHIFT1,color1472FF;
{五日换手数字}
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*0.8,’一换’+’\n’+NUMTOSTR(hs,2)),ALIGN,SHIFT1,COLORWHITE;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*0.8,’二换’+’\n’+NUMTOSTR(REF(hs,1),2)),ALIGN,SHIFT2,COLORWHITE;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*0.8,’三换’+’\n’+NUMTOSTR(REF(hs,2),2)),ALIGN,SHIFT3,COLORWHITE;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*0.8,’四换’+’\n’+NUMTOSTR(REF(hs,3),2)),ALIGN,SHIFT4,COLORWHITE;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*0.8,’五换’+’\n’+NUMTOSTR(REF(hs,4),2)),ALIGN,SHIFT5,COLORWHITE;
{五日量比数字}
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*1.4,’今日’+’\n’+’量比’+’\n’+NUMTOSTR(量比,2)),ALIGN,SHIFT1,COLORGREEN;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*1.4,’昨日’+’\n’+’量比’+’\n’+NUMTOSTR(REF(量比,1),2)),ALIGN,SHIFT2,COLORGREEN;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*1.4,’前日’+’\n’+’量比’+’\n’+NUMTOSTR(REF(量比,2),2)),ALIGN,SHIFT3,COLORGREEN;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*1.4,’前一’+’\n’+’量比’+’\n’+NUMTOSTR(REF(量比,3),2)),ALIGN,SHIFT4,COLORGREEN;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*1.4,’前二’+’\n’+’量比’+’\n’+NUMTOSTR(REF(量比,4),2)),ALIGN,SHIFT5,COLORGREEN;
{三日买盘和增比数字}
主买比:=(主买-ref(主买,1))/ref(主买,1);
昨主买比:=(ref(主买,1)-ref(主买,2))/ref(主买,2);
前主买比:=(ref(主买,2)-ref(主买,3))/ref(主买,3);
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*2.0,’现主买’+’\n’+NUMTOSTR(主买,0)+’\n’+’增’+NUMTOSTR(主买比,2)),ALIGN,SHIFT1,COLORRED;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*2.0,’昨主买’+’\n’+NUMTOSTR(ref(主买,1),0)+’\n’+’增’+NUMTOSTR(昨主买比,2)),ALIGN,SHIFT3,COLORRED;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*2.0,’前主买’+’\n’+NUMTOSTR(ref(主买,2),0)+’\n’+’增’+NUMTOSTR(前主买比,2)),ALIGN,SHIFT5,COLORRED;
{三日净买数字}
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*2.5,’现净买’+’\n’+NUMTOSTR(净买,0)),ALIGN,SHIFT1,coloryellow;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*2.5,’昨净买’+’\n’+NUMTOSTR(ref(净买,1),0)),ALIGN,SHIFT3,coloryellow;
DRAWTEXT(ISLASTBAR AND CLOSE>0,中*2.5,’前净买’+’\n’+NUMTOSTR(ref(净买,2),0)),ALIGN,SHIFT5,coloryellow;
 

 
解答如下:
mv34:=MA(VOL,34);
量突:REF(COUNT(VOL<mv34,8)=8,1) and VOL>mv34;

雨水:FILTER(MONTH=2 AND (DAY=18 OR DAY=20),2);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址