• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

ELSE IF THEN 函数的用法

常见公式 第一股票指标公式网 4周前 (10-30) 7次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

收阳:=C>=REF(C,1);
收阴:=C<REF(C,1);
放量:=VOL>REF(VOL,1);
缩量:=VOL<REF(VOL,1);
if 收阳 AND 放量 then
得分:=2;
else IF 收阳 AND 缩量 then
得分:=1;
else IF 收阴 AND 放量 then
得分:=-2;
else IF 收阴 AND 缩量 then
得分:=-1;
得分:=得分;
五日得分:sum(得分,5),linethick0,precis0;
STICKLINE(五日得分<0,0,五日得分,4,0),COLORGREEN;
STICKLINE(五日得分>0,0,五日得分,4,0),COLORRED;
 
解答如下:
收阳:=C>REF(C,1);
收阴:=C<REF(C,1);
放量:=VOL>REF(VOL,1);
缩量:=VOL<REF(VOL,1);

得分:c*0;
for i=2 to datacount do begin
if 收阳[i] AND 放量[i] then
得分[i]:=2;
else IF 收阳[i] AND 缩量[i] then
得分[i]:=1;
else IF 收阴[i] AND 放量[i] then
得分[i]:=-2;
else IF 收阴[i] AND 缩量[i] then
得分[i]:=-1;
end;

五日得分:sum(得分,5),linethick0;
STICKLINE(五日得分<0,0,五日得分,4,0),COLORGREEN;
STICKLINE(五日得分>0,0,五日得分,4,0),COLORRED;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址