• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

2个进\拉字样同时出现的选股公式

常见公式 第一股票指标公式网 4周前 (10-31) 9次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

选股条件一:日线上,进\拉字样同时出现,股价站在5日线之上;
选股条件二:在某股前20个交易日之内(只要是20天之内,如前10天、前19天都可以)的日线,进\拉字样同时出现;

源码如下:

LC:=REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;
空头:CROSS(85,RSI1)*30;
DRAWTEXT(CROSS(85,RSI1),80,’顶’);
Varb:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
Varc:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
Vard:=BARSCOUNT(CLOSE);
多头:(Varb< 20 AND Varc< 25 AND Vard> 50 AND AR<70 AND VOL<VOL[1] AND VOL[1]<VOL[2] AND VOL[2]<VOL[3])*30;
DRAWTEXT(CROSS(RSI1,25),-100,’进’);
做多:EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;
做空:EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
DRAWTEXT(CROSS(做多,做空) AND 做多<-10,-60,’拉’);
DRAWICON(CROSS(做多,做空) AND 做多<-10 AND 做空>REF(做空,1) OR CROSS(做多,做空) AND 做空<-35 ,-15,2);
DRAWTEXT(CROSS(RSI1,20)AND 做空<-20 AND 多头 ,-60,’进’);
 


解答如下:
SELECT CROSS(RSI1,25) and CROSS(做多,做空) AND 做多<-10;
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址