• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把下面公式改写成选股公式

常见公式 第一股票指标公式网 3周前 (10-31) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

帮我把下面的指标改成选股公式,股友提问要求三十分钟K线图中猎庄大于0时,或者三十分钟K线图中猎庄大于底部时选出股票,谢谢啦!

A1:3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:EMA(A1,5),LINETHICK1,COLOR6600FF;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)),LINETHICK0,COLOR00FF00;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;

DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A2<0,7),黑马线,’跑’),COLOR00FF00;

DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,15,’大黑马’);
底部:(A2<-10 AND A2>REF(A2,1))*25,colorred;
DRAWICON(底部 AND A3>REF(A3,1),25,4);
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0;
大势已去:IF(CROSS(黑马线,A1)AND 黑马线>70 AND 趋势线>80,90,100),COLORFF0000;
强弱:50,POINTDOT;

VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),15,1)/SMA(MAX(LOW-VAR1,0),10,1),LINETHICK2;
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
猎庄:IF(VAR5>REF(VAR5,1),VAR5,0),COLORLIRED,POINTDOT,LINETHICK5;
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,3,0 ),colorred,POINTDOT,LINETHICK2;

强弱分界线:20,colorgreen;
N1:=21;
VAR1A:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2A:=SMA(VAR1A,9,1)+100;
VAR3A:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4A:=SMA(VAR3A,3,1);
VAR5A:=SMA(VAR4A,3,1)+100;
VAR6A:=VAR5A-VAR2A;
端庄窝:=IF(VAR6A>N1,VAR6A-N1,0),COLORLIRED;
果断出击:IF(CROSS(端庄窝,0.01),30,0),STICK,colorgreen,LINETHICK2;
DRAWICON(果断出击>0,30,1),colorgreen;

RSV55:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*80;
K55:=SMA(RSV55,3,1);
资金线:SMA(K55,3,1),colorred,LINETHICK2;
WRA:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*100;
WR1:=SMA(WRA,3,1);

RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K9:=SMA(RSV9,3,1);
D9:=SMA(K9,3,1);
快速短线:3*K9-2*D9,COLORAAAACC,LINETHICK1;
RSV21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K21:=SMA(RSV21,13,1);
D21:=SMA(K21,3,1);
DRAWTEXT((D21-REF(D21,1))>0,D21,’·’),coloryellow,POINTDOT,
LINETHICK3;
DRAWTEXT((D21-REF(D21,1))<0,D21,’·’),colorblue,POINTDOT,LINETHICK3;
-5,colorwhite;
强势线:50,COLOR4080FF,POINTDOT;
80,POINTDOT,COLORAAAAAA;
100,COLORAAAAAA;
强势线1: -20,COLOR4080FF,POINTDOT


解答如下:
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),15,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:EMA(IF(LOW<=VAR4,VAR3,0),3);
XG:VAR5>REF(VAR5,1)
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址