• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

(波段副图)编选股公式

常见公式 第一股票指标公式网 1个月前 (10-31) 10次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

 

请老师编个选股公式,条件为红箭头出现。谢谢!

天线:80,COLORRED;
地线:20,COLORGREEN;
HQ0:=IF(ZIG(MA((H+L)/2,3),5)>REF(ZIG(MA((H+L)/2,3),5),1),1,0);
STICKLINE(HQ0=1,0,0.5,1,0),COLORRED;
STICKLINE(HQ0=1,100,99.5,1,0),COLORRED;
STICKLINE(HQ0=0,0,0.5,1,0),COLORGREEN;
STICKLINE(HQ0=0,100,99.5,1,0),COLORGREEN;
LOWV:=LLV(LOW,9);
HIGHV:=HHV(HIGH,9);
RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);
F:EMA(RSV,3),COLORWHITE;
S:MA(F,3),COLORYELLOW;
买进:0,COLORMAGENTA;
悬崖:0,COLORLIBLUE;
止损:0,COLORYELLOW;
RSVZ:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
PKZ:=SMA(RSVZ,5,1);
PDZ:=SMA(PKZ,6,1);
PJZ:=3*PKZ-2*PDZ;
LC:=REF(CLOSE,1);
VSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
LX:=DATATYPE;
ZQ:=IF(LX=4,4,IF(LX=3,4,IF(LX=1,8,4)));
DXW:=IF((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),1,0);
DXWMC:=IF((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),1,0);
MR1:=SUM(DXW,ZQ);
ZS2:=IF(MR1>0,1,0);
RSV1:=(CLOSE – LLV(LOW,18))/(HHV(HIGH,18) – LLV(LOW,18))*100;
K1:=EMA(RSV1,3);
D1:=EMA(K1,3);
J1:=(3*K1-2*D1);
KDJ1:=REF(COUNT(J1<REF(J1,1),5)>=3,1) AND REF(J1,1)<20;
KDJ2:=J1>REF(J1,1);
FZ:=SUM(IF(FILTER(KDJ1 AND KDJ2,3),30,0),ZQ);
ZS3:=IF(FZ>0,1,0);
MD1:=ZS2 AND ZS3;
TYP:=(HIGH+LOW+CLOSE)/3;
AZZ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
ZBPD:=CROSS(F,S) OR CROSS(AZZ,-100);
MR:=MD1 AND ZBPD;
XSZQ:=IF(DATATYPE=4,3,4);
DYC:=FILTER(MR,XSZQ);
STICKLINE(MR AND DYC,0,35,1,0),COLORMAGENTA;
DRAWICON(DXW,10,4);
底部:IF(CLOSE<MA(L+(H-L)/2,25)*0.95,1,0),COLORMAGENTA;
STICKLINE(底部,0,5,5,1),COLORMAGENTA;
HSL:=(VOL/CAPITAL)*100;
ZF:=(ABS(CLOSE-OPEN)/REF(CLOSE,1))*100;
ZHB:=(ZF/HSL)*100;
ZHB10:=MA(ZHB,10);
NOSL:=IF((VOL>REF(MA(VOL,3),1)*0.8),1,0);
ZX:=OPEN+(CLOSE-OPEN)/2;
ZXMAX:=HHV(ZX,10);
YH1:=BARSLAST(DXW);
YH2:=BARSLAST(DXWMC);
DQPD:=IF(YH2=0,1,IF(YH1>YH2,0,1));
GD1:=IF(PJZ>=100,1,0);
GD2:=COUNT(PJZ>=100,3);
GDCS:=IF(GD2>0,1,0);
KDJPD:=IF(GD1 OR GDCS,1,0);
RS2:=IF(VSI1>=80,1,0);
RS3:=COUNT(VSI1>=80,3);
RSICS:=IF(RS3>0,1,0);
RSIPD:=IF(RS2 OR RSICS,1,0);
ZBPD1:=IF(KDJPD AND VSI1>60,1,0);
ZBPD2:=IF(RSIPD AND PJZ>80,1,0);
ZBPD0:=ZBPD1 OR ZBPD2;
ZHBMAX:=HHV(ZHB10,5);
TD2:=IF(ZX=ZXMAX AND ZHB10<ZHBMAX,1,0);
TD3:=IF(DQPD AND TD2 AND NOSL,1,0);
TD33:=IF(ZBPD0 AND TD3,1,0);
SD1:=FILTERX(TD33,4);
STICKLINE(TD33 AND SD1,100,70,1,0),COLORLIBLUE;
顶部:IF(HIGH>MA(L+(H-L)/2,25)*1.15,1,0),COLORCYAN;
STICKLINE(顶部,100,95,5,1),COLORCYAN;
ZS:=CROSS(S,F) OR CROSS(100,AZZ);
ZS11:=IF(ZS,SUM(DXWMC,ZQ),0);
ZS22:=IF(ZS11>0,1,0);
DYC1:=FILTER(ZS22,XSZQ);
STICKLINE(ZS22 AND DYC1,100,70,1,0),COLORYELLOW;
DRAWICON(DXWMC,90,5);
A:=(3*C+L+O+H)/6;
XX:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
CB:=EMA(XX,13);
CBMA:=MA(CB,30);
KA:=(CBMA-REF(CBMA,5))/5;
∠A:=INTPART(ATAN(KA)*100);
RSV2:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;
K:=SMA(RSV2,5,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
ZLX:=EMA(J,6);
ZLXMA:=MA(ZLX,10);
KB:=(ZLXMA-REF(ZLXMA,5))/5;
∠B:=ATAN(KB);
强势:IF(∠A>=0 AND ∠B>0,1,0),COLORRED;
中强:IF(∠A>=0 AND ∠B<0,1,0),COLORLIRED;
稍强:IF(∠A<0 AND ∠B>0,1,0),COLORYELLOW;
弱势:IF(∠A<0 AND ∠B<=0,1,0),COLORGREEN;
 

 
解答如下:
{zig未来函数慎用!}
(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3));
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址