• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式等股票软件指标公式源码

立桩量主图求改为同花顺可用

常见公式 第一股票指标公式网 11个月前 (11-01) 79次浏览 已收录 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

源码如下:
BBI:(MA(CLOSE,M1)+MA(CLOSE,M2)+MA(CLOSE,M3)+MA(CLOSE,M4))/4;
IF(BBI>REF(BBI,1),BBI,DRAWNULL),COLORRED,LINETHICK2;
IF(BBI<REF(BBI,1),BBI,DRAWNULL),COLORYELLOW,LINETHICK2;
线上阳线买:0,NODRAW;线下阴线卖:0,NODRAW;

V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,1,0),COLORYELLOW;

水平面:MA(CLOSE,89),COLORFFA2FF;
高:=REF(HHV(H,N),M);
低:=REF(LLV(L,N),M);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
顶点:REFDATE(高,DATE),POINTDOT,LINETHICK2,COLORWHITE;
%19.8:REFDATE(H19,DATE),POINTDOT,LINETHICK2,COLORYELLOW;
%38.2:REFDATE(H38,DATE),POINTDOT,LINETHICK2,COLORGREEN;
%50:REFDATE(H中,DATE),POINTDOT,LINETHICK2,COLORRED;
%61.8:REFDATE(H61,DATE),POINTDOT,LINETHICK2,COLORMAGENTA;
%80.9:REFDATE(H80,DATE),POINTDOT,LINETHICK2,COLORBLUE;
低点:REFDATE(低,DATE),POINTDOT,LINETHICK2,COLORWHITE;
DRAWTEXT(ISLASTBAR,顶点,’顶点’),COLORWHITE;
DRAWTEXT(ISLASTBAR,低点,’低点’),COLORWHITE;

 

解答如下:
m:=120;//参数(1,555,120)调节低点周期
n:=250;//参数(1,555,250)调节高点周期
DRAWGBKLAST(CLOSE>0,STRIP(RGB(150,70,70),RGB(80,100,50),1));
BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
PARTLINE(BBI,BBI>REF(BBI,1),RGB(255,0,0),BBI<REF(BBI,1),RGB(255,255,0)),LINETHICK2;
V2:=IF(ISNULL(REFX(&CLOSE,1)),VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1);
STICKLINE(V2>=1,O,C,8,0),color007777;
STICKLINE(V2>=1,O,C,7,0),color009999;
STICKLINE(V2>=1,O,C,6,0),color00aaaa;
STICKLINE(V2>=1,O,C,5,0),color00bbbb;
STICKLINE(V2>=1,O,C,4,0),color00cccc;
STICKLINE(V2>=1,O,C,3,0),color00dddd;
STICKLINE(V2>=1,O,C,2,0),color00eeee;
STICKLINE(V2>=1,O,C,1,0),color00ffff;
t1:=BARSLAST(H=HHV(H,n));
t2:=BARSLAST(L=LLV(L,m));
高:=REF(HHV(H,t1+1),1);
低:=REF(LLV(L,t2+1),1);
H19:=高-(高-低)*0.191;
H38:=高-(高-低)*0.382;
H中:=高-(高-低)*0.5;
H61:=高-(高-低)*0.618;
H80:=高-(高-低)*0.809;
HORLINE(ISNULL(REFX(&CLOSE,1)),高,2,1);
HORLINE(ISNULL(REFX(&CLOSE,1)),H19,2,1);
HORLINE(ISNULL(REFX(&CLOSE,1)),H38,2,1);
HORLINE(ISNULL(REFX(&CLOSE,1)),H61,2,1);
HORLINE(ISNULL(REFX(&CLOSE,1)),H中,2,1);
HORLINE(ISNULL(REFX(&CLOSE,1)),H80,2,1);
HORLINE(ISNULL(REFX(&CLOSE,1)),低,2,1);
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),高,’高:’+TOSTRING(高,2)),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),H19,’0.809位:’+TOSTRING(H19,2)),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),H38,’0.618位:’+TOSTRING(H38,2)),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),H中,’中位:’+TOSTRING(H中,2)),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),H61,’0.382位:’+TOSTRING(H61,2)),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),H80,’0.191位:’+TOSTRING(H80,2)),COLOR009fff;
DRAWTEXT(ISNULL(REFX(&CLOSE,1)),低,’低位:’+TOSTRING(低,2)),COLOR009fff;
DRAWTEXT(CROSS(ISNULL(REFX(&CLOSE,60)),0.5),高*0.95,’提示:线上阳线买,线下阴线卖’),color00ffff;
水平面:MA(CLOSE,89),COLORFFA2FF,LINETHICK2;
DRAWTEXT(水平面<REF(水平面,1),水平面,’*’),color00ffff;
 

 


第一股票指标公式网(https://www.171415.com/)所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址