• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把这个成交量指标改成同花顺的

常见公式 第一股票指标公式网 3周前 (11-01) 8次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

V5:=MA(VOL,5);
V10:=MA(VOL,10);
V20:=MA(VOL,20);
LDAY1:=BARSLAST(CROSS(V5,V10));
LDAY2:=BARSLAST(CROSS(V5,V20));
LDAY3:=BARSLAST(CROSS(V10,V20));
LTJ1:=(LDAY1>LDAY2 OR LDAY1=LDAY2) {AND COUNT(CROSS(V5,V20),LDAY1)=1} AND LDAY2=0 AND V10<V20;
LTJ2:=(C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2) AND C>REF(C,2));
LTJ:=LTJ1 AND LTJ2;
LTJ0:=LTJ1 AND V10>REF(V10,1);
MA5:MA(C,5),COLORWHITE;
MA10:MA(C,10),COLORCYAN;
MA20:MA(C,20),COLORRED;
MA40:MA(C,40),LINETHICK2,POINTDOT,COLORBLUE;
MA60:MA(C,60),LINETHICK2,POINTDOT,COLORGREEN;
PDAY1 := BARSLAST(CROSS(MA5,MA60));{5日均线上穿60日均线}
PDAY2 := BARSLAST(CROSS(MA10,MA60));{10日均线上穿60日均线,至此形成鸭颈部}
{股票软件整理}
PDAY3 := BARSLAST(REF(HIGH=HHV(HIGH,PDAY2),1));{形成头部,要下跌}
PDAY4 := BARSLAST(CROSS(MA10,MA5){ OR (REF(MA10,1)<REF(MA5,1) AND MA5=MA10)});{下跌后,5日均线和10日均线死叉}
PDAY5 := BARSLAST(CROSS(MA5,MA10){ OR (REF(MA5,1)=REF(MA10,1) AND MA5>MA10)});{回落不久,5日均线和10日均线形成金叉,形成部}
A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;
A3:=MA5>MA60 AND MA10>MA60;
{JT:=CROSS(MA20,MA60) AND C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2);
CSFR:=CROSS(C,MA20) AND CROSS(C,MA40) AND CROSS(C,MA60);
STICKLINE(JT,H,L,1,0),COLORYELLOW;
STICKLINE(JT,O,C,8,0),COLORYELLOW;
STICKLINE(CSFR,H,L,1,0),COLORWHITE;
STICKLINE(CSFR,O,C,8,0),COLORWHITE;
DRAWTEXT(CSFR,H,’出水芙蓉’),COLORYELLOW;
DRAWTEXT(JT ,L, ‘价托’),COLORRED;}
CSFR:=CROSS(C,MA20) AND CROSS(C,MA40) AND CROSS(C,MA60);
YDAY1:=BARSLAST(CROSS(MA5,MA10));
YDAY2:=BARSLAST(CROSS(MA5,MA20));
YDAY3:=BARSLAST(CROSS(MA10,MA20));
YJZZ:=(YDAY1=YDAY2 AND YDAY2=YDAY3 OR (YDAY1-YDAY2=1 OR YDAY2-YDAY3=1)) AND REF(MA5,2)<REF(MA10,2) AND REF(MA10,2)<REF(MA20,2) AND MA5>MA10 AND MA10>MA20 ;
YJZZ1:=YDAY1=YDAY2 AND YDAY2=YDAY3 AND MA5>MA10 AND MA10>MA20 AND YDAY1=1;
YJT:=YDAY1>=YDAY2 AND YDAY2=0 AND MA10<MA20;
DAY1:=BARSLAST(CROSS(MA20,MA40));
DAY2:=BARSLAST(CROSS(MA20,MA60));
DAY3:=BARSLAST(CROSS(MA40,MA60));
TJ0:=DAY1>=DAY2 AND DAY3<5;
短顶:MA(REF(HHV(H,40),1),1);
头顶:MA(REF(HHV(H,60),1),1);
年顶:MA(REF(HHV(H,0),1),1),LINETHICK2,POINTDOT,COLORWHITE;
JZZ:=DAY1=DAY2 AND DAY2=DAY3 AND REF(MA20,1)<REF(MA40,1) AND REF(MA40,1)<REF(MA60,1) AND MA20>MA40 AND MA40>MA60;
TJ1:=DAY1>=DAY2 AND COUNT(CROSS(MA20,MA60),DAY1)=1{AND (DAY1-DAY2)<10};
TJ2:=C>O AND CROSS(C,头顶);
TJ21:=C>O AND CROSS(C,短顶);
{TJ22:=C>O AND CROSS(C,年顶) AND VOL<V5;换手率小12%}
TJ3:=VOL>REF(VOL,1);
TJ4:=MA20>MA60 AND MA40>REF(MA40,1) AND MA40<MA60;
TJ5:=DAY1>=DAY2 AND DAY2=0 AND MA40<MA60;
{TJ:=(TJ2 AND TJ3) OR (TJ21 AND TJ3);}
TJ:=DYNAINFO(4)>0
AND HHV(HIGH,10)/LLV(LOW,10)<1.25
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)
AND CLOSE>OPEN
AND CLOSE>=HHV(HIGH,10);
STICKLINE(LTJ0,H,L,1,0),COLORGREEN;
STICKLINE(LTJ0,O,C,8,0),COLORGREEN;
STICKLINE(TJ,H,L,1,0),COLORYELLOW;
STICKLINE(TJ,O,C,8,0),COLORYELLOW;
{STICKLINE(TJ22,H,L,1,0),COLORYELLOW;
STICKLINE(TJ22,O,C,8,0),COLORYELLOW;}
STICKLINE(LTJ,H,L,1,0),COLORRED;
STICKLINE(LTJ,O,C,8,0),COLORRED;
STICKLINE(CSFR,H,L,1,0),COLORWHITE;
STICKLINE(CSFR,O,C,8,0),COLORWHITE;
DRAWTEXT(CSFR,H,’出水芙蓉’),COLORYELLOW;
DRAWTEXT(TJ,L-0.2, ‘放量突破’),COLORRED;
{DRAWTEXT(TJ22,H+0.2, ‘轻松过顶’),COLORWHITE;}
DRAWTEXT(LTJ,H+0.5,’量托+多方炮’),COLORYELLOW;
DRAWTEXT(LTJ0,H+0.5,’量托’),COLORYELLOW;
DRAWTEXT(TJ5,MA60-0.2,’季价托’),COLORYELLOW;
DRAWTEXT(YJT,MA20-0.5,’月价托’),COLORYELLOW;
DRAWTEXT(JZZ,MA60-0.2,’金蜘蛛’),COLORYELLOW;
DRAWTEXT(YJZZ OR YJZZ1,MA20-0.2,’月金蜘蛛’),COLORYELLOW;
老鸭头:=(A1 AND A2 AND A3) AND FILTER(A1 AND A2 AND A3 ,5);
DRAWTEXT(老鸭头,L,’老鸭头’),COLORGREEN;
STICKLINE(老鸭头,H,L,0.5,0),COLORGREEN;
STICKLINE(老鸭头,O,C,6,1),COLORGREEN,LINETHICK3;(
 
 
解答如下:
V5:=MA(VOL,5);
V10:=MA(VOL,10);
V20:=MA(VOL,20);
LDAY1:=BARSLAST(CROSS(V5,V10));
LDAY2:=BARSLAST(CROSS(V5,V20));
LDAY3:=BARSLAST(CROSS(V10,V20));
LTJ1:=(LDAY1>LDAY2 OR LDAY1=LDAY2) AND LDAY2=0 AND V10<V20;
LTJ2:=(C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2) AND C>REF(C,2));
LTJ:=LTJ1 AND LTJ2;
LTJ0:=LTJ1 AND V10>REF(V10,1);
MA5:MA(C,5),colorwhite;
MA10:MA(C,10),colorcyan;
MA20:MA(C,20),colorred;
MA40:MA(C,40),LINETHICK2,POINTDOT,colorblue;
MA60:MA(C,60),LINETHICK2,POINTDOT,colorgreen;
PDAY1 := BARSLAST(CROSS(MA5,MA60));
PDAY2 := BARSLAST(CROSS(MA10,MA60));
//{股票软件整理}
PDAY3 := BARSLAST(REF(HIGH=HHV(HIGH,PDAY2),1));
PDAY4 := BARSLAST(CROSS(MA10,MA5));
PDAY5 := BARSLAST(CROSS(MA5,MA10));
A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;
A3:=MA5>MA60 AND MA10>MA60;
{JT:=CROSS(MA20,MA60) AND C>O AND REF(C,1)<REF(O,1) AND REF(C,2)>REF(O,2);
CSFR:=CROSS(C,MA20) AND CROSS(C,MA40) AND CROSS(C,MA60);
STICKLINE(JT,H,L,1,0),coloryellow;
STICKLINE(JT,O,C,8,0),coloryellow;
STICKLINE(CSFR,H,L,1,0),colorwhite;
STICKLINE(CSFR,O,C,8,0),colorwhite;
DRAWTEXT(CSFR,H,’出水芙蓉’),coloryellow;
DRAWTEXT(JT ,L, ‘价托’),colorred;}
CSFR:=CROSS(C,MA20) AND CROSS(C,MA40) AND CROSS(C,MA60);
YDAY1:=BARSLAST(CROSS(MA5,MA10));
YDAY2:=BARSLAST(CROSS(MA5,MA20));
YDAY3:=BARSLAST(CROSS(MA10,MA20));
YJZZ:=(YDAY1=YDAY2 AND YDAY2=YDAY3 OR (YDAY1-YDAY2=1 OR YDAY2-YDAY3=1)) AND REF(MA5,2)<REF(MA10,2) AND REF(MA10,2)<REF(MA20,2) AND MA5>MA10 AND MA10>MA20 ;
YJZZ1:=YDAY1=YDAY2 AND YDAY2=YDAY3 AND MA5>MA10 AND MA10>MA20 AND YDAY1=1;
YJT:=YDAY1>=YDAY2 AND YDAY2=0 AND MA10<MA20;
DAY1:=BARSLAST(CROSS(MA20,MA40));
DAY2:=BARSLAST(CROSS(MA20,MA60));
DAY3:=BARSLAST(CROSS(MA40,MA60));
TJ0:=DAY1>=DAY2 AND DAY3<5;
短顶:MA(REF(HHV(H,40),1),1);
头顶:MA(REF(HHV(H,60),1),1);
年顶:MA(REF(HHV(H,0),1),1),LINETHICK2,POINTDOT,colorwhite;
JZZ:=DAY1=DAY2 AND DAY2=DAY3 AND REF(MA20,1)<REF(MA40,1) AND REF(MA40,1)<REF(MA60,1) AND MA20>MA40 AND MA40>MA60;
TJ1:=DAY1>=DAY2 AND COUNT(CROSS(MA20,MA60),DAY1)=1;
TJ2:=C>O AND CROSS(C,头顶);
TJ21:=C>O AND CROSS(C,短顶);
TJ3:=VOL>REF(VOL,1);
TJ4:=MA20>MA60 AND MA40>REF(MA40,1) AND MA40<MA60;
TJ5:=DAY1>=DAY2 AND DAY2=0 AND MA40<MA60;
{TJ:=(TJ2 AND TJ3) OR (TJ21 AND TJ3);}
TJ:=O>0
AND HHV(HIGH,10)/LLV(LOW,10)<1.25
AND REF(CLOSE,1)<(LLV(LOW,15)+(HHV(HIGH,15)-LLV(LOW,15))*0.85)
AND CLOSE>OPEN
AND CLOSE>=HHV(HIGH,10);
STICKLINE(LTJ0,H,L,1,0),colorgreen;
STICKLINE(LTJ0,O,C,8,0),colorgreen;
STICKLINE(TJ,H,L,1,0),coloryellow;
STICKLINE(TJ,O,C,8,0),coloryellow;
STICKLINE(LTJ,H,L,1,0),colorred;
STICKLINE(LTJ,O,C,8,0),colorred;
STICKLINE(CSFR,H,L,1,0),colorwhite;
STICKLINE(CSFR,O,C,8,0),colorwhite;
DRAWTEXT(CSFR,H,’出水芙蓉’),coloryellow;
DRAWTEXT(TJ,L-0.2, ‘放量突破’),colorred;
DRAWTEXT(LTJ,H+0.5,’量托+多方炮’),coloryellow;
DRAWTEXT(LTJ0,H+0.5,’量托’),coloryellow;
DRAWTEXT(TJ5,MA60-0.2,’季价托’),coloryellow;
DRAWTEXT(YJT,MA20-0.5,’月价托’),coloryellow;
DRAWTEXT(JZZ,MA60-0.2,’金蜘蛛’),coloryellow;
DRAWTEXT(YJZZ OR YJZZ1,MA20-0.2,’月金蜘蛛’),coloryellow;
老鸭头:=(A1 AND A2 AND A3) AND FILTER(A1 AND A2 AND A3 ,5);
DRAWTEXT(老鸭头,L,’老鸭头’),colorgreen;
STICKLINE(老鸭头,H,L,0.5,0),colorgreen;
STICKLINE(老鸭头,O,C,6,1),colorgreen,LINETHICK3;

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (1)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址