• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

分时指标

常见公式 第一股票指标公式网 3周前 (11-02) 5次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

分时指标请老师优化下 把分时指标1 阻力 支撑 上顶 下底 改掉, 用 愿赌服输分时放进去

分时指标1源码
AAA:=MAX(DYNAINFO(3),DYNAINFO(5));
BBB:=MIN(DYNAINFO(3),DYNAINFO(6));
CCC:=AAA-BBB;

中轨:=(AAA+BBB)/2,COLOR999900;
DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*500/EMA(CLOSE,26);
DEAA:=EMA(DIFF,9);MACD:=(DIFF-DEAA)/4;
STICKLINE(MACD>=REF(MACD,1)AND MACD<=0,中轨,中轨+MACD,2,1),COLOR009999;
STICKLINE(MACD>REF(MACD,1)AND MACD>=0,中轨,中轨+MACD,2,1),COLOR0000DD;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,中轨,中轨+MACD,2,0)COLORDDDD00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,中轨,中轨+MACD,2,0),COLORDDDD00;

阻力:BBB+CCC*7/8,COLOR00DD00,LINETHICK2;
支撑:BBB+CCC*1/8,COLORRED,LINETHICK2;
上顶:BBB+CCC*2/3,COLORMAGENTA,LINETHICK1.7;
下底:BBB+CCC/3,COLORBLUE,LINETHICK1.7;
现价:C,COLOR00FFFF,LINETHICK2;

 

{愿赌服输分时}
A1:=AMOUNT/VOL/100;
A2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
A3:=SUM(AMOUNT,40)/A1/100;
A4:=SUM(AMOUNT,80)/A1/100;
B1:=DMA(A2,VOL/A3);
B2:=DMA(A2,VOL/A4);
B3:=(CLOSE-B1)/B1*100;
B4:=(CLOSE-B2)/B2*100;
控盘:1,COLORYELLOW,LINETHICK1;
高点:5,,COLORFF6600;
风险:-1,COLORGREEN,LINETHICK2;
低点:-4,COLORCCFF33;
现价:C,NODRAW;
均价:SUM(现价*V,240)/SUM(V,240),COLORYELLOW,NODRAW;
回调认同:EMA(EXPMA(C,20),13),NODRAW;
分时压力:MA(REF(HHV(C,30),1),2),NODRAW;
分时支撑:MA(REF(LLV(C,30),1),2),NODRAW;
STICKLINE(FILTER(C,60)>0,高点,低点,0.5,0),COLORRED;
 

 
解答如下:
AAA:=MAX(DYNAINFO(3),DYNAINFO(5));
BBB:=MIN(DYNAINFO(3),DYNAINFO(6));
CCC:=AAA-BBB;
中轨:=(AAA+BBB)/2,COLOR999900;
DIFF:=(EMA(CLOSE,12)-EMA(CLOSE,26))*500/EMA(CLOSE,26);
DEAA:=EMA(DIFF,9);MACD:=(DIFF-DEAA)/4;
STICKLINE(MACD>=REF(MACD,1)AND MACD<=0,中轨,中轨+MACD,2,1),COLOR009999;
STICKLINE(MACD>REF(MACD,1)AND MACD>=0,中轨,中轨+MACD,2,1),COLOR0000DD;
STICKLINE(MACD<REF(MACD,1)AND MACD<0,中轨,中轨+MACD,2,0)COLORDDDD00;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,中轨,中轨+MACD,2,0),COLORDDDD00;
{愿赌服输分时}
A1:=AMOUNT/VOL/100;
A2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
A3:=SUM(AMOUNT,40)/A1/100;
A4:=SUM(AMOUNT,80)/A1/100;
B1:=DMA(A2,VOL/A3);
B2:=DMA(A2,VOL/A4);
B3:=(CLOSE-B1)/B1*100;
B4:=(CLOSE-B2)/B2*100;
控盘:1,COLORYELLOW,NODRAW;
高点:5,,COLORFF6600,NODRAW;
风险:-1,COLORGREEN,NODRAW;
低点:-4,COLORCCFF33,NODRAW;
现价:C,NODRAW;
均价:SUM(现价*V,240)/SUM(V,240),COLORYELLOW;
回调认同:EMA(EXPMA(C,20),13);
分时压力:MA(REF(HHV(C,30),1),2);
分时支撑:MA(REF(LLV(C,30),1),2);

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址