• 欢迎访问第一股票指标公式网,汇集目前最全,最新的各种股票公式,股票指标公式,公式下载等股票软件指标公式源码

把买卖不愁指标出现“买”字改成选股公式

常见公式 第一股票指标公式网 3周前 (11-02) 6次浏览 0个评论 扫描二维码

股友提问要求:

171415.com解答:

 网友求助:

买卖不愁指标源码如下:

{
简单说明:
1、主图融合了人家的三个原创指标(在此感谢原创,容我在此借鉴!):立体K线;变色趋势线;箱体。实际使用时参考三点:K线颜色(已在图顶上备注);大、小箱体的支撑与压力;收盘股价在蓝色趋势线上持股(趋势线的分叉与合龙都是一个波段的变化行为)!
2、副图中的黄色、绿色、粉红色竖线代表着主力的进场建仓;蓝色曲线代表股价的趋势(也可理解为主力的建仓或者背离,比方说“中兵光电”在2008年10月14日的时候蓝色趋势线值135.8,而收盘价是13.31,到2008年11月4日蓝色趋势线值150,却股价为11.68,明显形成一种背离,其实说穿了就是主力早就潜伏进去了,之后成为全市唯一一支最早解套的A股!);红色曲线代表资金强度,他代表两个意思:红线在蓝线上运行持股(上下两次交叉形成买点,比较放心);另一种意思代表主力的资金强度,往往当天资金强度突然变得很大也就意味着主力的最后疯狂---你也跟着撤吧!
以上几点是本人愚见,接受各位老师与坛友批评!---奉上源码,大智慧1用,主题自己命名,再次感谢原创者!
主图:
}
VarA:=IF(CLOSE>150,91.3,0.913);
箱体下沿:INTPART(CLOSE/VarA )*VarA,pointdot,linethick2,colorgreen;
箱体上沿:箱体下沿+VarA,,pointdot,linethick2,coloryellow ;
SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),EMA8,’拉升’),COLORFF00FF;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE – LC),0),3,1) / SMA(ABS((CLOSE – LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.96),’加仓’),COLORYELLOW;
DRAWTEXT(CROSS(88,RSI),(HIGH * 1.04),’卖’),COLORGREEN;
VAR2:=LLV(LOW,27);
VAR3:=HHV(HIGH,34);
VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;
注意买:=IF((VAR4<10),80,100);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;

MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买=1,5),LOW*0.96,’买’),COLORRED;
STICKLINE(C>REF(C,1),H,L,0,1),COLOR0000FF;
STICKLINE(C>REF(C,1),O,C,2,0),COLOR000055;
STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;
STICKLINE(C=REF(C,1),O,C,2,1),COLOR333333;
STICKLINE(C<REF(C,1),H,L,0,1),COLORFFFF00;
STICKLINE(C<REF(C,1),O,C,2,0),COLORFF0033;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORFF7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORFF9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORFFBB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORFFCC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORFFDD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORFFEE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORFFFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000DD;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000FF;
VAR9Q:=C= HHV(C,4)AND (REF(C,1)>=REF(C,2) OR REF(C,1)>=REF(C,3)) OR REF(C,1)=HHV(C,4) AND CLOSE>=REF(C,2) OR REF(C,2)=HHV(C,4) AND REF(C,3)=LLV(C,4) AND C>=REF(C,1) OR REF(C,3)=HHV(C,4) AND C>=REF(C,1) AND C>=REF(C,2);
红持:var9Q,color0000ff,LINETHICK0;
STICKLINE(VAR9Q,C,(O+C)/2,7,0),COLOR000055;
STICKLINE(VAR9Q,C,(O+C)/2,6,0),COLOR000066;
STICKLINE(VAR9Q,C,(O+C)/2,5,0),COLOR000077;
STICKLINE(VAR9Q,C,(O+C)/2,4,0),COLOR000099;
STICKLINE(VAR9Q,C,(O+C)/2,3,0),COLOR0000BB;
STICKLINE(VAR9Q,C,(O+C)/2,2,0),COLOR0000DD;
STICKLINE(VAR9Q,C,(O+C)/2,1,0),COLOR0000FF;
VARAQ:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);
粉变:varaQ,colorff99ff,LINETHICK0;
STICKLINE(VARAQ,C,(O+C)/2,7,0),COLORFF11FF;
STICKLINE(VARAQ,C,(O+C)/2,6,0),COLORFF33FF;
STICKLINE(VARAQ,C,(O+C)/2,5,0),COLORFF55FF;
STICKLINE(VARAQ,C,(O+C)/2,4,0),COLORFF77FF;
STICKLINE(VARAQ,C,(O+C)/2,3,0),COLORFF99FF;
STICKLINE(VARAQ,C,(O+C)/2,2,0),COLORFFBBFF;
STICKLINE(VARAQ,C,(O+C)/2,1,0),COLORFFDDFF;
VARBQ:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<>HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);
灰跌:varbQ,color888888,LINETHICK0;
STICKLINE(VARBQ,C,(O+C)/2,7,0),COLOR333333;
STICKLINE(VARBQ,C,(O+C)/2,6,0),COLOR555555;
STICKLINE(VARBQ,C,(O+C)/2,5,0),COLOR777777;
STICKLINE(VARBQ,C,(O+C)/2,4,0),COLOR999999;
STICKLINE(VARBQ,C,(O+C)/2,3,0),COLORBBBBBB;
STICKLINE(VARBQ,C,(O+C)/2,2,0),COLORDDDDDD;
STICKLINE(VARBQ,C,(O+C)/2,1,0),COLORFFFFFF;
VARCQ:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);
绿买:varcQ,color00ff00,LINETHICK0;
STICKLINE(VARCQ,O,(O+C)/2,7,0),COLOR003300;
STICKLINE(VARCQ,O,(O+C)/2,6,0),COLOR005500;
STICKLINE(VARCQ,O,(O+C)/2,5,0),COLOR007700;
STICKLINE(VARCQ,O,(O+C)/2,4,0),COLOR009900;
STICKLINE(VARCQ,O,(O+C)/2,3,0),COLOR00BB00;
STICKLINE(VARCQ,O,(O+C)/2,2,0),COLOR00DD00;
STICKLINE(VARCQ,O,(O+C)/2,1,0),COLOR00FF00;
VARDQ:=REF(C,1)=HHV(C,4) AND C<REF(C,2) OR (REF(C,2)=HHV(C,4) AND REF(C,1)>REF(C,3) OR REF(C,3)=HHV(C,4) AND REF(C,1)>REF(C,2)) AND REF(C,2)>=REF(C,4) AND C<REF(C,1);
蓝抛:vardQ,colorff9900,LINETHICK0;
STICKLINE(VARDQ,O,(O+C)/2,7,0),COLORFF1100;
STICKLINE(VARDQ,O,(O+C)/2,6,0),COLORFF3300;
STICKLINE(VARDQ,O,(O+C)/2,5,0),COLORFF5500;
STICKLINE(VARDQ,O,(O+C)/2,4,0),COLORFF7700;
STICKLINE(VARDQ,O,(O+C)/2,3,0),COLORFF9900;
STICKLINE(VARDQ,O,(O+C)/2,2,0),COLORFFBB00;
STICKLINE(VARDQ,O,(O+C)/2,1,0),COLORFFDD00;
CG:MA(C,17),COLORFF00FF;
FL:HHV(CG,2),COLOR00FF00;
FS:CG-(FL-CG),COLORFF0000;
AMV0:=VOL*(O+C)/2;
{
副图(一):
TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),N);
TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),N);
TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),N);
动力线:100*(TH*2+TQ)/(TL*2+TQ),colorRED;
趋势线:MA(动力线,M),colorBLUE;

副图(二):
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
主力进场:
STICKLINE(VAR5>REF(VAR5,1),0,VAR5,2,0 ),colorYELLOW;
主力进场阳:
STICKLINE(VAR5>REF(VAR5,1) AND C>O,0,VAR5,2,0 ),colorEE00EE;
Var6:=LLV(H,240);
Var7:=200*(C-Var6)/Var6;
弱势:STICKLINE(Var7<0,0,Var7,2,0),COLORgreen;
}

 
解答如下:
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
 

 


第一股票指标公式网所有股票公式及文章来源于网络仅供学习研究,请勿以此为依据进行股票交易。 版权投诉邮箱:313707241@qq.com 投放广告公式交流 QQ:313707241
喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论
表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址